Jump to content
Ultimaker Community of 3D Printing Experts

S5 pro bundle : 10 critical bugs in 3 hours


Recommended Posts

Posted · S5 pro bundle : 10 critical bugs in 3 hours

Hello,

 

@ Ultimaker Really, please, remove the PRO world in "S5 pro bundle" until the following bugs are not corrected

 

1- No way to exit a finished printing

After a finished print, there is no way to exit theses screens except a reboot (PS, the print was not started due to a unknow reason)

 

1-1.thumb.jpg.26366a6b5ec65851319b3152965cb258.jpg1-3.thumb.jpg.442be5a446fd05efb73086eb9ed51def.jpg

(items a grayed)

1-2.thumb.jpg.471a8921427fdb38d7b117ef4e95c9ca.jpg

 

2- Abusive purge

Each time a new part is printed, both print head are purged. The head move, front, back, too much material is purged. This is still true when using the latest fw (june 02). This consume time and money. When changing a print head, it seems that a quick purge is performed. This looks useless.

 

2.thumb.jpg.f0c977a73a67266c300a716a6ce5a4c0.jpg 

 

3- Multiple progess bar sometime running in reverse-time

Why 2 progess bars ? 

The text mention "may take 1 minute", but it took clearly more

 

3.thumb.jpg.e36c62016d66aa1194551e46bcd2e0b9.jpg

 

4- Freeze at "end of procedure"

What's happening ? => Reboot ! No way to escape this screen

4.thumb.jpg.9c099c51b8f4b20825d99aaa492cfcb3.jpg

 

5- Aborting bugs

When aborting a procedure supposed to take 1 minute after 10 minutes waiting, the screen freeze after clicking "yes"

5.thumb.jpg.7482b2536c1624e26243c9ec3d444b34.jpg

 

6- No way to remove a material

"Materiel in use" : First, this is wrong, nothing is printing. Then, all options are grayed, nothing available. Consequently the TPU is still present on the bowden tubes and no way to remove it and change material.

6.thumb.jpg.a668e1988359ee0c18157ff12f9e2db3.jpg

 

7- RFID tags detection not reliable

All slots excepted the B slot are Ultimaker official materials. The detection works 50% of the time (meaning the materiel is sometime not detected, sometime detected is the adjacent slot, sometime detected in 2 slots, even if an other materiel is already present is the adjacent slot).
This is a conception bug and I can NOT guess than Ultimaker never experienced this bug. Your RFID antennas are definitely wrongly placed.

You HAVE TO

- Stop to communicate that the materiel station is able to detect materials

- Provide a way to manually enter the good materiel (including ultimaker materials and not only generics)

7.thumb.jpg.f5db4e7c495d83d138eee23f7c09539c.jpg8.thumb.jpg.6f459906452a04fca8fa13e1b7898564.jpg

 

8- ?

Don't know what's happening. The PC i slot B is 90% full. Due to bugs 6 and 10 I still blocked at this point.

8.thumb.jpg.6f459906452a04fca8fa13e1b7898564.jpg

 

9- Outrageous ER sreens during updates

I updated to the latest fw because of to much ER61 or ER63 errors and I had a ER blocking screen during the update process. I supposed that the update process was working at background and leave the machine for minutes. The update process successfully ends but again there is something improve here.

 

10- No way do do things manually when shit happens

Compared to the S2 printer, this is a regression.

In this case, we just have to wait for the future release. We are not so patient.

 

11-Abusive boot time

If a machine can run for days without errors after boot, I'm ok to wait minutes for boot. If a machine requires recurrent boot then it have to boot fast. The S5 needs 2-3 minutes for boot, the lights are ON/OFF/ON/Dimming/OFF/ON, what's the hell, what is going on ?

I'm electronic engineer. My current development use an embedded linux-from-scratch on ARM processor, HDMI, USB, openGL and boot in 2 seconds. What does the S5 do ????

 

I loose 3 hours to NOT print anything with this quasi-new 10k€ printed supposed to be "pro".

 

What a deception.

 

 

  • Link to post
    Share on other sites
    Posted · S5 pro bundle : 10 critical bugs in 3 hours

    I certainly cannot comment on all your findings as some would require to be a firmware dev. But this information here might help to understand why things are as they are atm.

     

    1 - The printer is waiting for the heated bed to cool down. As soon as it is cold enough to touch you get the "confirm removal" button and can finish the process. The background here is a legal one: the machine has to be safe so removal should not be allowed if there is a risk to burn your fingers. Safety is part of professionalism - whether we like it or not in specific cases.

    You can speed it up on your own risk: Nobody and nothing prevents you from opening the doors, remove the hot plate and insert a cold glass plate.

     

    2 - A change from e.g. black to white filament or vice versa requires quite an amount of priming to ensure the old color is not mixed into the new print. Current firmware plays it safe here. Maybe Ultimaker will enhance it one day so it takes such things into consideration and offers specific priming amount (down to almost zero if the same material as in the last print is loaded).

     

    3 - The top bar represents the various steps in a wizard. The actual progress bar of a certain step is shown in the lower half of the screen.

     

    4 - I don't know how long you waited - the progress bars have some non-linearity sometimes. It could also be a bug in the firmware. However, I would recommend to switch the printer off, wait maybe 30s and switch it on again and check it again. This procedure is what I do after the first-time start-up wizard completed and after firmware upgrades. A proper re-initialization is certainly not a bad thing.

     

    5 - see 4

     

    6 - That looks to me as if loading and unloading of the material are available. If it does not work, there is a (bit ugly) work-around. Go to the printcore menu of the printcore in question and unload it. This triggers the material unload routine. But the printer is not in a good firmware state after this; you should reboot it.

     

    7 - Double recognition of NFC tags indeed happens sometimes. A good way to avoid / minimize the issue is to put Ultimaker spools in such a way into the bay that it is close to its left edge - for all spools!

     

    8 - Press on bay B and it should give you more information about what's wrong, no?

     

    9 - I would not be aware of a background firmware update while the printer is actually doing something. Maybe you started firmware update while there was still filament loaded (your point 6)? It might be a good strategy to first fix an error before upgrading the firmware.

     

    10 - Comparing the S5 Pro Bundle with a 2+ might not be a fair thing to do. Sure, both are Ultimaker 3D printers. But they are pretty different in terms of features and automatization. It's an old truth that a larger number of features usually gives a larger number of potential issues. Btw. I'm also often an impatient person. 😉

     

    11 - Yes, booting the Pro Bundle takes its time and as mentioned on top I'm not a developer so I cannot tell you what exactly the printer is doing and why it takes that amount of time. If you are interested in this you can dump the logs on an USB stick and have a look at the boot-up entries there.

     

    I hope the above helps you and others to get the best out of the Ultimaker S5 Pro Bundle as it presents itself at the moment.

    • Like 2
    • Thanks 3
    Link to post
    Share on other sites
    Posted · S5 pro bundle : 10 critical bugs in 3 hours

    Thanks @bonelli for reporting this, and thanks to @Dim3nsioneer for your detailed response.

    I've forwarded these concerns to the firmware team who I hope will come back to us about this soon!

  • Link to post
    Share on other sites
    Posted · S5 pro bundle : 10 critical bugs in 3 hours

    We're sorry to hear you're having trouble with your setup. Despite your troubles, thank you @bonelli for providing us with your feedback, we're always looking for ways to improve.

     

    When looking through the list it seems that at least some of the items are triggered by having material loaded to the print core, while the printer is not printing. This should not be the case. Material(s) are loaded upon printing and they should unload after printing. What would be interesting to know is what triggered this situation in the first place.

     

    It looks like for points 3, 4, 5, 6 there is indeed material loaded. If this is the case, I'll refer to http://ultimaker.com/er61 to get the machine in a normal state again.

     

    1. After a print we're waiting for the material unloading process, which removes the material without leaving a string behind. Depending on material, this can take a while. Also for safety purposes, the bed should cool down before "confirm removal" is shown.

     

    2. When changing materials before a print we're purging a safe amount so in the end the nozzle only contains the new material. When the same material is used, less material is purged. At the end of a print we also purge a bit, so we can ensure the tip of the material comes out right.

     

    3. The top progress bar is the wizard steps. The bottom progress bar is the current step. (As Dim3nsioneer also said in his comment). Is it true that material is still loaded when this happened? Normally you should be able to do the wizard very fast.

     

    (3?) 4, 5, 6 See top to get the machine in a normal state again. From the menus there is indeed no way to remove the material.

     

    7. We are aware of sometimes unreliable NFC reading, we are looking into ways to make NFC detection more reliable (within the given constraints). As Dim3nsioneer says: A good way to avoid / minimize the issue is to put Ultimaker spools in such a way into the bay that it is close to its left edge - for all spools!

     

    8. If the material is still loaded (and the printer is not printing) - follow the steps to get the machine in a normal state again. Slot B shows an End Of Filament. There are two possibilities that this can happen: No filament detect at funnel, or pulling the material while machine is on.

     

    9. Although we don't entirely understand how this could happen, our main suspect would be if you had a problem / error code before and rebooted the machine without physically fixing it. In this case the probability of the error popping up again after reboot is high. It's good practice to start an update when the machine is in a normal state.

     

    10. We hear you, we want to fix it for you. We are constantly trying to improve our processes. The Material Station is intended to (un)load automatically. In no way do we intend to block you from doing manual actions, like attach/detach bowden tubes, heating hotends, opening the feeder. It is however preferred if possible to turn off the machine while performing these actions.

     

    11. Agree that startup time can be improved. It's quite a complex software stack and initializing peripherals also takes time, but it has our attention.

     

    • Thanks 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...