Jump to content
Ultimaker Community of 3D Printing Experts

Plugin available on the Cura Marketplace but not on the Web Marketplace


Recommended Posts

Posted · Plugin available on the Cura Marketplace but not on the Web Marketplace

There is no separate review process.

 

It looks like your plugin is only marked to be compatible with Cura SDK version 7.2.0, and the Web Marketplace currently shows plugins that are compatible with Cura SDK version 7.0.0, instead of showing plugins that are compatible with 7.0.0, 7.1.0 and 7.2.0 (because all these plugins work with the current version of Cura).

  • Like 1
Link to post
Share on other sites
Posted · Plugin available on the Cura Marketplace but not on the Web Marketplace

Thank you @ahoeben, that totally explains it.

 

Verified that my plugin is compatible with SDK 7.0.0 and 7.1.0 and submitted a new version for review. That should make it available on the web interface as well. Thanks for your help!

  • Link to post
    Share on other sites
    Posted · Plugin available on the Cura Marketplace but not on the Web Marketplace

    We currently show all plugins compatible with SDK 7.1.0 (and 7.0.0 because those are compatible). I'll make sure it gets updated to 7.2.0 (which includes back to 7.0.0 in terms of compatibility) to reflect the most recent stable Cura.

     

    Edit: a fix is in the works that handles the SDK versioning in the web version of the Marketplace a bit differently so that it always automatically reflects the most recent stable Cura SDK version. This should prevent the problem from reoccurring in the future as well.

  • Link to post
    Share on other sites
    Posted · Plugin available on the Cura Marketplace but not on the Web Marketplace

    Question: What about showing the compatibility per plugin including all plugins that are compatible with newer Cura versions (maybe, those of the last half or full year; not only the latest)? Some users, especially in companies, might not upgrade every time a new Cura version comes out.

  • Link to post
    Share on other sites
    Posted · Plugin available on the Cura Marketplace but not on the Web Marketplace
    1 minute ago, Dim3nsioneer said:

    Question: What about showing the compatibility per plugin including all plugins that are compatible with newer Cura versions (maybe, those of the last half or full year; not only the latest)? Some users, especially in companies, might not upgrade every time a new Cura version comes out.

     

    Under the hood it already kinda works like this. Unless we do a breaking SDK change in Cura (causing the major version number to be bumped), all existing plugins on the same major SDK range are still compatible and will be shown. We try to reduce the amount of breaking SDK changes as much as possible (one, maybe twice, a year).

  • Link to post
    Share on other sites
    Posted · Plugin available on the Cura Marketplace but not on the Web Marketplace

    Certainly an new issue with the Web Marketplace. My analyse only the plugin with indicate "Brand" on the Left are display. But in the Cura Market place we have much more plugin

    brand.jpg

  • Link to post
    Share on other sites
    Posted · Plugin available on the Cura Marketplace but not on the Web Marketplace

    @Cuq It seems you are signed in and the Marketplace is filtered on verified (security-checked, Essentials plugins). Are you in fact an Essentials customer or is something going wrong there?

    • Like 1
    Link to post
    Share on other sites
    Posted · Plugin available on the Cura Marketplace but not on the Web Marketplace

    Ok without authentification I got all the plugin list.  So yes there is certainly an issue with my profil, I'm not supposed to be an essential customer or to have specified such option . Is it possible to modify this setting ?

    brand2.jpg

  • Link to post
    Share on other sites
    Posted · Plugin available on the Cura Marketplace but not on the Web Marketplace
    9 minutes ago, Cuq said:

    Ok without authentification I got all the plugin list.  So yes there is certainly an issue with my profil, I'm not supposed to be an essential customer or to have specified such option . Is it possible to modify this setting ?

     

    I'll make sure the operations team takes care of that asap.

    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...