Jump to content
Ultimaker Community of 3D Printing Experts

Where is the initial temperatue set in CURA?


Recommended Posts

Posted · Where is the initial temperatue set in CURA?

Near the beginning of every GCode file I produced with CURA is a section similar to this:

 

;Generated with Cura_SteamEngine 4.6.1
M140 S60
M105
M190 S60
M104 S200
M105
M109 S200
M82 ;absolute extrusion mode
; Ender 3 Custom Start G-code

(The last line shows is the first line of GCode from the printer's Start GCode)

 

The initial commands set the bed temperature to 60 and the extruder temperature to 200. But I can't find where in CURA the value of 60 is set.

 

There's no temperature setting that I can see in the printer settings.

 

I'm using Generic PLA, but in the Material settings the Bed Temperature is 50,  not 60. In the profile, the Material setting presumably is taken by default from the Material, and is also 50.

 

Obviously I could override the initial GCode with additional GCode in the printer start, for example, but if I want a lower temperature I'm not sure if it will wait and if I want a higher temperature I should just be able to set it at the start.

 

So where does the value 60 get set?

 

  • Link to post
    Share on other sites
    Posted · Where is the initial temperatue set in CURA?

    These are set in two places.

    1) These settings originally come from the material profiles. In the top of the screen, there's a menu bar with three sections. Click the middle section to reveal a window with a selection of material and nozzle size. Click the material and select a profile or click manage materials. Here you can create material profiles with custom settings.

    2) However, if you are experimenting in day to day use, it's probably more common to use a temperature setting override. Click the right part of the same menu bar. This reveals a window with settings for the layer height, infill, support and adhesion. In the bottom, click custom, and you will see a long list of settings you can change to override the profile, including bed and nozzle temperature. 

  • Link to post
    Share on other sites
    Posted · Where is the initial temperatue set in CURA?

    Hi Nitro2k01.

    As I explained, I've already looked at the Material profile for Generic PLA and in that the Default Build Plate Temperature is 50 degrees. There's no setting for temperature in the Printer profile and in the overall Profile the Build Plate Temperature and the Build Plate Initial Temperature both show 50.

    I know I can override it in the Profile, but what I want to know is where the initial value of 60 comes from which has been put into every GCode file I've sliced for the last 6 months.  Until today, I'd never changed any temperature setting in CURA so why has it been outputiing 60 and not 50.

     

    Where does the value 60 come from?

    Annotation 2020-06-12 000000.png

    Annotation 2020-06-12 002540.png

  • Link to post
    Share on other sites
    Posted · Where is the initial temperatue set in CURA?

    OK. The reason I was asking about this was that I wanted to change it earlier today and when I went looking for temperature settings all I could find was the value 50 when I expected to see 60.

     

    I've since set it to 70 in the Profile and tried reset to defaults (50) to confirm previous behaviour, so, of course, now it puts 50 in the GCode, which is what I'd expect.

     

    So I guess I'll never know where it was previously getting the 60 from!

  • Link to post
    Share on other sites
    Posted (edited) · Where is the initial temperatue set in CURA?

    I apologize for not reading the question properly and answering based on that.

     

    The only other way I can imagine that command being created is through the profile setting "build plate temperature initial layer" which is hidden by default. If that were the case, there should be a M140 S50 command later on in the G code.

     

    (Edit: Shown in your screenshot, but possibly overwritten by a profile change at that time.)

    Edited by nitro2k01
  • Link to post
    Share on other sites
    Posted (edited) · Where is the initial temperatue set in CURA?

    And also, besides checking for a second M140 command, this theory can be tested by looking for material_bed_temperature_layer_0 in the settings dump at the end of the G code file.

    Edited by nitro2k01
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker Transformation Summit
        Visit our virtual showroom and learn more about the Ultimaker ecosystem!
        • 14 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...