Jump to content
Ultimaker Community of 3D Printing Experts

Can't select any objects


Recommended Posts

Posted · Can't select any objects

Hallo,

 

I am having an issue for months now, I think since cura 4.2 or so, now just updated to cura 4.6.2, hoping this would finally work again, but it doesn't. Since I do not want to switch to another slicer, I am now seeking help here.


My issue is, that the only way I have to select an object is through the Object list on the lower left. clicking anywhere in the 3d view, no matter how clearly I click the object, it will deselect. Hence I cannot drag an object at all. When I want to move an object, I have to select it in the object list and manually type the coordinates. This kind of works. However, rotation is impossible, as there is nowhere I can enter an angle. So I end up starting a 3d program, loading the model, rotating it there and loading it back into cura. Not a very nice work flow. Other options like placing support blockers or so have of course also become unusable.

 

I am running Arch Linux with kernel 5.7.10, Python 3.8.4 and Cura 4.6.2 (this package https://www.archlinux.org/packages/community/any/cura/ ) on i3 tiling window manager. This issue now persists for months, while before it was always working.

 

I have no idea what the reason might be :-(

 

Hoping someone else encountered this and solved it somehow :-)

 

P.S. Generally it would be nice to be able to enter rotation angles instead of just being able to rotate through dragging.

  • Link to post
    Share on other sites
    Posted · Can't select any objects
    23 minutes ago, burtoogle said:

    If you run the AppImage from UM, does the mouse selection/interaction work as expected?

    yes, just check and it apparently does, but I can't use my printer definitions and so on, when running the AppImage, and generally would like to have an installed version 😞

     

    Is it possible that the arch package itself is faulty in some way?

  • Link to post
    Share on other sites
    Posted · Can't select any objects
    11 minutes ago, homernl82 said:

    Is it possible that the arch package itself is faulty in some way?

     

    I'm guessing it's because you're using Python 3.8.4 and, AFAIK, the Cura source from UM is still expecting Python 3.5.7.

  • Link to post
    Share on other sites
    Posted · Can't select any objects
    43 minutes ago, homernl82 said:

    but I can't use my printer definitions and so on, when running the AppImage

     

    side question: why not....?

    Does the AppImage not use the exact same configuration folder?

  • Link to post
    Share on other sites
    Posted · Can't select any objects

    Hmm, if that's the reason, there's probably no easy fix 😞

     

  • Link to post
    Share on other sites
    Posted · Can't select any objects
    1 minute ago, tinkergnome said:

     

    side question: why not....?

    Does the AppImage not use the exact same configuration folder?

    Apparently not. But probably just a matter of moving the files to the right place. Still not the preferred solution, but probably better than what I currently have.

  • Link to post
    Share on other sites
    Posted · Can't select any objects

    If you put the definition in ~/.local/share/cura/4.6/definitions it should pick it up just fine.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...