Jump to content
Ultimaker Community of 3D Printing Experts

Cura 4.7 crashes when opening STL file


Recommended Posts

Posted (edited) · Cura 4.7 crashes when opening STL file

I needed to reprint an STL I downloaded from Thingiverse last week (Hero Me Geb5 - Hero_Me_Gen5_Base_1.stl). It printed fine in 4.6.2.I had 4.7beta installed and it crashed, so I reloaded 4.6.2, which told me 4.7 was now released, so I downloaded that and installed it. It also crashes opening the same STL file.  I've told CURA to send a report each time.

 

I've currently got both 4.6.2 and 4.7 installed and 4.6.2 will load and slice this file, so the file itself is obviously not corrupted.

 

Is anyone else having trouble with 4.7 or could it be something specific to my set up. I'm running Windows 10 Pro Insider Preview version 20197.

 

Update: I'm using Nvidia GeForce drivers. 4.6.2 works fine and I've never had a problem with any previous version.

 

By the way, I find it amusing that every time I open 4.6.2 it tells me "Ultimaker Cura 4.7.0 provides a better and more reliable printing experience" when my experience is that it's crashed every time I've tried to use it.  

Edited by StarNamer
Mispelling
  • Link to post
    Share on other sites
    Posted (edited) · Cura 4.7 crashes when opening STL file

    Seriously same problem. I was stupid enough to delete all my “userdata” files to see if that was the problem. 
     

    I ended up recreating my profiles from scratch and it doesn’t work. So I had to go back to 4.6.2 and recreate my profiles there again. 
     

    I have both installed on the system as installing 4.6.2 doesn’t ask to remove a higher numbered version. I may as well remove 4.7 and keep using 4.6.2. 
     

    It crashes only upon opening an STL file. Windows is latest release version of 10. I believe version 2003 or whatever the May update was. 
     

    It happens with all files I’ve tried so it’s not the file. I can open and slice in 4.6.2. There is some output for the error it seemed to reference profiles. And someone mentioned deleting the Cura folder under your userdata worked in this situation on some other version of Cura. 

    Edited by sr1329
  • Link to post
    Share on other sites
    Posted · Cura 4.7 crashes when opening STL file

    Problems here as well, on a 4.7 clean install, worked ok for a few prints, then started crashing importing any stl I have, after changing a few small profile material settings and the theme.

    Using NVidia drivers here, on x86 Win.

    4.6.2 is fine and never had such an issue.

  • Link to post
    Share on other sites
    Posted · Cura 4.7 crashes when opening STL file
    Link to post
    Share on other sites
    Posted (edited) · Cura 4.7 crashes when opening STL file

    Reading to the end of the comments in issue 8230, it says it's the same issue as 8249, which is that the config parser has been replaced and obviously not tested very well! I found this the moment I tried 4.7beta so how come no one else testing the beta version picked it up?

     

    In my case, I used OctoLapse which requires having comments in the startup GCode like "; layer_height = {layer_height}" and Cura 4.7 crashes because there's an equals sign in the GCode (even though it's a comment!). So I currently have a choice of using Cura 4.7 or OctoLapse!

     

    From reading the comments about the change, I gather it was done to speed up startup from 2.5 seconds to 1.2 seconds. My vote would be that this isn't important. I'm about to do a 3D print which is going to take hours and you think I care about an extra second or two to start the slicer? I'd be more impressed if the speed of the slicing could be improved.

     

    So for a simple fix, can we have a version 4.7.1 with the old config parser or setting to switch between the two until someone can mend the new one? 

    Edited by StarNamer
    Typographical errors
  • Link to post
    Share on other sites
    Posted (edited) · Cura 4.7 crashes when opening STL file

    Thanks all - this fix worked for me: https://github.com/Ultimaker/Cura/issues/8235#issuecomment-682036305

    Easy enough to do and it works for me on Win and worked for a mate on Apple (there is no python35.zip on Mac, but the FastConfigParser.py(c) is in the install directory somewhere.)

    Edited by cods69
  • Link to post
    Share on other sites
    Posted · Cura 4.7 crashes when opening STL file
    On 8/28/2020 at 11:21 AM, StarNamer said:

    I found this the moment I tried 4.7beta so how come no one else testing the beta version picked it up?

    No idea 😞 It's also why i'm so frustrated with this issue.

     

    On 8/28/2020 at 11:21 AM, StarNamer said:

    From reading the comments about the change, I gather it was done to speed up startup from 2.5 seconds to 1.2 seconds. My vote would be that this isn't important. I'm about to do a 3D print which is going to take hours and you think I care about an extra second or two to start the slicer? I'd be more impressed if the speed of the slicing could be improved.

    That's your opinion. Unfortunately, it's not something that a lot of people agree with. The startup time is one of the things in Cura that most people complain about. Also note that the improvement was on my machine, which isn't a good indication for everyone (my boot times are already much shorter than what a lot of people report).

     

    On 8/28/2020 at 11:21 AM, StarNamer said:

    So for a simple fix, can we have a version 4.7.1 with the old config parser or setting to switch between the two until someone can mend the new one? 

    A patch version is on the way.

  • Link to post
    Share on other sites
    Posted · Cura 4.7 crashes when opening STL file

    I also have been having this issue for the past two weeks. I did delete my profiles and it started working. Today when I opened it up, I'm not sure why it suddenly started again, but it is back.

     

    Startup time is important, but not as important as it being able to open at all.

     

    Thanks for doing what you do, but this WAS reported in the beta, and understandably people are frustrated that it made it to a standard release.

     

    Keep up the good work.  Waiting for a patch.

  • Link to post
    Share on other sites
    Posted · Cura 4.7 crashes when opening STL file

    Just har this problem and googles this. even after removing the octolapse script from my printer machine settings I can’t load any stl files without crashing... which is strange 4.7 worked for a while before this crap started. and now I can’t fix the one file I need to fix. 

  • Link to post
    Share on other sites
    Posted · Cura 4.7 crashes when opening STL file

    Creating a new printer profile worked. which si weird, I copied the start script from a new profile into my old... so these two ar basically identical but one crashes.

  • Link to post
    Share on other sites
    Posted (edited) · Cura 4.7 crashes when opening STL file

    I wish they warned people about this KNOWN bug so thatan Octolapse user would just wait.

    Edited by sr1329
  • Link to post
    Share on other sites
    Posted · Cura 4.7 crashes when opening STL file
    9 hours ago, sr1329 said:

    I wish they warned people about this KNOWN bug so thatan Octolapse user would just wait.

    I wish we'd known this when releasing 4.7... Unfortunately we didn't, since apparantly no-one with octolapse tested the beta.


    But no worries, a patch is underway.

    • Like 1
    Link to post
    Share on other sites
    Posted · Cura 4.7 crashes when opening STL file

    So did 4.7.1 fix this?

  • Link to post
    Share on other sites
    Posted · Cura 4.7 crashes when opening STL file
    On 9/7/2020 at 7:22 PM, nallath said:

    I wish we'd known this when releasing 4.7... Unfortunately we didn't, since apparantly no-one with octolapse tested the beta.


    But no worries, a patch is underway.

     

    I signed up just to say thank you so much. 4.7.1 fixed this for me. Much appreciated!

    • Like 3
    Link to post
    Share on other sites
    Posted · Cura 4.7 crashes when opening STL file
    5 hours ago, vdhdesign said:

    I signed up just to say thank you so much. 4.7.1 fixed this for me. Much appreciated!

    Glad to hear 🙂

  • Link to post
    Share on other sites
    Posted · Cura 4.7 crashes when opening STL file

    I just want to say Thank you. My problem of stl opening crash got fixed by Cura 4.7.1.

     

    Thank you.

    • Like 1
    Link to post
    Share on other sites
    Posted (edited) · Cura 4.7 crashes when opening STL file

    I have a Creality Ender 3 Pro and usually use the Creality slicer.  Two days ago, I wanted to print in PETG so loaded up Cura 4.6.x to make use of the PETG profile built in.  I was promped to upgrade to 4.7.1, which I did.

     

    I loaded a file and printed it twice.  I later went to load the STL file again and Cura Crashed.  I did a little research and discovered this was a problem with 4.7, so I installed 4.6 again, which also wouldn't work.  I then decided to use Creality slicer, and it also wouldn't work.

     

    I monkeyed around for 2 days without any kind of success.  I then ACCIDENTALLY discovered that Cura would load STL files which were located in other folders.  It just wouldn't work from the downloads folder, which is where files from Thingiverse go by default.

     

    I now have Cura 4.7 installed again, and working well, as long as I don't try to load an STL from the downloads folder.

     

    Hopefully, somebody else will benefit from this discovery.

     

     

    Edited by prescove
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker Transformation Summit

        On April 20 - April 23 we will host the Ultimaker Transformation Summit. Come talk to us via Live chat and get inspired by any of our relevant presentations!
        • 6 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...