Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  

Problems with UM2 again.

Recommended Posts


My replacement UM2 was working flawlessly for some time, than I decided to try using the flexible PLA, which worked for some time and I printed a couple of designs fine.

A couple of days later I came back & tried printing & realized my extruder was blocked.

Flexible PLA is very nice but it sticks too well to the bed & you actually need to heat the bed a little to get it off, unlike PLA where its easy to remove onces it cools down. The other problem is that it's too sticky it blocks the extruder and its a pain to get it off.

So I tried a couple of times to clean it & it worked a little & than again stopped.

Now I was trying to heat the head to 250 hoping it might help and suddenly the ultimaker crashed with the ultimaker logo half showing on the LCD, so I switch it off from the back & now it won't come on at all, so it seems dead.

I contacted Sander on the 10 & 11th of December via PM asking for spare parts back when the extruder was blocked but I did not receive any reply until this day.

Now since the UM2 is completely dead I need to know how to send it back for replacement, or I don't even mind replacing the parts myself as long as I can order them.

They only sell parts for the original UM.

Hope someone from UM2 can contact me for help.


Share this post

Link to post
Share on other sites

Try disconnecting USB cable if connected. Then disconnect power cable from home power. Leave disconnected for a very long time - until the blue lights goes off. 20 minutes for me! If you turn on the UM2 while the "brick" is unplugged you should be able to get the light to go off in one second instead of 20 minutes.

Then turn off UM2, plug in the power brick and turn it back on.

Some power bricks have circuitry that won't reset until you power cycle them.


Share this post

Link to post
Share on other sites

i dont think this is the same situation.

but when i plugged in my ultimaker2 with usb. i started cura and clicked update firmware... of course my cura was still set for ultimaker 1 and uploaded the firmware for the um1 to my um2... that really shut down the whole printer... dead as a doodoo.

so i changed my cura to ultimaker2 and then reconnected usb cable and reinstalled the correct um2 firmware... then restarted and worked perfect !

maybe worth checking which firmware you loaded ?

Ian :-)


Share this post

Link to post
Share on other sites

No lights? No fans? Nothing? Not even a blue light on the power brick? It's starting to sound like your power brick is broken. Or maybe the electrical outlet you plugged it into.


Share this post

Link to post
Share on other sites

If it were me I would take the 2 screws off the bottom cover and remove it. Then trace the power cord and power switch and make sure when the power switch is on the power gets past the switch. I would test this using a meter. Then I would trace this signal to the main voltage regulator - a large part with 3 large pins. I would check to make sure the part generates 12V. But truly the problem is probably before this part because I think the 19V goes directly to the rear fan and so if the rear fan doesn't spin then something VERY SIMPLE is broken. I think. Possibly the switch. More likely a cable or connector right there where the power comes in.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • How to 3D print with reinforced engineering materials
      Ultimaker is hosting a webinar where we explain how you can achieve and maintain a high print success rate using these new reinforced engineering materials. Learn from Ultimaker's Product Manager of Materials and top chemical engineer Bart van As how you can take your 3D printing to that next level.
      • 0 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!