Jump to content
Ultimaker Community of 3D Printing Experts

Ultimaker S3 Digital Factory 'connect' button non-responsive

Recommended Posts

Posted (edited) · Ultimaker S3 Digital Factory 'connect' button non-responsive

hi! new to the UM fam. have a small farm of UMS3s for a higher-ed college. earlier today I put x5 machines on Digital Factory; they all appeared and I renamed them. One of them then went 'missing' (grey, circle-X) from Digital Factory. At this time the 'connect' button at Digital Factory menu is non-responsive. See: https://photos.app.goo.gl/KRcPcjdHgTk7KDBa7

I have attempted rebooting, Reset Digital Factory (via Settings), and Reset all printer settings (also via Settings) - I'm not sure what else to do, but the button is not responding I therefore cannot connect the printer to Digital Factory. Any thoughts?


Edited by qcmakerspace
feel free to delete thread - right after posting the machine went back on the network -- dang...
  • Link to post
    Share on other sites
    Posted · Ultimaker S3 Digital Factory 'connect' button non-responsive

    The video link is working for me. 

    One question, is the printer able to access the internet? 

    What happens when you try to check for new firmware updates?

  • Link to post
    Share on other sites
    Posted · Ultimaker S3 Digital Factory 'connect' button non-responsive

    Please export the printer logs via the touch screen settings menu and upload them here or send them to me via DM. Without those we can't really see what is going on.



    • Like 1
    Link to post
    Share on other sites
    • 2 weeks later...
    Posted · Ultimaker S3 Digital Factory 'connect' button non-responsive

    My work's UMS3 also had this problem when we purchased it. I tried everything I could to get it to work (different networks, ethernet, wifi, factory reset, cura connect reset, you name it) but ultimately the only thing that worked for me was to do a firmware recovery procedure with the help of my reseller. I first flashed to 5.3.10 then to 5.7.2 then I updated the firmware to 5.7.3 and I was able to get the digital factory code after rebooting the printer. If the above suggestions fail, I would ask your reseller to help you with that procedure (I did it myself all you need is a screwdriver and 45mins-1h).

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker Transformation Summit

        On April 20 - April 23 we will host the Ultimaker Transformation Summit. Come talk to us via Live chat and get inspired by any of our relevant presentations!
        • 6 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    • Create New...