Jump to content
Ultimaker Community of 3D Printing Experts

Cura 4.8 - how do I stop preheating?


Recommended Posts

Posted · Cura 4.8 - how do I stop preheating?

Here's the problem I am facing:
Every time I start a print using Cura sliced g-code, the bed preheats and then the nozzle preheats before the pre-print code is run.
My pre-print GCode does a full bed mesh checking using G29 (25 points), then homes once more, then prepares the actual print with a priming line etc.

During all this time, the nozzle is preheated by Cura and oozes filament pretty much everywhere.

I have found a setting called "Initial Printing Temperature" which I assume controls the initial temperature of the nozzle before the G-Code is being processed. Am I correct in my assumption? For example, if I set it to 100 degrees Celsius, would it mean that there's no more oozing and fully heated nozzle while pre-print GCode is being processed?

Thank you for your answers!

  • Link to post
    Share on other sites
    Posted (edited) · Cura 4.8 - how do I stop preheating?

    For a bed mesh check you want the bed and nozzle hot, otherwise it's pretty much useless since it won't count for heat expansion. When the nozzle is heating up, retract the filament a few milimeters by hand, that should do to stop oozing

    Edited by tricky2k
  • Link to post
    Share on other sites
    Posted · Cura 4.8 - how do I stop preheating?

    Actually the nozzle being hot or not won't matter at all, the expansion is very small. Furthermore, you only have to do it once.
    Mesh bed leveling helps in case the bed moves a tiny bit because of the springs and there is no need for nozzle to be hot at the time. The bed, yes, but not the nozzle.

    Other slicers don't preheat the nozzle if I tell them not to. Cura seems to add the M109 command before even processing the pre-print G-Code. So far I have resorted to editing the GCode every time and removing the offending part, but I want to find out whether that can be done through the slicer rather than manually.

     

    This is the part I am talking about:

     

    ;Generated with Cura_SteamEngine 4.8.0
    M140 S85
    M105
    M190 S85
    M104 S230
    M105
    M109 S230

     

     

    • Like 1
    Link to post
    Share on other sites
    Posted (edited) · Cura 4.8 - how do I stop preheating?

    That was the other thing I was going to tell you, to edit the gcode, but yes, it's annoying and not for noobs. Can M109 be modified in the Start GCODE in machine settings?

    Edited by tricky2k
  • Link to post
    Share on other sites
    Posted · Cura 4.8 - how do I stop preheating?

    Well that's the issue, the preheat GCode is inserted by Cura before the "Start G-Code" entries in Machine Settings.
    One thing I have done is dialing back the temperature to undo Cura's preheating, but there is still a little bit of filament buildup in the nozzle.

     

    Here's my Start G-Code:

     

    M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration
    M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate
    M204 P500.00 R1000.00 T500.00 ;Setup Print/Retract/Travel acceleration
    M205 J0.01 ;Setup Jerk
    M220 S100 ;Reset Feedrate
    M221 S100 ;Reset Flowrate
    M104 S120 ;Set temperature back to 120 degrees to mitigate Cura preheating
    G28 ;Home First
    G29 ;Create New Mesh
    M104 S{print_temperature}
    G28 ;Home
    M420 S1 Z2 ;Enable ABL using saved Mesh and Fade Height
    
    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up
    G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position
    M109 S{print_temperature}
    G1 X10.1 Y200.0 Z0.2 F1500.0 E15 ;Draw the first line
    G1 X12.4 Y200.0 Z0.2 F5000.0 ;Move to side a little
    G1 X12.4 Y20 Z0.2 F3000.0 E30 ;Draw the second line faster
    G10 ; Retract
    G1 X14.4 Y20 Z0.2 F5000.0 ; Move a little bit more to mitigate stringing
    G1 Z2.0 F3000 ;Move Z Axis up
    G1 X14.4 Y200 Z2.0 F5000.0 ; Move a little bit more to mitigate stringing
    G11; Unretract
    G92 E0 ;Reset Extruder

     

  • Link to post
    Share on other sites
    Posted · Cura 4.8 - how do I stop preheating?

      

    3 hours ago, war4peace said:

    M109 S{print_temperature}

    This is the wrong replacement pattern. Use this and Cura will not have to prepend its own preheat sequence for your extruder:

     

    M109 S{material_print_temperature}

    Similarly, include this to stop Cura from having to preheat the bed for you:

     

     

    M190 S{material_bed_temperature}
    • Like 1
    • Thanks 1
    Link to post
    Share on other sites
    Posted · Cura 4.8 - how do I stop preheating?
    2 hours ago, ahoeben said:

      

    This is the wrong replacement pattern. Use this and Cura will not have to prepend its own preheat sequence for your extruder:

     

    
    M109 S{material_print_temperature}

    Similarly, include this to stop Cura from having to preheat the bed for you:

     

     

    
    M190 S{material_bed_temperature}


    Thank you, that did the trick. Turns out I had the wrong variable. All good now, thanks again for fixing this!

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...