Jump to content
Ultimaker Community of 3D Printing Experts

Cannot select a Part


Recommended Posts

Posted · Cannot select a Part

I'm running Cura 4.8 on a Mac with Big Sur Ver 11.0.1.  When I first start Cura, all is well. (Works as expected) Typically, the problem appears after I print a part and then load a new part to be printed.  I cannot select any parts.  If I close Cura and restart, I'm back to normal for a while.  It happens as described but it has happened at other times too.  Cura is not locked up because I can right click and the menu drops down.

 

This is annoying! Any help would be greatly appreciated.

  • Link to post
    Share on other sites
    Posted · Cannot select a Part

    hmm, strange. I have the same versions, Cura 4.8 and macOS 11.0.1

    I also tried now to remove the objects and load something else, but I can still select the model on move it around.

     

    Will try it the next days if I get maybe the same problem when I keep running Cura for a longer time, but currently I cannot reproduce it.

     

    But I can remember we had a similar problem in the past. Cannot remember with which version, maybe it was when 4.0 was released and it was then fixed with the next version or so. 

     

    Do you use something special, like a 3DConnexion Cad mouse or something like that?

  • Link to post
    Share on other sites
    Posted · Cannot select a Part

    Just an idea with the 3DConnexion mouse. I don't think it is the reason, I have also one, but the 3DConnexion driver is still beta for Big Sur and I am not sure how deep the driver is integrated into the system.

     

    How long does it take until it happens? Just to know how long I have to play with it 🙂 

  • Link to post
    Share on other sites
    Posted · Cannot select a Part

    It's not consistent, but after loading a simple model, if I repeat Rotate, Move, Slice, Monitor, Preview, Prepare it will stop allowing me to select the model after a few loops.  I did this 3 times in about 5 minutes.

     

  • Link to post
    Share on other sites
    Posted · Cannot select a Part

    Ok, I will try and play tomorrow with it, maybe I can reproduce it also on my side.

  • Link to post
    Share on other sites
    Posted · Cannot select a Part

    So, I have seen now the same problem on my iMac. I sliced something on Friday and didn't closed Cura. Today I tried to select the object and got exactly the same problem. When I select the object in the object list in the left bottom and then click on the object, it gets deselected. After a Cura restart everything is fine now again.

     

    So I can reproduce it, but I guess it is hard to find the root cause for it when the failure is not permanent.

  • Link to post
    Share on other sites
    Link to post
    Share on other sites
    Posted · Cannot select a Part

    Thanks, I will post my experience there too.

  • Link to post
    Share on other sites
    Posted · Cannot select a Part

    Well that’s encouraging.  At least it’s not just a me problem. Thanks for your efforts in reproducing it.  

  • Link to post
    Share on other sites
    Posted · Cannot select a Part

    I get the same. I’m on macOS 11.0.1 and Cura 4.8. It happens frequently enough that I’ve gone back to using 4.7.1 unless I need something like the improved Arrange All Models function 

  • Link to post
    Share on other sites
    Posted · Cannot select a Part

    I am also having problems selecting objects. It usually happens consistently after I save the file, and I would have to restart the program to resolve it.

     

    Cura 4.8, MacOS 11.0.1

  • Link to post
    Share on other sites
    Posted · Cannot select a Part

    Reproducing this error the same way. Cura 4.8 & macOS 11.0.1. This is a fresh installation, without any profiles listed and all default settings. I saved, then had to quit and restart. Clearing the build plate and reloading the same or another file does not correct the problem.

  • Link to post
    Share on other sites
    Posted · Cannot select a Part

    Confirming, this problem is happening to me on version 4.7.1 as well.

  • Link to post
    Share on other sites
    Posted · Cannot select a Part

    I have the same problem, does anyone have any solution. I'm getting to work more or less using the app in low resolution, giving less problems.

  • Link to post
    Share on other sites
    Posted · Cannot select a Part

    Same here, after upgrading to Cura 4.8 on a Mac with Big Sur Ver 11.1.  Related, I can select via Edit / Select All Models, or ⌘A, but then can't use some tools that require a subsequent click / select (eg, Select face to align to the buildplate just deselects).

  • Link to post
    Share on other sites
    Posted · Cannot select a Part

    Hi all!
    I'm not claiming this answer as my own, but found this at https://community.ultimaker.com/topic/33478-cant-select-any-objects/ :
    "I have MacOS 11.0 - Cura 4.8 - and fixed it with - Adding Cura to "Security & Privacy" - "Privacy" - "Full Disk Access""
    I'm on 11.1, / 4.8. On applying the preference change, it worked for me.
    Enjoy!
    Mikey

    image.thumb.png.7edd03b478871c18dd2cf608ff10b5d3.png

    • Like 1
    Link to post
    Share on other sites
    Posted · Cannot select a Part

    Problem solved for me! Thanks a bunch, MarioPS! That was driving me nuts!

  • Link to post
    Share on other sites
    Posted · Cannot select a Part

    Full disk access helps a bit, it is much better, but I still see the problem from time to time.

  • Link to post
    Share on other sites
    Posted · Cannot select a Part

    I have the same problem too (cura 4.8, macbook pro Big Sur), full disk acces does not help.

    When I'v done some manipulations on a model, I can't select it anymore on the build table. When I select it in the list of models it seems selected but when I try to move it par example it gets deselected immediately .

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker Transformation Summit

        On April 20 - April 23 we will host the Ultimaker Transformation Summit. Come talk to us via Live chat and get inspired by any of our relevant presentations!
        • 14 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...