Jump to content
Ultimaker Community of 3D Printing Experts

Problem mit "Einzug aktivieren" in Cura


Ralf1071
 Share

Recommended Posts

Posted · Problem mit "Einzug aktivieren" in Cura

Hallo zusammen,

ich habe folgendes Problem. Wenn ich ein Objekt slice ohne die Funktion "Einzug aktivieren" zu benutzen, dann ist alles ok. Der G-Code ist fehlerfrei. Sobald ich aber die Funktion "Einzug aktivieren" benutze wird am ende des G-Codes noch "G1 F1500 E756.68779" eingefügt. Der E-Wert ist abhängig vom Objekt und ist je nach Objekt unterschiedlich. Was auch verwirrt, ist, obwohl der E-Wert positiv ist und der Extruder somit zusätzlich am Ende des Drucks die Menge an Kunststoff ausgeben müsste, er umgekehrt diese Distanz an Filament zurückziehen möchte. Ich habe 2 Dateien angehängt. Test1.gcode ohne der Funktion "Einzug aktivieren". Test2.gcode mit der Funktion "Einzug aktivieren". Der Fehlerhafte Eintrag ist in Zeile 25158

Test1.gcode Test2.gcode

  • Link to post
    Share on other sites

    Posted (edited) · Problem mit "Einzug aktivieren" in Cura

    Hallo

     

    Ich kann jetzt zwar nicht genau herauslesen was jetzt eigentlich der Fehler ist bzw. was der Drucker macht bzw. nicht machen soll.

     

    4 hours ago, Ralf1071 said:

    Der Fehlerhafte Eintrag ist in Zeile 25158

     

    Das glaub ich nicht das schaut nämlich richtig aus

     

    Aber dieser Code in deinen End-Script schaut Fehlerhaft aus:

    G1 E-2.0 F300; Kunststoff zurückziehen um ein kleksen zu vermeiden

     

    Du hast nämlich den absolut Extrusion Modus aktiviert (M82), das heißt wenn der Drucker das liest dreht er das ganze Filament von E756.68779 auf E-2.

    Ist das der Fehler was er macht???

    Ist aber in beiden Dateien gleich????

    Um das zu beheben musst du entweder vorher M83 = relative Extrusion Modus, rein schreiben:

    M83		; relative extrusion mode
    G1 E-2.0 F300	; Kunststoff zurückziehen um ein kleksen zu vermeiden

     

    Oder, deine E-Achse ab nullen:

     

    G92 E0
    G1 E-2.0 F300	; Kunststoff zurückziehen um ein kleksen zu vermeiden

     

    Ich würde die erste Variante empfehlen

     

    Gruß

    Edited by zerspaner_gerd
  • Link to post
    Share on other sites

    Posted · Problem mit "Einzug aktivieren" in Cura
    7 hours ago, zerspaner_gerd said:

    Hallo

     

    Ich kann jetzt zwar nicht genau herauslesen was jetzt eigentlich der Fehler ist bzw. was der Drucker macht bzw. nicht machen soll.

     

     

    Das glaub ich nicht das schaut nämlich richtig aus

     

    Aber dieser Code in deinen End-Script schaut Fehlerhaft aus:

    
    G1 E-2.0 F300; Kunststoff zurückziehen um ein kleksen zu vermeiden

     

    Du hast nämlich den absolut Extrusion Modus aktiviert (M82), das heißt wenn der Drucker das liest dreht er das ganze Filament von E756.68779 auf E-2.

    Ist das der Fehler was er macht???

    Ist aber in beiden Dateien gleich????

    Um das zu beheben musst du entweder vorher M83 = relative Extrusion Modus, rein schreiben:

    
    M83		; relative extrusion mode
    G1 E-2.0 F300	; Kunststoff zurückziehen um ein kleksen zu vermeiden

     

    Oder, deine E-Achse ab nullen:

     

    
    G92 E0
    G1 E-2.0 F300	; Kunststoff zurückziehen um ein kleksen zu vermeiden

     

    Ich würde die erste Variante empfehlen

     

    Gruß

    Danke für die schnelle Antwort,

    ja es war gestern einfach schon zu spät und ich hatte schon zu lange auf den Code geschaut. Ich habe dann den Wald vor lauter Bäumen nicht mehr gesehen :-).

    Der Fehler war, das er zum Schluss statt meinen eingestellten 2mm eben mehrere cm retract machte.

    Letztendlich hatte ich schon angefangen Fehler zu suchen wo gar keine sind und hatte genau das vergessen, das ja auf absolut-Werte eingestellt ist. Der fehlende Eintrag G92 E0 im End-Code wars schließlich, der alles durcheinander brachte. Der war mal drin und den musste ich am Wochenende aus versehen gelöscht haben als ich was anderes im End-Code ausprobierte. 

    Danke trotzdem für die schnelle Antwort,

     

    Gruß Ralf

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...