Jump to content
Ultimaker Community of 3D Printing Experts

z-offset after auto-leveling/rafting - z-level relative/absolut?


Recommended Posts

Posted · z-offset after auto-leveling/rafting - z-level relative/absolut?

Since days Im searching a bug I noticed at my printer:
After auto-leveling and printing the raft, My z-level is about 4.65mm.
Looks like my Gcode starts at this z-level, so Im missing the bottom.
Whats wrong?
Is it a cura-sertting?

For me it looks like after rafting there need to be done a z-level = 0. Or the model needs its z-level be relative, like: whereever you are (after rafting), go on, incremenz z and print.

77.jpg

  • Link to post
    Share on other sites
    Posted · z-offset after auto-leveling/rafting - z-level relative/absolut?

    Looking at both your gcode and the project file, I am still not quite sure what your problem is. Have you tried printing without a raft?

     

  • Link to post
    Share on other sites
    Posted · z-offset after auto-leveling/rafting - z-level relative/absolut?

    If your printhead is 4.65mm above the buildplate when it is done leveling, you should add a homing command after leveling so the printhead is at Z = 0.

  • Link to post
    Share on other sites
    Posted (edited) · z-offset after auto-leveling/rafting - z-level relative/absolut?

    Printing without raft is a bad idea at the moment....since my nozzle crashed into my BuildTak yesterday 😞

     

    Funny, my start g-code looks like:

    Quote

    G28 ; homing axis

    G29 ; bed leveling

    G1 Z15.0 F6000 ;Move the platform down 15mm

    ;Prime the extruder

    G92 E0

    G1 F200 E3

    G92 E0



    So I just have to swap G28 and G29?
    Just starting a test now 😉

    Edited by Trommelschlumpf
  • Link to post
    Share on other sites
    Posted · z-offset after auto-leveling/rafting - z-level relative/absolut?

    Right after homing (from the LCD or via a G28) and before the print head moves anywhere else, the display will show your Home Offsets.  Mine is X-1.00 Y-4.00 Z 0.00.  Your X and Y values will likely be different but your Z should be 0.  If some command has changed your Home Offset Z to a negative number then the print isn't starting on the bed, but in the air.  Within the Gcode file ";layer:0" is at Z1.4.  That sounds reasonable.

     

    You can slide the model on the build plate in Cura to print it in a different area of the build plate of the printer.

  • Link to post
    Share on other sites
    Posted (edited) · z-offset after auto-leveling/rafting - z-level relative/absolut?

    That didn't help 😞


    I just recorded a small video of the printer's behavior:

    https://youtu.be/vQkE3Z16EZI


    Also I uploaded an archive:
    [url=http://www.digitalinventions.de/files/temp/IronBot_Cura_Marlin_Problem_first_4.65mm.zip]http://www.digitalinventions.de/files/temp/IronBot_Cura_Marlin_Problem_first_4.65mm.zip[/url]

    This file contains:
    -Marlin-config
    -Marlin-config_adv
    -screenshot cura-settings for printer (like start/end gcode)
    -3d object I sliced and printed
    -M503 marlin printer status
    -3mf cura-project-file
    -gcode-file

     

    Might the z-height of my printer in the config-file be the problem? When probing, you can see the values on the display. But I couldn't see 4.65mm anywhere except the M503 status home-offset (see M503 file: home offset).

     

     

    Here's the Marlin threat for my printer:
    https://reprap.org/forum/read.php?415,878907,879958#msg-879958

     

    What else could I do?

     

     

     

    Edited by Trommelschlumpf
  • Link to post
    Share on other sites
    Posted · z-offset after auto-leveling/rafting - z-level relative/absolut?

    Nice video.  ("You do not have permission to access this document" when I tried the zip file link).

    In the video, once the raft is done printing your printer goes through the moves for the bottom of the box and for the draft shield, but does not extrude any plastic.  From the CFFFP gcode file you provided here is the transition between the top layer of the raft, and the first layer of the part:

    G1 X107.77 Y102.9 E892.07564  ;The last extrusion of layer:-3 is at Z=0.9 and is the top surface of the raft.
    G0 F600 X107.77 Y102.9 Z1.4     ;The Z moves to 1.4
    G0 F4200 X77.563 Y85.94
    ;TIME_ELAPSED:379.038926
    ;LAYER:0
    ;TYPE:WALL-INNER
    ;MESH:Spiral_Cube.stl
    G1 F3000 X77.713 Y85.94 E892.07748  ;Extrusion starts on the bottom of the cube at Z=1.4.  The air gap is .5 to make it easier to remove the part from the raft (at the cost of a poor finish on the bottom of the part).
    G1 X102.44 Y85.938 E892.37972

     

    So the printer should be pushing plastic but it doesn't appear to be.  The X and Y move to the proper points as described in the gcode, but the E is odd.  Or maybe it isn't.  In the settings section at the end of the gcode file it says you have Initial Layer Flow and Print Flow set to 70%.  Is there a reason for that?  The flow for a raft is very heavy, but a 70% flow into a .5 air gap may not be enough to get the plastic to stick to the raft.  It may be extruding but at such a slow rate that it looks like nothing is happening until finally it starts air printing.

  • Link to post
    Share on other sites
    Posted (edited) · z-offset after auto-leveling/rafting - z-level relative/absolut?

    Did you try to copy&paste the link? For me it's working on two devices without any problem...

     

     

    The extruder is working on the lost layers. But I set the flow to 70% because at 100% the gear is grinding the filament (until it's unable to move it any further) while the nozzle is closed by the raft.. 

     

    There is no air-printing. First it's printing the raft, then it slides on the top raft layer which prevents filament flow (imagine like the ironing feature) ...when z finally is greater than 4.65mm there is space for the filamentflow.

    But the extruder is always working.

     

    Parts printed on z > 4.65mm look fine. So on each of my prints the bottom 4.65mm are missing 😞

     

    Edited by Trommelschlumpf
  • Link to post
    Share on other sites
    Posted (edited) · z-offset after auto-leveling/rafting - z-level relative/absolut?

    In the video, all the moves are there.  I can see it move for the bottom of the part, then move over and do the draft shield, it just isn't pushing plastic.

    Let's go back.  #1 is to calibrate your E-steps.  In almost all cases the flow should be 100%.  Anything over 105 or under 95 indicates the calibration is off.

    When you send the printer M503, what are the numbers in the M206 line?  If you can't send M503 then with the LCD, Auto-Home the print head and check the numbers for XYZ on the LCD display.  What are they?

    Edited by GregValiant
  • Link to post
    Share on other sites
    Posted · z-offset after auto-leveling/rafting - z-level relative/absolut?

    In fact it IS pushing plastic - but the raft prevents filamentflow. Next video Ill add a third camera for the extruder 🤣

    When flow was 100% I could see the filament-hills around the nozzle...until there was no more filament coming out - because the 1.75mm was grinded to less than 0.5mm... so for the moment Im fine with 70% flow until my z-level problem is solved.

     

    After I power on the machine it says:
     

    16:04:57.723 > Marlin 2.0.7.2
    16:04:57.723 >
    16:04:57.723 > echo: Last Updated: 2020-10-15 | Author: CySign  
    16:04:57.725 > echo:Compiled: Dec 26 2020
    16:04:57.726 > echo: Free Memory: 3369  PlannerBufferBytes: 1200
    16:05:01.338 > DIGIPOTS Loading
    16:05:01.338 > DIGIPOTS Loaded 
    16:05:01.348 > DIGIPOTS Loading
    16:05:01.348 > DIGIPOTS Loaded 
    16:05:01.351 > echo:V82 stored settings retrieved (733 bytes; crc 18855)
    16:05:02.149 > echo:SD card ok
    M503
    16:07:13.928 > echo:  G21    ; Units in mm (mm)  
    16:07:13.929 > echo:  M149 C ; Units in Celsius  
    16:07:13.930 >
    16:07:13.930 > echo:; Filament settings: Disabled
    16:07:13.932 > echo:  M200 T0 D1.75
    16:07:13.932 > echo:  M200 T1 D1.75
    16:07:13.933 > echo:  M200 S0
    16:07:13.933 > echo:; Steps per unit:
    16:07:13.934 > echo: M92 X80.00 Y80.00 Z400.00
    16:07:13.936 > echo: M92 T0 E747.60
    16:07:13.937 > echo: M92 T1 E98.00
    16:07:13.937 > echo:; Maximum feedrates (units/s):
    16:07:13.940 > echo:  M203 X70.00 Y70.00 Z4.00
    16:07:13.941 > echo:  M203 T0 E20.00
    16:07:13.941 > echo:  M203 T1 E10.00
    16:07:13.942 > echo:; Maximum Acceleration (units/s2):
    16:07:13.944 > echo:  M201 X3000.00 Y3000.00 Z2000.00
    16:07:13.945 > echo:  M201 T0 E3000.00
    16:07:13.947 > echo:  M201 T1 E3000.00
    16:07:13.969 > echo:; Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
    16:07:13.969 > echo:  M204 P2000.00 R2000.00 T2000.00
    16:07:13.969 > echo:; Advanced: B<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> J<junc_dev>
    16:07:13.969 > echo:  M205 B20000.00 S0.00 T0.00 J0.01
    16:07:13.969 > echo:; Home offset:
    16:07:13.969 > echo:  M206 X0.00 Y0.00 Z4.65
    16:07:13.969 > echo:; Hotend offsets:
    16:07:13.969 > echo:  M218 T1 X0.00 Y0.00 Z0.000
    16:07:13.969 > echo:; Auto Bed Leveling:
    16:07:13.969 > echo:  M420 S0 Z0.00
    16:07:13.969 > echo:  G29 W I0 J0 Z2.58250
    16:07:13.969 > echo:  G29 W I1 J0 Z2.56000
    16:07:13.969 > echo:  G29 W I2 J0 Z2.55500
    16:07:13.969 > echo:  G29 W I0 J1 Z2.48000
    16:07:13.971 > echo:  G29 W I1 J1 Z2.52000
    16:07:13.971 > echo:  G29 W I2 J1 Z2.50250
    16:07:13.973 > echo:  G29 W I0 J2 Z2.25000
    16:07:13.974 > echo:  G29 W I1 J2 Z2.32500
    16:07:13.975 > echo:  G29 W I2 J2 Z2.31500
    16:07:13.975 > echo:; Material heatup parameters:
    16:07:13.978 > echo:  M145 S0 H180 B70
    16:07:13.978 > echo:  M145 S1 H231 B105
    16:07:13.979 > echo:; PID settings:
    16:07:13.994 > echo:  M301 P22.20 I1.08 D114.00
    16:07:13.994 > echo:  M301 P22.20 I1.08 D114.00
    16:07:13.994 > echo:; Retract: S<length> F<units/m> Z<lift>
    16:07:13.994 > echo:  M207 S3.00 W13.00 F2700.00 Z0.00
    16:07:13.994 > echo:; Recover: S<length> F<units/m>
    16:07:13.994 > echo:  M208 S0.00 W0.00 F0.00
    16:07:13.994 > echo:; Auto-Retract: S=0 to disable, 1 to interpret E-only moves as retract/recover
    16:07:13.994 > echo:  M209 S0
    16:07:13.994 > echo:; Z-Probe Offset (mm):
    16:07:13.995 > echo:  M851 X28.84 Y2.70 Z0.20
    16:07:13.996 > echo:; Filament load/unload lengths:
    16:07:14.006 > echo:  M603 T0 L500.00 U800.00
    16:07:14.006 > echo:  M603 T1 L500.00 U800.00
    16:07:14.006 > echo:; Tool-changing:
    16:07:14.006 > echo: Z2.00
    16:07:14.006 > echo:; Filament runout sensor:
    16:07:14.006 > echo:  M412 S0 D37.00
    16:07:14.006 > ok

     

    After Homing it says:
     

    
    16:08:18.056 > echo:Active Extruder: 0
    16:08:19.938 > echo:busy: processing
    16:08:21.952 > echo:busy: processing
    16:08:22.193 > echo:Active Extruder: 0
    16:08:22.193 > X:-82.00 Y:-15.00 Z:226.65 E:0.00 Count X:-6560 Y:-1200 Z:88800
    16:08:22.197 > ok
    M503
    16:08:27.143 > echo:  G21    ; Units in mm (mm)
    16:08:27.155 > echo:  M149 C ; Units in Celsius
    16:08:27.155 >
    16:08:27.155 > echo:; Filament settings: Disabled
    16:08:27.155 > echo:  M200 T0 D1.75
    16:08:27.155 > echo:  M200 T1 D1.75
    16:08:27.155 > echo:  M200 S0
    16:08:27.155 > echo:; Steps per unit:
    16:08:27.155 > echo: M92 X80.00 Y80.00 Z400.00
    16:08:27.155 > echo: M92 T0 E747.60
    16:08:27.155 > echo: M92 T1 E98.00
    16:08:27.155 > echo:; Maximum feedrates (units/s):
    16:08:27.157 > echo:  M203 X70.00 Y70.00 Z4.00
    16:08:27.157 > echo:  M203 T0 E20.00
    16:08:27.157 > echo:  M203 T1 E10.00
    16:08:27.158 > echo:; Maximum Acceleration (units/s2):
    16:08:27.160 > echo:  M201 X3000.00 Y3000.00 Z2000.00
    16:08:27.171 > echo:  M201 T0 E3000.00
    16:08:27.171 > echo:  M201 T1 E3000.00
    16:08:27.171 > echo:; Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
    16:08:27.171 > echo:  M204 P2000.00 R2000.00 T2000.00
    16:08:27.171 > echo:; Advanced: B<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> J<junc_dev>
    16:08:27.173 > echo:  M205 B20000.00 S0.00 T0.00 J0.01
    16:08:27.175 > echo:; Home offset:
    16:08:27.175 > echo:  M206 X0.00 Y0.00 Z4.65
    16:08:27.176 > echo:; Hotend offsets:
    16:08:27.184 > echo:  M218 T1 X0.00 Y0.00 Z0.000
    16:08:27.184 > echo:; Auto Bed Leveling:
    16:08:27.184 > echo:  M420 S0 Z0.00
    16:08:27.184 > echo:  G29 W I0 J0 Z2.58250
    16:08:27.184 > echo:  G29 W I1 J0 Z2.56000
    16:08:27.184 > echo:  G29 W I2 J0 Z2.55500
    16:08:27.184 > echo:  G29 W I0 J1 Z2.48000
    16:08:27.185 > echo:  G29 W I1 J1 Z2.52000
    16:08:27.187 > echo:  G29 W I2 J1 Z2.50250
    16:08:27.188 > echo:  G29 W I0 J2 Z2.25000
    16:08:27.190 > echo:  G29 W I1 J2 Z2.32500
    16:08:27.191 > echo:  G29 W I2 J2 Z2.31500
    16:08:27.191 > echo:; Material heatup parameters:
    16:08:27.202 > echo:  M145 S0 H180 B70
    16:08:27.202 > echo:  M145 S1 H231 B105
    16:08:27.202 > echo:; PID settings:
    16:08:27.202 > echo:  M301 P22.20 I1.08 D114.00
    16:08:27.202 > echo:  M301 P22.20 I1.08 D114.00
    16:08:27.202 > echo:; Retract: S<length> F<units/m> Z<lift>
    16:08:27.202 > echo:  M207 S3.00 W13.00 F2700.00 Z0.00
    16:08:27.202 > echo:; Recover: S<length> F<units/m>
    16:08:27.204 > echo:  M208 S0.00 W0.00 F0.00
    16:08:27.206 > echo:; Auto-Retract: S=0 to disable, 1 to interpret E-only moves as retract/recover
    16:08:27.208 > echo:  M209 S0
    16:08:27.210 > echo:; Z-Probe Offset (mm):
    16:08:27.218 > echo:  M851 X28.84 Y2.70 Z0.20
    16:08:27.218 > echo:; Filament load/unload lengths:
    16:08:27.218 > echo:  M603 T0 L500.00 U800.00
    16:08:27.218 > echo:  M603 T1 L500.00 U800.00
    16:08:27.218 > echo:; Tool-changing:
    16:08:27.218 > echo: Z2.00
    16:08:27.218 > echo:; Filament runout sensor:
    16:08:27.220 > echo:  M412 S0 D37.00
    16:08:27.220 > ok

     

    And after leveling it says:
     

    
    16:10:50.787 > Bilinear Leveling Grid:
    16:10:50.787 >       0      1      2
    16:10:50.788 >  0 +2.455 +2.463 +2.495
    16:10:50.790 >  1 +2.418 +2.458 +2.425
    16:10:50.790 >  2 +2.220 +2.318 +2.305
    16:10:50.792 >
    16:10:50.792 > X:121.16 Y:114.30 Z:9.44 E:0.00 Count X:9693 Y:9144 Z:2842
    16:10:50.796 > ok
    M503
    16:11:15.606 > echo:  G21    ; Units in mm (mm)
    16:11:15.618 > echo:  M149 C ; Units in Celsius
    16:11:15.618 >
    16:11:15.618 > echo:; Filament settings: Disabled
    16:11:15.618 > echo:  M200 T0 D1.75
    16:11:15.618 > echo:  M200 T1 D1.75
    16:11:15.618 > echo:  M200 S0
    16:11:15.618 > echo:; Steps per unit:
    16:11:15.618 > echo: M92 X80.00 Y80.00 Z400.00
    16:11:15.618 > echo: M92 T0 E747.60
    16:11:15.618 > echo: M92 T1 E98.00
    16:11:15.618 > echo:; Maximum feedrates (units/s):
    16:11:15.630 > echo:  M203 X70.00 Y70.00 Z4.00
    16:11:15.630 > echo:  M203 T0 E20.00
    16:11:15.630 > echo:  M203 T1 E10.00
    16:11:15.630 > echo:; Maximum Acceleration (units/s2):
    16:11:15.630 > echo:  M201 X3000.00 Y3000.00 Z2000.00
    16:11:15.630 > echo:  M201 T0 E3000.00
    16:11:15.630 > echo:  M201 T1 E3000.00
    16:11:15.630 > echo:; Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
    16:11:15.630 > echo:  M204 P2000.00 R2000.00 T2000.00
    16:11:15.633 > echo:; Advanced: B<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> J<junc_dev>
    16:11:15.637 > echo:  M205 B20000.00 S0.00 T0.00 J0.01
    16:11:15.638 > echo:; Home offset:
    16:11:15.638 > echo:  M206 X0.00 Y0.00 Z4.65
    16:11:15.645 > echo:; Hotend offsets:
    16:11:15.645 > echo:  M218 T1 X0.00 Y0.00 Z0.000
    16:11:15.645 > echo:; Auto Bed Leveling:
    16:11:15.645 > echo:  M420 S1 Z0.00
    16:11:15.645 > echo:  G29 W I0 J0 Z2.45500
    16:11:15.645 > echo:  G29 W I1 J0 Z2.46250
    16:11:15.646 > echo:  G29 W I2 J0 Z2.49500
    16:11:15.647 > echo:  G29 W I0 J1 Z2.41750
    16:11:15.649 > echo:  G29 W I1 J1 Z2.45750
    16:11:15.650 > echo:  G29 W I2 J1 Z2.42500
    16:11:15.651 > echo:  G29 W I0 J2 Z2.22000
    16:11:15.653 > echo:  G29 W I1 J2 Z2.31750
    16:11:15.661 > echo:  G29 W I2 J2 Z2.30500
    16:11:15.661 > echo:; Material heatup parameters:
    16:11:15.661 > echo:  M145 S0 H180 B70
    16:11:15.661 > echo:  M145 S1 H231 B105
    16:11:15.661 > echo:; PID settings:
    16:11:15.661 > echo:  M301 P22.20 I1.08 D114.00
    16:11:15.661 > echo:  M301 P22.20 I1.08 D114.00
    16:11:15.662 > echo:; Retract: S<length> F<units/m> Z<lift>
    16:11:15.664 > echo:  M207 S3.00 W13.00 F2700.00 Z0.00
    16:11:15.665 > echo:; Recover: S<length> F<units/m>
    16:11:15.669 > echo:  M208 S0.00 W0.00 F0.00
    16:11:15.679 > echo:; Auto-Retract: S=0 to disable, 1 to interpret E-only moves as retract/recover
    16:11:15.679 > echo:  M209 S0
    16:11:15.679 > echo:; Z-Probe Offset (mm):
    16:11:15.679 > echo:  M851 X28.84 Y2.70 Z0.20
    16:11:15.679 > echo:; Filament load/unload lengths:
    16:11:15.679 > echo:  M603 T0 L500.00 U800.00
    16:11:15.679 > echo:  M603 T1 L500.00 U800.00
    16:11:15.680 > echo:; Tool-changing:
    16:11:15.680 > echo: Z2.00
    16:11:15.681 > echo:; Filament runout sensor:
    16:11:15.684 > echo:  M412 S0 D37.00
    16:11:15.684 > ok

     

  • Link to post
    Share on other sites
    Posted · z-offset after auto-leveling/rafting - z-level relative/absolut?

    ...and then, after homing again:
     

    M503
    16:14:28.470 > echo:  G21    ; Units in mm (mm)
    16:14:28.480 > echo:  M149 C ; Units in Celsius
    16:14:28.480 >
    16:14:28.480 > echo:; Filament settings: Disabled
    16:14:28.480 > echo:  M200 T0 D1.75
    16:14:28.480 > echo:  M200 T1 D1.75
    16:14:28.480 > echo:  M200 S0
    16:14:28.480 > echo:; Steps per unit:
    16:14:28.480 > echo: M92 X80.00 Y80.00 Z400.00
    16:14:28.480 > echo: M92 T0 E747.60
    16:14:28.480 > echo: M92 T1 E98.00
    16:14:28.480 > echo:; Maximum feedrates (units/s):
    16:14:28.483 > echo:  M203 X70.00 Y70.00 Z4.00
    16:14:28.484 > echo:  M203 T0 E20.00
    16:14:28.484 > echo:  M203 T1 E10.00
    16:14:28.493 > echo:; Maximum Acceleration (units/s2):
    16:14:28.493 > echo:  M201 X3000.00 Y3000.00 Z2000.00
    16:14:28.493 > echo:  M201 T0 E3000.00
    16:14:28.493 > echo:  M201 T1 E3000.00
    16:14:28.493 > echo:; Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
    16:14:28.494 > echo:  M204 P2000.00 R2000.00 T2000.00
    16:14:28.497 > echo:; Advanced: B<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> J<junc_dev>
    16:14:28.501 > echo:  M205 B20000.00 S0.00 T0.00 J0.01
    16:14:28.502 > echo:; Home offset:
    16:14:28.502 > echo:  M206 X0.00 Y0.00 Z4.65
    16:14:28.509 > echo:; Hotend offsets:
    16:14:28.509 > echo:  M218 T1 X0.00 Y0.00 Z0.000
    16:14:28.509 > echo:; Auto Bed Leveling:
    16:14:28.509 > echo:  M420 S1 Z0.00
    16:14:28.509 > echo:  G29 W I0 J0 Z2.45500
    16:14:28.509 > echo:  G29 W I1 J0 Z2.46250
    16:14:28.510 > echo:  G29 W I2 J0 Z2.49500
    16:14:28.511 > echo:  G29 W I0 J1 Z2.41750
    16:14:28.513 > echo:  G29 W I1 J1 Z2.45750
    16:14:28.514 > echo:  G29 W I2 J1 Z2.42500
    16:14:28.516 > echo:  G29 W I0 J2 Z2.22000
    16:14:28.517 > echo:  G29 W I1 J2 Z2.31750
    16:14:28.526 > echo:  G29 W I2 J2 Z2.30500
    16:14:28.526 > echo:; Material heatup parameters:
    16:14:28.526 > echo:  M145 S0 H180 B70
    16:14:28.526 > echo:  M145 S1 H231 B105
    16:14:28.526 > echo:; PID settings:
    16:14:28.526 > echo:  M301 P22.20 I1.08 D114.00
    16:14:28.526 > echo:  M301 P22.20 I1.08 D114.00
    16:14:28.527 > echo:; Retract: S<length> F<units/m> Z<lift>
    16:14:28.528 > echo:  M207 S3.00 W13.00 F2700.00 Z0.00
    16:14:28.529 > echo:; Recover: S<length> F<units/m>
    16:14:28.532 > echo:  M208 S0.00 W0.00 F0.00
    16:14:28.533 > echo:; Auto-Retract: S=0 to disable, 1 to interpret E-only moves as retract/recover
    16:14:28.536 > echo:  M209 S0
    16:14:28.543 > echo:; Z-Probe Offset (mm):
    16:14:28.543 > echo:  M851 X28.84 Y2.70 Z0.20
    16:14:28.543 > echo:; Filament load/unload lengths:
    16:14:28.543 > echo:  M603 T0 L500.00 U800.00
    16:14:28.543 > echo:  M603 T1 L500.00 U800.00
    16:14:28.544 > echo:; Tool-changing:
    16:14:28.544 > echo: Z2.00
    16:14:28.545 > echo:; Filament runout sensor:
    16:14:28.548 > echo:  M412 S0 D37.00
    16:14:28.548 > ok

     

  • Link to post
    Share on other sites
    Posted · z-offset after auto-leveling/rafting - z-level relative/absolut?

    As far as I understand, all values are absolute.
    Does cura support relative z-values? Maybe this will work.

     

    I can imagine Marlin setting a safety-z-zero and a one-way (up only to avoid crashes on moving-down).
    So it starts printing where ever Z level is after leveling.
    Then it goes over to next z-value. As this is smaller than current z-level, it won't move down.
    Next layer, still z-level is too small...so all movements except Z do work.
    This might repeat until Z reached current z-level (which is 4.65mm).

     

    What do you think about this idea?
     

  • Link to post
    Share on other sites
    Posted · z-offset after auto-leveling/rafting - z-level relative/absolut?

    It doesn't work that way.  There are special commands (G90 and G91) to set the printer to relative mode.  There are none in the gcode file.

    Within the setup for the ABL is a z offset I think it's in the M851 line as M851 X28.84 Y2.70 Z0.20.  Your home offset is in the M206 line as X0 Y0 Z4.65.

    Cura doesn't know those numbers.  They are in the printer.  I don't have an ABL and now officially am out of my depth.  I would think that the ABL needs to be calibrated along with your E motor.  You can keep putting band-aids on it but at some point it's going to need to be adjusted.

  • Link to post
    Share on other sites
    Posted · z-offset after auto-leveling/rafting - z-level relative/absolut?

    You are aware that your extruder is set up in Cura with a 0.3 nozzle?  Just checking.  Because your second extruder has a 0.4 nozzle.

  • Link to post
    Share on other sites
    Posted (edited) · z-offset after auto-leveling/rafting - z-level relative/absolut?

    What does ABL mean?

     

    That's correct. First extruder has a .3mm nozzle, second a .4mm one.  At the moment I'm only using the forsi one.

    Edited by Trommelschlumpf
  • Link to post
    Share on other sites
    Posted · z-offset after auto-leveling/rafting - z-level relative/absolut?

    Auto Bed Leveling

  • Link to post
    Share on other sites
    Posted · z-offset after auto-leveling/rafting - z-level relative/absolut?

    This is your CFFP Spiral...gcode file printed on my Ender in PLA.  I changed the Bed and Printing temps and put in an M221 S125 to push the Flow to 125% because I'm too lazy to change nozzles.  There was still extreme under-extrusion after the raft finished so I used the LCD and tuned flow to 150% and it was better.  All the layers are there.

    The problem is with your printer.  I am guessing it's in the ABL settings, but I advise going over the whole thing and calibrating it.  There is no good reason to have to run flow down to 70%.

     

    DSCN2556.JPG

  • Link to post
    Share on other sites
    Posted · z-offset after auto-leveling/rafting - z-level relative/absolut?

    Thanks or testing. For calibration reasons I'm trying to testprint...while I figured out the first-layer-problems...

    As soon as I could deal with it, the whole thing will be calibrated ;)

     

    I created an bug-report on github - maybe there somebody knows what to do: https://github.com/MarlinFirmware/Marlin/issues/20590

  • Link to post
    Share on other sites
    Posted · z-offset after auto-leveling/rafting - z-level relative/absolut?

    One of the reasons I have chosen not to move to Auto Bed Leveling is the complexity.  It isn't just a sensor that gets mounted near the nozzle, it's a whole set of motions controlled (and saved to memory) in the printer.  The board in the Ender prints well but there isn't enough memory for anything else.  I'm not changing boards either.  Reddit is full of people who bought printers "upgraded" from a board designed for their printer to some random board they heard about, and now their prints suck or more often, the printer no longer does anything.  Mine works, I understand it, it's as simple as I can get a machine with 4 motors, 4 fans, two computers, a bunch of wheels and pulleys, and a 250 degree piece of aluminum right in the middle.  I love my parchment paper.  A piece will last weeks and when it finally does tear, I don't have to load a bootloader and re-flash it.  I just walk into the kitchen and grab another little piece off the 50 foot roll.

     

    Anyway, that was my ABL rant.  I could go on about calibration too but I'll keep it simple...it's a machine,  parts wear, belts stretch, it doesn't always get the exact same filament.  It needs tune-ups from time to time to keep it at the top of it's game.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker Transformation Summit

        On April 20 - April 23 we will host the Ultimaker Transformation Summit. Come talk to us via Live chat and get inspired by any of our relevant presentations!
        • 7 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...