Jump to content
Ultimaker Community of 3D Printing Experts

"Pause at Height" Issue


Recommended Posts

Posted · "Pause at Height" Issue

Diving into the world of 3D printing with my sons and we are having a blast. We wanted to change colours mid-print. We did some research and found the "pause at height" script in Cura is how it can be done. However ... no matter how closely we follow "how-to" videos ... we can't get our prints to pause. There is a mention of a pause in the Gcode. I must be doing something wrong. Any advice?

 

We are using Cura 4.8. 

 

TIA

 

Michael, Carter and Keaton

 

 

  • Link to post
    Share on other sites

    Posted · "Pause at Height" Issue

    I cannot remember where I read it, but I believe the Pause at Height is not working with height, but is ok with the layer number. I am on an older version and I always use layer number and not height, so I am not sure.

    Maybe @gr5 can clarify?

  • Link to post
    Share on other sites

    Posted · "Pause at Height" Issue

    Pause At Height is not good when Adaptive Layers are enabled, or when Z-hops are enabled.  In the case of adaptive layers, since the layer height varies and since a search for the Z height is vary specific, the chances of entering a Z that is actually present in the file is like picking a number for the lottery.  When Z-hops are enabled the Z jumps up and down and Pause at Height picks the first instance of the Z that it comes across.  That may not (often is not) the working Z height but rather a Z-hop height.  When the script continues after the pause it will seem to skip a layer or two.  It doesn't actually skip a layer but rather prints it at the Z-hop height.

    Using the PauseAtHeight Plugin with it set to "At Layer" works well.

     

    Creality has been playing with the way their boards interpret Gcode commands.  They don't seem to feel it's necessary to inform anybody of what they did.  For instance it has just come up that M117 doesn't work on the 4.2.x boards and there have been complaints that M0 does not work to pause the print.  In regards to Creality machines - neither problem appears to be related to Cura or Marlin.

    • Thanks 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...