Jump to content
Ultimaker Community of 3D Printing Experts

Firmware update (5.2.16) broke my UM3... again


Recommended Posts

Posted · Firmware update (5.2.16) broke my UM3... again

*Sigh* here we go again; just updated from 5.2.11 to 5.2.16 and guess what... the corrupted display bug (see this topic) re-appeared. Just like it did when I originally upgraded to 5.2.11 from the versions before that. As the title states, I'm on a UM3.

 

The corrupted display is not the worst of it, though, just like last time, the printer randomly stalls while printing (but keeps extruding), leaving me with a failed print.

 

@ultimaker: something in your upgrade process seems to break my printer (and by the looks of it other people's printers too).

 

Last time the only way to fix it was to factory reset the printer by re-flashing the firmware (see this topic), requiring me to disassemble the printer. I don't feel like doing that again. On top of that, Ultimaker moderators explicitly removed the files (linked in that topic) required to do so!

 

I contacted Ultimaker support and they referred me to a reseller (they did not seem interested in fixing this bug at all) who then quoted me a couple hundred EUR to swap out the logic board (not covered by warranty). I mean... what the hell. The logic board was clearly not at fault, because the firware re-flash restored the UM3 to a working state. I could even upgrade to 5.2.11 without any problems afterwards.

 

I'm reading similar stories all over these forums. Please please PLEASE, Ultimaker, get your support act together!

IMG_6378.jpg

  • Thanks 1
Link to post
Share on other sites
Posted · Firmware update (5.2.16) broke my UM3... again

This does not look pretty. I got an Ultimaker because i expected it to be premium *especially* in support. It does not really seem like it. I want to hope your problem gets fixed, or selling mine will soon became a priority. I don't want to get stuck with such an expensive brick.

  • Link to post
    Share on other sites
    Posted · Firmware update (5.2.16) broke my UM3... again

    Hello, 

     

    Thank you for your message and I'm sorry to hear about your issue. 

    On 1/8/2021 at 9:21 PM, bastos80 said:

    On top of that, Ultimaker moderators explicitly removed the files (linked in that topic) required to do so!

     

    It is important to realise that we, Ultimaker support and community moderators, are happy to support you in getting your printer back to work. But the instructions and especially the recovery image could become updated over time and to ensure everyone uses the correct files, and not make the problem worse, we prefer if they are not shared publicly. Do you have an issue? Ask us and we'll make sure you get the correct information. 

     

    I'll send you a DM with the recovery image you need and the instructions to follow. 

     

     

    • Thanks 1
    Link to post
    Share on other sites
    • 5 weeks later...
    Posted · Firmware update (5.2.16) broke my UM3... again

    I am in the same situation now after updating today to 5.2.16,  print head cleaning no longer works, so my

    printer is now unusable. SandervG can you please send me recovery image also, i was in 4. XX not sure what

    i have only updated this printer twice in 5-6 years and both times it has ruined it. 

  • Link to post
    Share on other sites
    Posted · Firmware update (5.2.16) broke my UM3... again
    17 hours ago, itretail said:

    I am in the same situation now after updating today to 5.2.16,  print head cleaning no longer works, so my

    printer is now unusable. SandervG can you please send me recovery image also, i was in 4. XX not sure what

    i have only updated this printer twice in 5-6 years and both times it has ruined it. 

     

    Hi, of course! Please see this comment and follow the instructions! We'll get back with you shortly. 

     

     

  • Link to post
    Share on other sites
    Posted · Firmware update (5.2.16) broke my UM3... again

    Updating to 5.2.16 stopped print head cleaning from working, it would begin the "heating printcore - waiting" and

    would just stay on that message indefinitely. Ran recovery to 4.3.3 and now have to go thru all the initial calibration 

    again. I wish you would test this software before release.

     

  • Link to post
    Share on other sites
    Posted · Firmware update (5.2.16) broke my UM3... again

    This is related to my other thread on the issue.  I'm at 4.3.3 following a recovery as well. 

     

    I understand the wish to have everyone on the same level but for some reason upgrading is hazardous to the stability of these machines and there does not seem to be a path that allows reversion to the previous, stable state.  It's all the way back to 4.3.3 or, given the latest link on the 'bricked UM3' thread, 5.2.16. 

     

    Some middle ground, please..  How about the latest stable variant of 5.2.11?

     

    J

  • Link to post
    Share on other sites
    Posted · Firmware update (5.2.16) broke my UM3... again

    Just an update on this, after recovering to 4.3.3 and familiarising myself with the recovery procedure, i decided to have another go at the update to 5.2.16, followed by factory reset (as suggested by another posted) and this fixed the print core cleaning issue, so i am now printing again on 5.2 16 which i have to say is producing the best prints i've ever had from this printer. In future i will wait a long time before updating again, and keep a recovery sd card handy in any case.

     

    But it is disappointing that support for these (lets face it very expensive printers) is only available via the forum, the manufacturer seems to just ignore us users.

    • Thanks 1
    Link to post
    Share on other sites
    Posted · Firmware update (5.2.16) broke my UM3... again

    That's encouraging.  I'll give it a try on one printer, get it stable there, then try the other one.

    From 4.3.3 as you were, there is still an intermediate firmware step?  If you can spare the time to just indicate what you did and the order, it will probably help me and a host of others who have been exactly where you were.

     

    Thanks for the update !

    John

  • Link to post
    Share on other sites
    Posted · Firmware update (5.2.16) broke my UM3... again
    15 minutes ago, JohnInOttawa said:

    rom 4.3.3 as you were, there is still an intermediate firmware step? 

     

    Yes, when you update from 4.3.3 or older you have to install first the stepping stone build. And then the latest firmware. Don't print or do something else with the stepping stone firmware, I can remember there was a problem when someone tried to print with it.

     

    More infos and download links here:

    https://support.ultimaker.com/hc/en-us/articles/360011587199-Update-the-Ultimaker-3-firmware

     

    • Thanks 1
    Link to post
    Share on other sites
    Posted · Firmware update (5.2.16) broke my UM3... again

    Thanks for the link!  I'll give it a try tomorrow with a fresh pot of coffee and a fully recharged sense of humour.

     

    Will be interesting to see how the Bondtech DDG updater works with the new setup.  Fingers crossed.

     

    J

  • Link to post
    Share on other sites
    Posted · Firmware update (5.2.16) broke my UM3... again

    Good luck!

     

    And if the DDG update doesn't work, you can always make the changes directly via developer mode and ssh. So don't worry about it.

  • Link to post
    Share on other sites
    Posted · Firmware update (5.2.16) broke my UM3... again

    I must have recovered to something greater than 4.3.3 because i didn't do the intermediate step, i had kept a copy of the

    recovery image mentioned in this post below, after performing recovery, i just did update firmware again from the maintenance menu, then factory reset. Then tried the print core cleaning again, ( after power off/on i think) and this time it worked. The recovery image is not there anymore so i don't know what exact version is was. I knew it had worked before so didn't bother to check, but it was definitely before 5.x.x

     

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker Transformation Summit

        On April 20 - April 23 we will host the Ultimaker Transformation Summit. Come talk to us via Live chat and get inspired by any of our relevant presentations!
        • 5 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...