Jump to content
Ultimaker Community of 3D Printing Experts

Model Specific Settings - override Extruder used


joeman1556
 Share

Recommended Posts

Posted · Model Specific Settings - override Extruder used

Hi,

IF we have say a 4 extruder printer (1,2,3,4) 

 

1 is outline for MODEL 1

2 is infill for MODEL 1

 

3 is outline for MODEL 2

4 is infill for MODEL 2

 

 

Can this be done?

 

 

Thanks

 

joe

  • Link to post
    Share on other sites

    Posted · Model Specific Settings - override Extruder used

    Yes.  I'm pretty sure you can.  You can definitely have 2 different models with extruder 1 for one model and extruder 2 for the other.

     

    You can also specify that the infill (or support also) can be done by a different extruder than the shell.

     

    I'm not sure how to do 4 extruders but I think it's possible.

  • Link to post
    Share on other sites

    Posted · Model Specific Settings - override Extruder used

    Within Settings for EXTRUDER 1 I set INFILL override to #2.

     

    Then I go to EXTRUDER 3 and notice its' INFILL override is set to #2. I change this to #4...

     

    But this changes the override for INFILL for EXTRUDER 1 

     

    😞

     

     

    When I go try to do it by Model...it doesn't give me option to override 😞

     

  • Link to post
    Share on other sites

    Posted · Model Specific Settings - override Extruder used

    I've noticed in one of the json config files..

     

     

                    "infill_extruder_nr":
                    {
                        "label": "Infill Extruder",
                        "description": "The extruder train used for printing infill. This is used in multi-extrusion.",
                        "type": "optional_extruder",
                        "default_value": "-1",
                        "settable_per_mesh": false,
                        "settable_per_extruder": false,
                        "settable_per_meshgroup": true,
                        "settable_globally": true,
                        "enabled": "extruders_enabled_count > 1"
                    },
     

    So, this probably explains what I'm seeing.

     

     

     

     

  • Link to post
    Share on other sites

    Posted · Model Specific Settings - override Extruder used
    4 hours ago, joeman1556 said:

    Within Settings for EXTRUDER 1 I set INFILL override to #2.

     

    The infill extruder is not defined per extruder, but per model (the same way as the assignment of the main extruder).

    According to the shown snippet - "Infill Extruder" should be selectable as a "per model setting".

     

     

    Quote

                    "infill_extruder_nr":
                    {
                        "label": "Infill Extruder",
                        "description": "The extruder train used for printing infill. This is used in multi-extrusion.",
                        "type": "optional_extruder",
                        "default_value": "-1",
                        "settable_per_mesh": false,
                        "settable_per_extruder": false,
                        "settable_per_meshgroup": true,
                        "settable_globally": true,
                        "enabled": "extruders_enabled_count > 1"
                    },

     

     

  • Link to post
    Share on other sites

    Posted · Model Specific Settings - override Extruder used

    Lovely. I'll have a play around with it.

     

    I did try :-

                    "infill_extruder_nr":
                    {
                        "label": "Infill Extruder",
                        "description": "The extruder train used for printing infill. This is used in multi-extrusion.",
                        "type": "optional_extruder",
                        "default_value": "-1",
                        "settable_per_mesh": false,
                        "settable_per_extruder": true,
                        "settable_per_meshgroup": true,
                        "settable_globally": false,

                        "enabled": "extruders_enabled_count > 1"
                    },

     

     

    But I'll play with your suggestion...get a better understanding.

     

    Many Thanks

    Joe

  • Link to post
    Share on other sites

    Posted · Model Specific Settings - override Extruder used

    Setting just...

     

     "settable_per_mesh": true

     

    did the trick.

     

    I can now select the extruder for INFILL "per model"

     

    Lovely!

    • Like 2
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...