Jump to content
Ultimaker Community of 3D Printing Experts

Post Processing Script not working in Cura 4.8 anymore?


reibuehl
 Share

Recommended Posts

Posted · Post Processing Script not working in Cura 4.8 anymore?

Hi all,

 

I just tried to add a material change at a certain Z height to my g-code by using the post processing script "Filament Change" from the Extensions->Post processing menu in Cura 4.8. Unfortunately this did not work. My UM2 did not initiate the filament change and an inspection of the generated g-code showed that nothing was inserted at the layer where I had specified the change.

 

Is this a bug or did I do something wrong?

 

Best regards,

Reiner

 

  • Link to post
    Share on other sites

    Posted · Post Processing Script not working in Cura 4.8 anymore?

    First of all: don't use "Filament Change" for Ultimaker 2 (or newer) printers. It uses gcode M600 which is simply ignored by the printer.

    Use "Pause at height" instead (and mind the comments for "Extrude Amount"). During the actual pause use the material change function from the printer menu.

     

     

    37 minutes ago, reibuehl said:

    inspection of the generated g-code showed that nothing was inserted at the layer where I had specified the change

     

    That's a different topic - dunno 🤷‍♂️

     

  • Link to post
    Share on other sites

    Posted · Post Processing Script not working in Cura 4.8 anymore?

    Good information, thanks! Now that I know what to search for, I actually found the M600 in the g-code - just not where I expected it... I configured the Filament Change for Layer 803 and then searched for ";LAYER:803" in the file where I expected the change command. It is actually inserted before ";LAYER:802", two layers earlier than I expected it. I guess the plugin and Cura have a off-by-one issue where one starts counting from 0 and the other starts at 1.

     

    Regarding the "Extrude Amount" setting: The help for that parameter talks about 128mm for an UM2. That sounds a lot since the change procedure of the printer already ensures that the filament is transported to the nozzle. Do you use such a high value?

  • Link to post
    Share on other sites

    Posted · Post Processing Script not working in Cura 4.8 anymore?
    4 hours ago, reibuehl said:

    It is actually inserted before ";LAYER:802", two layers earlier than I expected it. I guess the plugin and Cura have a off-by-one issue where one starts counting from 0 and the other starts at 1.

     

    Yep. Layer numbers in (Cura generated) gcode files always start with index zero. So ";LAYER:0" actually marks the first layer and so on. And (i think) most of the post processing scripts insert their stuff before the layer starts. So it should better be named "Pause before layer" or such... 🙂

     

    4 hours ago, reibuehl said:

    Regarding the "Extrude Amount" setting: The help for that parameter talks about 128mm for an UM2. That sounds a lot since the change procedure of the printer already ensures that the filament is transported to the nozzle. Do you use such a high value?

     

    Me personally? Nope. 🙂

     

    The change procedure retracts the material to the "end-of-print" position after completion. That's 20mm by default. In addition: with gcode-flavor "Ultimaker 2" all extruded values are interpreted as volumetric amount. For filament diameter 2.85mm and 20mm length the volume is approx. 127.6mm³

    That's where this number comes from.

     

    So... it depends. For default firmware and default gcode-flavor: 128 is about right. For all other cases... use whatever the end-of-print retraction is set to.

    Good luck!

     

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • The Ultimaker Showcase — October 14. What's new?
        Your dear friends at Ultimaker have some exciting news and insights for you!
         
        • 0 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...