Jump to content
Ultimaker Community of 3D Printing Experts

Please Help: Cura 4.8.0 Freezes During Launch


Recommended Posts

Posted · Please Help: Cura 4.8.0 Freezes During Launch

I have been printing now for a little over a year and have almost exclusively used Cura as my slicer. About 4 weeks ago I got a stronger laptop for work from home and for printing. Cura 4.7.x, 4.8.0 Beta, and finally 4.8.0 worked great when I first installed them on the new computer. I later uninstalled the default MacAfee antivirus and loaded Kaspersky total security (previously paid for the service on another machine). I don't know if this has anything to do with it but this is one of the things I noticed around the timeframe. Shortly after that, I am unable to open Cura. When I go to the launch the program it cycles through GUI but as soon as the program itself opens, it freezes part way through loading. I could uninstall the program and reinstall it and get about another 2-3 slices from the program before it would begin to freeze again. I have also tried other slicers like Prusaslicer and that too after a time will eventually freeze. I am able to run Creo and NX without issue on my new computer. Any help or guidance you all could provide would be greatly appreciated! See below for computer specs and previously tested resolutions. I will be sure to respond to any questions or comments!

 

Computer: Dell G5, i7 @2.6Ghz (4.1OC), 500Gb NVMe M.2, GTX 1660Ti, 16Gb RAM, Windows 10 64-bit

 

I've tried:

  • Restarting the computer
  • Uninstalling and re-installing Cura (will work for a minute and then eventually freeze)
  • Pausing internet security while uninstall/reinstall/running
  • Deleting the Cura folders from the Appdata/Local and Appdata/Roaming and restarting
  • Run as admin (works for a minute so I can uncheck "send anon print information" but eventually freezes before you can slice a file)
  • Troubleshoot compatibility, both standard and windows 7/8 modes
  • Link to post
    Share on other sites
    Posted · Please Help: Cura 4.8.0 Freezes During Launch

    One possibility is that there are too many triangles in your STL file.  Try slicing something simple like a cube with only 12 triangles.  Or something that you have sliced before that sliced quickly.  Meshlab tells you how many triangles/faces there are the moment it loads your STL and can decimate them to fewer triangles as well if you want.  This is just a guess but it's all I can think of right now.

  • Link to post
    Share on other sites
    Posted · Please Help: Cura 4.8.0 Freezes During Launch

    I misunderstood.  locate the log file and post it here.  Also look at it - it may have clues towards the end.

     

    On my windows10 computer it is here: C:\Users\gr5\AppData\Roaming\cura\4.8
    On linux is here:   /home/gr5/.local/share/cura/master

     

    %APPDATA%\cura\<Cura version>\cura.log (Windows), or usually C:\Users\\<your username>\AppData\Roaming\cura\<Cura version>\cura.log
    $USER/Library/Application Support/cura/<Cura version>/cura.log (OSX)
    $USER/.local/share/cura/<Cura version>/cura.log (Ubuntu/Linux)
     

  • Link to post
    Share on other sites
    Posted · Please Help: Cura 4.8.0 Freezes During Launch
    1 hour ago, gr5 said:

    I misunderstood.  locate the log file and post it here.  Also look at it - it may have clues towards the end.

     

    On my windows10 computer it is here: C:\Users\gr5\AppData\Roaming\cura\4.8
    On linux is here:   /home/gr5/.local/share/cura/master

     

    %APPDATA%\cura\<Cura version>\cura.log (Windows), or usually C:\Users\\<your username>\AppData\Roaming\cura\<Cura version>\cura.log
    $USER/Library/Application Support/cura/<Cura version>/cura.log (OSX)
    $USER/.local/share/cura/<Cura version>/cura.log (Ubuntu/Linux)
     

    Not a problem, thank you for taking the time to help out! I greatly appreciate it. Attached is the .log file.

     

    cura.log

  • Link to post
    Share on other sites
    Posted · Please Help: Cura 4.8.0 Freezes During Launch

    So it isn't exactly crashing - it's just slow.  "just".  Definitely shut off kaspersky completey - 100% off - and try it once without kaspersky running.  I remember something about that from past posts.

     

    How many megabytes is the STL you sliced?

     

     Did you install cura on a network drive?

     

    So there have been issues with cura slowing to a crawl due to - I forget what exactly but I think maybe:

    searching through USB devices

    searching through online printers

    searching through networked drives (dropbox?  NAS drives?)

     

    Try disconnecting your network cable and then launching cura - see if that helps.

     

    In google type "site:ultimaker.com cura slow".  The "site:" will only give you answers from the ultimaker web site which is ideal.  There have been other people where cura was too slow to use and they got things figured out.

     

    Let me know if you tried: 1) kaspersky 2) network 3)size of stl 4) installation disk

     

     

  • Link to post
    Share on other sites
    Posted · Please Help: Cura 4.8.0 Freezes During Launch
    21 hours ago, gr5 said:

    So it isn't exactly crashing - it's just slow.  "just".  Definitely shut off kaspersky completey - 100% off - and try it once without kaspersky running.  I remember something about that from past posts.

     

    How many megabytes is the STL you sliced?

     

     Did you install cura on a network drive?

     

    So there have been issues with cura slowing to a crawl due to - I forget what exactly but I think maybe:

    searching through USB devices

    searching through online printers

    searching through networked drives (dropbox?  NAS drives?)

     

    Try disconnecting your network cable and then launching cura - see if that helps.

     

    In google type "site:ultimaker.com cura slow".  The "site:" will only give you answers from the ultimaker web site which is ideal.  There have been other people where cura was too slow to use and they got things figured out.

     

    Let me know if you tried: 1) kaspersky 2) network 3)size of stl 4) installation disk

     

     

    Thank you for the response.

     

    1. I closed out of my AV, cleared the local and roaming cura folders and tried to load Cura as an admin. It still acts as if it was frozen.

    1a. After I closed Cura from my first test, i went through the trouble shooting app and selected recommended settings and it failed again. I sent the information to Microsoft and it came back saying "Incompatible Program - Not Fixed"

    2. My network is via WiFi, there is no network cable

    2a. After I closed Cur from the second test, I then turned off my WiFi and tried opening it again as an admin.

    3. When I am able to actually open Cura and get it to slice (My problem), I was able to slice a single item that was 1.08MB

    4. Cura is installed locally on my machine (C Drive - 500GB NVMe ). My printer is not connected to my cura.logr and I use the SD card to transfer information to the printer.

     

    I have attached my .log file for this round of testing as well if it helps. Thank you again for taking the time to review this!

    cura.log

  • Link to post
    Share on other sites
    Posted (edited) · Please Help: Cura 4.8.0 Freezes During Launch

    My recommendation is:

    1. Cura runs in compatibility mode and uses the on-board Intel graphics card. I would try to select the NVIDIA driver instead. The procedure depends on your operating system and/or graphics driver version. For example:
      https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/select-gpu-to-use-by-specific-applications/eb671f52-5c24-428d-a7a0-02a36e91ee2f
       
    2. Start Cura one more time with disabled network, open the preferences window and disable "Check for updates on start" and "Send (anonymous) print information" (at the bottom of the dialog).
      Disable "Restore window position on start", if you use more than one monitor.
    3. Disable bundled plugins that you do not use (in "Marketplace") e.g.:
      - Firmware Update Checker
      - UM3 Network Printing
      - USB Printing
      - Update Checker
    4. Restart Cura, enable the network connection and check if it makes a difference.
      ("start as Administrator" should not be necessary)

     

    Or better do one step at a time to find the root cause.

    Good luck!

    Edited by tinkergnome
  • Link to post
    Share on other sites
    Posted · Please Help: Cura 4.8.0 Freezes During Launch
    20 hours ago, tinkergnome said:

    My recommendation is:

    1. Cura runs in compatibility mode and uses the on-board Intel graphics card. I would try to select the NVIDIA driver instead. The procedure depends on your operating system and/or graphics driver version. For example:
      https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/select-gpu-to-use-by-specific-applications/eb671f52-5c24-428d-a7a0-02a36e91ee2f
       
    2. Start Cura one more time with disabled network, open the preferences window and disable "Check for updates on start" and "Send (anonymous) print information" (at the bottom of the dialog).
      Disable "Restore window position on start", if you use more than one monitor.
    3. Disable bundled plugins that you do not use (in "Marketplace") e.g.:
      - Firmware Update Checker
      - UM3 Network Printing
      - USB Printing
      - Update Checker
    4. Restart Cura, enable the network connection and check if it makes a difference.
      ("start as Administrator" should not be necessary)

     

    Or better do one step at a time to find the root cause.

    Good luck!

    So, I changed the forced cura to use the GPU. I was able to get into cura long enough for me to select and change out the settings for Print information, restore window, and check for updates. Those are now all unchecked. Testing it without the AV and not on the internet, I was able to get in, load a flle, and slice it, but the moment I tried to go into the settings file, it "locked up" again.

     

    Then.... and here's the kicker, I unplugged everything from my laptop and tried again and it works flawlessly (so far). I even changed most of the settings back to original and it still came up clean. So I believe it has to do with one of my USB ports or displays. It is a hodge podge because I use my laptop for work from home but I have a 3rd party USB-C docking station plugged in to my laptop that runs 2 monitors and has another USB 3.0 hub splitter attached which connects a phone charger, USB wireless keyboard, printer, and external hard drive.

     

    Not sure which one of those is causing the issue with Cura but one of them or all of them are contributing somehow. I do seem to have a workaround, it is just a little inconvenient. But I would rather be able to use it than not. If you see something that could cause it from that list let me know and I'll try that too!

  • Link to post
    Share on other sites
    Posted · Please Help: Cura 4.8.0 Freezes During Launch

    USB makes complete sense.  It's looking for a 3d printer on all the USB ports.  Sometimes I think cura has too many features.  You are going to have to unplug and plug in each USB device to figure it out I think.  It's possible that the "bad" device has to be connected when you first start cura and if you connect it later cura might not notice.  Not sure.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker Transformation Summit

        On April 20 - April 23 we will host the Ultimaker Transformation Summit. Come talk to us via Live chat and get inspired by any of our relevant presentations!
        • 5 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...