Jump to content
Ultimaker Community of 3D Printing Experts

Issues with Pause at height


Recommended Posts

Posted (edited) · Issues with Pause at height

I am currently running Cura 4.8.0, just updated from 4.6.1.

 

In 4.6.1 Pause at height was a very easy command and worked very well for me. Set the height in mm at which point you want the printer to pause, and it would happen flawlessly. The printer would stop, at which time I could insert a 1/4-20 nut into the partially finished print. After this I would push the button on the front of the printer and the print would resume.

 

1360477734_ScreenShot2021-01-31at10_39_25AM.thumb.png.022c04f78c532647969e409ac9163a68.png

Now in 4.8.0 when I choose Pause at height, there are a lot more options. You can now choose the height in mm of layer number. There are many more options to choose from No matter what options I have chosen, the printer does not pause at the chosen height/layer. The printer stops.

 

1667285448_ScreenShot2021-01-31at10_42_25AM.thumb.png.3aa77a744f64f7d3c561e2a2e6ebce81.png

When I set the "Disarm timeout" setting to 20 seconds for instance, the printer pauses a short time and then still stops completely.

 

1253460484_ScreenShot2021-01-31at10_58_43AM.thumb.png.ff274f6b3777f04ab42297c67d4dd4fa.png

What are the correct settings for the printer to pause and then resume again? The printer I am using is the Ultimaker 2.

BTW, this is what I want to make again. I have made this successfully numerous times for myself and friends. It's a tripod holder for my phone. I need to pause the printer to insert the 1/4-20 nut. These photos were taken after the printer stopped.

 

 IMG_8487.thumb.JPG.bf85742029b40e27bcba334aa58508a6.JPG

 

 

IMG_8488.thumb.JPG.f1b34c2e60ff858cfdc7d3015a921ee3.JPG

 

 

IMG_8487.JPG

IMG_8488.JPG

Edited by zews
  • Link to post
    Share on other sites
    Posted · Issues with Pause at height

    When you try to use Pause at Height with "Height" as the main option, and you have Z-Hops in the file, the plugin doesn't find the correct Z height.  It's a known issue and has been reported on GitHub and a repair is planned.  The layer number is the number of the layer in the Gcode file (base 0).  It is equal to the Cura preview layer minus 1.

     

    Method.  You have it set to BQ(M25).  That is firmware-specific to your printer. 

     

    The Disarm Timout is a countdown in seconds.  If there has been no movement for "X" number of seconds then the Stepper motors disable and the printer loses track of the print head location.  20 seconds wasn't good.  The max allowed in the plugin is 1800 seconds so set it to that.  It will give you 30 minutes to change filament or install a nut, or whatever.

     

    The amount of Retraction occurs at the pause.  The amount of Extrude is the prime on restart.  They require some practice since they are affected by the amount of ooze that occurs during the pause.  The speeds can be set to whatever you normally use in Cura.  I use Pause at Height to change colors.  I don't bother with the retraction settings.

     

    Redo layer???  I know it doesn't work as expected and that's about all I know.

     

    Standby temperature is generally your printing temperature so the nozzle doesn't cool off during the pause.

     

    Display text sends a message to the display.  Yours might be "Insert your nuts now".  (Sorry...couldn't resist.  I'm doubly sorry if you are of the female persuasion.)

     

    Gcode before Pause I usually put in M300 so the machine beeps when it pauses.

     

    Gcode After Pause can be used for different things.  It goes in at the line immediately below M25.

     

     

     

     

     

     

     

     

  • Link to post
    Share on other sites
    Posted · Issues with Pause at height

    I don't know what Z-Hops means. The fact that this is a known issue makes me want to believe that I cannot make this work in version 4.8.0. I guess it's back to version 4.6.1. Is that correct? 


    They made something that was very simple much more complicated, and now it doesn't work. Would have been nice if I had known about this in advance. I would not have updated Cura. 

    From your answer I read that the BQ(M25) setting is correct for my Ultimaker 2 printer.

     

    The mentioned 20 seconds for Disarm timeout was just a tryout. I had the Pause height set a layer 4, so it would be just a few minutes after the beginning of the print instead of almost done.

    I don't understand why 20 seconds would not be good. 20 seconds gives me plenty of time to insert the nut. I don't need 30 minutes to do that.

    All the other settings you mention do not seem to be relevant to my particular print.

     

     

     

  • Link to post
    Share on other sites
    Posted · Issues with Pause at height

    I just reinstalled version 4.6.1 and tried Pause at height again. I set the height to pause at to 1 mm so I wouldn't have too waste much filament.

    It still doesn't work. As with 4.8.0 it stops at the set height, instead of pausing.

     

    Now I don't remember which software version it worked with. It may have been 4.0.0, 3.6.0, or 3.2.1 (these are the versions for which I still have the install files.) Or even all the way back to 15.06.03. So annoying, because it used to work beautifully.

     

  • Link to post
    Share on other sites
    Posted · Issues with Pause at height
    2 hours ago, zews said:

    From your answer I read that the BQ(M25) setting is correct for my Ultimaker 2 printer.

     

    Why do you use the script for BQ printers (your screenshots)? M25 stops the print on Ultimaker printers.

    The default method should be "Marlin (M0)"  - which is the correct choice for UM2.

    • Like 1
    Link to post
    Share on other sites
    Posted · Issues with Pause at height

    Cura users asked for changes.  I'm sure the people who develop and caretake Cura looked at those requested changes before implementing them.

    The default "Disarm Timeout" on my Ender 3 Pro is 120 seconds.  I'm not there to constantly stare at the printer so I set the Disarm Timeout as high as possible just in case I'm slow to respond.

    I find that the Pause at Height works exactly as intended.  My machine has Marlin firmware.  The M0 stops the print and a button click on the LCD resumes the print.  Looking back at my statement "That is firmware-specific to your printer." could be misleading.  I should have said that the Mcode used to pause a print is "firmware-specific to ANY printer".  

  • Link to post
    Share on other sites
    Posted · Issues with Pause at height
    18 hours ago, tinkergnome said:

     

    Why do you use the script for BQ printers (your screenshots)? M25 stops the print on Ultimaker printers.

    The default method should be "Marlin (M0)"  - which is the correct choice for UM2.


    I used the BQ(M25) setting because that was the default after I installed version 4.8.0, not knowing any better. I assumed Cura would know which one to use as my Ultimaker 2 is the only printer set in Preferences. Frankly I don't know what a "BQ printer" is. Even though I have had my Ultimaker 2 since 2014, and have used it regularly, my prints are always very small. I use the printer mostly for jewelry prototypes, so very small items. I am just now finishing the filament spool the printer came with. My skill is just mediocre level at best.

    The only time I have needed to use the "Pause at height" option has been for this phone tripod holder that I have made a number of times. It has always worked beautifully going back to Cura version 15.06.03 from 2015.

    I made another print with your suggested method of Marlin(M0), and "Pause at height" of 1 mm as a test. BINGO! It worked beautifully! It stopped, and I could resume the print. Thank you very much for that tip!

    I do have a couple additional questions if I may. I had retraction set to "0". A bit of filament was still hanging from the nozzle as the print head paused in the far right corner. When the print resumed that got in the way a little. I wonder if I should set it to 1mm or another setting to prevent that. Do you have a suggestion?

    How could I have known that I should set method to Marlin(M0) from the start? I could not find any documentation for this setting.

    In version 4.6.1 there is only one setting available for Pause at height, which is in mm. Nothing else can be set. As I mentioned pause did not work in this version either. How would that be solved in that version?

    Thanks again for your advice. It made all the difference.

  • Link to post
    Share on other sites
    Posted · Issues with Pause at height

    "...A bit of filament was still hanging from the nozzle as the print head..."

    The technical term for that is "booger" and it is the result of some oozing from the nozzle.  The retraction setting would likely help, but then you need a prime ("Extrude Amount" in the settings).  If the Extrude Amount isn't just right it will result in a blob.  My system is to hold the booger with a pair of long nose tweezers in my left hand, and hit the button with my right hand.   Off it goes.

     

    In Cura under Manage Printers | Machine Settings the Gcode flavor is noted.  In 4.6 check that you are using Marlin(M0) to pause.  As I said, if there are Z-hops in the Gcode file then the Plugin has trouble finding the working Z height.  "By Layer" should work fine.

     

     

     

     

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker Transformation Summit

        On April 20 - April 23 we will host the Ultimaker Transformation Summit. Come talk to us via Live chat and get inspired by any of our relevant presentations!
        • 6 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...