Jump to content
Ultimaker Community of 3D Printing Experts

Recurrent Issue with "Line Error" on S3


Recommended Posts

Posted · Recurrent Issue with "Line Error" on S3

I seem to be having a recurrent and persistent error which has severely limited the utility of my S3. I continue to get "line errors" on simple geometries I'm trying to print. I have been in contact with service and have really seemed to have tried everything without finding a solution. I have designed using different programs (tinkercad, MOI), updated firmware, used print over network, used local printing with two different USB drives, redesigned the object from scratch, etc etc. Finally I sent the machine into service for an overhaul last month despite it being less than a year old. It worked as expected for a couple prints and now is back to the same errors. I haven't found any solutions I haven't tried elsewhere apart from returning it for a replacement. I was hoping for a little insight into what might be worth trying. I'm very frustrated. 

 

I've included two of the files I've tried without success.

 

Nathan 

IMG_0627.jpg

tooth cust.obj display tooth stand.stl

  • Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3

    I'm not 100% sure but I think it means the gcode file is corrupt (actually ufp file for S3).

     

    If it only did this through USB then I'd say you've got a bad USB drive but if it also does it through network printing - still (check one more time if you haven't already since you got the printer back) then I'd say your flash memory on the olimex board is corrupt.  I'd get a new one asap.  Especially while still under warranty!

     

    Another thing to try - upgrade the software to the latest firmware - this stresses the flash drive and moves files around and if it completely fails the upgrade then that's confirmation.  Or if you are lucky now files printed over the network are in a new position. 

     

    If you know linux and you have the older firmware you could create a few gigabytes of junk data on there such that new files printing over the network will go into a different location on the internal olimex flash drive as these failures tend to be localized (in just a few spots of the flash) in my experience.  But the newer S3 firmwares I think disable the ability to ssh into the printer and do this kind of thing unless you have the olimex serial cable.

     

    Anyway, if it's still under warranty when you started getting these errors, have the reseller give you a new olimex board.  I've heard the claim that these types of errors are rare (corrupted flash) which really surprises me as I've met a few people with the issue (different issue from yours).  So each case like this needs to have some attention placed on it.

     

     

    • Like 1
    Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3

    Please post the EXACT ufp file that gets this error so I can look at line 146.  If the file is gone then please post the ufp file the next time this happens.

     

    Can you prove that it's the same olimex card?  For example if you had configured the old one for your wifi network but not the new one yet the new one already knew about your network?

     

    Usually if a vendor says they replaced something, they did.

  • Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3

    Nothing special about line 64:

    1568276161_Screenshotfrom2021-02-1308-21-11.png.580dc20ca356d40ab29893f26614d1c2.png
     

    I'm stupid - I should have asked you to post the log files.  Power up the printer, put a usb stick in it.  Go to maintenance menus and there is a way to copy the log files to the stick.  Then post all of those files - there's like 20 files.  Please post them all.

  • Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3

    Hi there,

     

    Just a little note, half of your model is floating above the bed.

    But if this create the error -have no idea.

     

     

  • Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3
    On 2/6/2021 at 10:04 PM, gr5 said:

    I'm not 100% sure but I think it means the gcode file is corrupt (actually ufp file for S3).

     

    If it only did this through USB then I'd say you've got a bad USB drive but if it also does it through network printing - still (check one more time if you haven't already since you got the printer back) then I'd say your flash memory on the olimex board is corrupt.  I'd get a new one asap.  Especially while still under warranty!

     

    Another thing to try - upgrade the software to the latest firmware - this stresses the flash drive and moves files around and if it completely fails the upgrade then that's confirmation.  Or if you are lucky now files printed over the network are in a new position. 

     

    If you know linux and you have the older firmware you could create a few gigabytes of junk data on there such that new files printing over the network will go into a different location on the internal olimex flash drive as these failures tend to be localized (in just a few spots of the flash) in my experience.  But the newer S3 firmwares I think disable the ability to ssh into the printer and do this kind of thing unless you have the olimex serial cable.

     

    Anyway, if it's still under warranty when you started getting these errors, have the reseller give you a new olimex board.  I've heard the claim that these types of errors are rare (corrupted flash) which really surprises me as I've met a few people with the issue (different issue from yours).  So each case like this needs to have some attention placed on it.

     

     

    Hi @gr5,    I'm not 100% sure but I think it means the gcode file is corrupt (actually ufp file for S3).

     

    Sure, you're right..  🙂

     

    Well, I tried to print this latter file (UM3S_Another try.udf), -but got a message with a yellow "exclamation mark" and "Conflict" across the model.

    Still using firmware 5.8.0 on my S3. (wonder if older firmware addressed this issue different?)

     

    Torgeir

     

     

  • Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3

    "conflict" usually means you have the wrong core type (e.g. AA 0.4 instead of say AA 0.25) or the wrong material type.

  • Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3

    I'll definitely grab the log files when I get back home. 

     

    Interestingly, if I slice the same files with Simplify3D and then load that Gcode into Cura and send it to the printer it works just fine. Must be an error introduced with cura slicing? I went so far as to install a legacy version of cura on a different computer and the error persisted. 

  • Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3
    3 hours ago, SeeDiph said:

    if I slice the same files with Simplify3D and then load that Gcode into Cura

    😯

    Maybe it's random?  I'm thinking your flash memory has corruptions and I'm hoping the log file will tell us much more.

  • Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3
    17 hours ago, gr5 said:

    "conflict" usually means you have the wrong core type (e.g. AA 0.4 instead of say AA 0.25) or the wrong material type.

    As usual, you are right.. 🙂

     

    Torgeir.

     

  • Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3

    Sorry for the delay. All your insight is appreciated. Here is what I have from this week's efforts.

    cap_NJF-UMS3_2021-02-18_22.24.30_X195.0Y155.0_sensor_reset.log cap_NJF-UMS3_2021-02-18_22.24.46_N1_X173.0Y155.0.log cap_NJF-UMS3_2021-02-18_22.25.03_N0_X195.0Y155.0.log cap_NJF-UMS3_2021-02-18_22.25.12_N0_X215.0Y175.0.log cap_NJF-UMS3_2021-02-18_22.25.14_N0_X215.0Y135.0.log cap_NJF-UMS3_2021-02-18_22.25.16_N0_X215.0Y95.0.log cap_NJF-UMS3_2021-02-18_22.25.19_N0_X175.0Y15.0.log cap_NJF-UMS3_2021-02-18_22.25.21_N0_X175.0Y55.0.log cap_NJF-UMS3_2021-02-18_22.25.23_N0_X175.0Y95.0.log cap_NJF-UMS3_2021-02-18_22.25.25_N0_X175.0Y135.0.log cap_NJF-UMS3_2021-02-18_22.25.27_N0_X175.0Y175.0.log cap_NJF-UMS3_2021-02-18_22.25.30_N0_X135.0Y175.0.log cap_NJF-UMS3_2021-02-18_22.25.32_N0_X135.0Y135.0.log cap_NJF-UMS3_2021-02-18_22.25.34_N0_X135.0Y95.0.log cap_NJF-UMS3_2021-02-18_22.25.36_N0_X135.0Y55.0.log cap_NJF-UMS3_2021-02-18_22.25.38_N0_X135.0Y15.0.log cap_NJF-UMS3_2021-02-18_22.25.40_N0_X95.0Y15.0.log cap_NJF-UMS3_2021-02-18_22.25.42_N0_X95.0Y55.0.log cap_NJF-UMS3_2021-02-18_22.25.44_N0_X95.0Y95.0.log cap_NJF-UMS3_2021-02-18_22.25.47_N0_X95.0Y135.0.log cap_NJF-UMS3_2021-02-18_22.25.49_N0_X95.0Y175.0.log cap_NJF-UMS3_2021-02-18_22.25.51_N0_X55.0Y175.0.log cap_NJF-UMS3_2021-02-18_22.25.53_N0_X55.0Y135.0.log cap_NJF-UMS3_2021-02-18_22.25.55_N0_X55.0Y95.0.log cap_NJF-UMS3_2021-02-18_22.25.57_N0_X55.0Y55.0.log cap_NJF-UMS3_2021-02-18_22.25.59_N0_X55.0Y15.0.log cap_NJF-UMS3_2021-02-18_22.26.09_N1_X215.0Y95.0.log cap_NJF-UMS3_2021-02-18_22.26.12_N1_X55.0Y175.0.log cap_NJF-UMS3_2021-02-18_22.26.14_N1_X55.0Y15.0.log cap_NJF-UMS3_2021-02-19_03.10.30_X195.0Y155.0_sensor_reset.log cap_NJF-UMS3_2021-02-19_03.10.47_N1_X173.0Y155.0.log cap_NJF-UMS3_2021-02-19_03.11.04_N0_X195.0Y155.0.log cap_NJF-UMS3_2021-02-19_03.11.12_N0_X215.0Y175.0.log cap_NJF-UMS3_2021-02-19_03.11.14_N0_X215.0Y135.0.log cap_NJF-UMS3_2021-02-19_03.11.17_N0_X215.0Y95.0.log cap_NJF-UMS3_2021-02-19_03.11.19_N0_X175.0Y15.0.log cap_NJF-UMS3_2021-02-19_03.11.21_N0_X175.0Y55.0.log cap_NJF-UMS3_2021-02-19_03.11.24_N0_X175.0Y95.0.log cap_NJF-UMS3_2021-02-19_03.11.26_N0_X175.0Y135.0.log cap_NJF-UMS3_2021-02-19_03.11.28_N0_X175.0Y175.0.log cap_NJF-UMS3_2021-02-19_03.11.30_N0_X135.0Y175.0.log cap_NJF-UMS3_2021-02-19_03.11.32_N0_X135.0Y135.0.log cap_NJF-UMS3_2021-02-19_03.11.34_N0_X135.0Y95.0.log cap_NJF-UMS3_2021-02-19_03.11.36_N0_X135.0Y55.0.log cap_NJF-UMS3_2021-02-19_03.11.39_N0_X135.0Y15.0.log cap_NJF-UMS3_2021-02-19_03.11.41_N0_X95.0Y15.0.log cap_NJF-UMS3_2021-02-19_03.11.43_N0_X95.0Y55.0.log cap_NJF-UMS3_2021-02-19_03.11.45_N0_X95.0Y95.0.log cap_NJF-UMS3_2021-02-19_03.11.47_N0_X95.0Y135.0.log cap_NJF-UMS3_2021-02-19_03.11.49_N0_X95.0Y175.0.log cap_NJF-UMS3_2021-02-19_03.11.51_N0_X55.0Y175.0.log cap_NJF-UMS3_2021-02-19_03.11.53_N0_X55.0Y135.0.log cap_NJF-UMS3_2021-02-19_03.11.56_N0_X55.0Y95.0.log cap_NJF-UMS3_2021-02-19_03.11.58_N0_X55.0Y55.0.log cap_NJF-UMS3_2021-02-19_03.12.00_N0_X55.0Y15.0.log cap_NJF-UMS3_2021-02-19_03.12.09_N1_X215.0Y95.0.log cap_NJF-UMS3_2021-02-19_03.12.12_N1_X55.0Y175.0.log cap_NJF-UMS3_2021-02-19_03.12.15_N1_X55.0Y15.0.log dmesg.log flow_NJF-UMS3.log process_data.log sensor_data.log

  • Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3

    Sorry - wrong files.  Among all those files there should have been a few that ended with something like:

    boot0.log boot1.log (or maybe boot0.log.zip).  I think the files all start with "Ultimaker".  All those "cap" files can be deleted.  They are just data from active leveling.  Not interesting unless you have active levelling failures.

     

    The only thing interesting so far is the dmesg.log but I think it only contains everything since the most recent boot.  I assume you got the error a few days ago?  Warning that the boot0 one will have the most recent day or two and boot1 will be a few days before and so on so depending how long ago you got the error, the more log files I have to search through.

     

     

  • Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3

    I don't remember seeing those files but will give it another try. 

  • Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3

    So I think I have the issue figured out. Filleting was introducing very small errors in the models, thus making them non-manifold but for whatever reason, cura was not detecting it. Repaired in mesh maker, all the problem files print without issue. 

  • Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3

    Most likely the error was in the Active Leveling where one of the failing probes was not detected. The release notes mention this bug fixed in 5.8.1. What firmware version are you on?

     

    During printing, when the print head comes close to the failed probe point, then the line error pops up. Often it will be the same failing probe location because of the physics in your specific printer. The Active Leveling sensor is a very sensitive device; on a different day with other temperature, different humidity, or your phone not next to the printer, everything might suddenly work again.

    When the line error happens again, try to locate your object to a different location on the build plate.

  • Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3

    @CarloK - this is fascinating - are you sure "line error" can ever possibly refer to active leveling?  I've seen other people get this error for example if they pull out the usb flash drive during printing and thought it only ever implied a corrupt gcode file (somehow).

     

    But if this error can occur during leveling that would be useful for me to keep in mind!

  • Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3

    Absolutely sure for the S3 and S5 that this is one of the possible causes, next to the obvious damaged files on the USB. The release notes mention this fixed in 5.8.1. If it happens in newer versions than I'd like to hear about this.

     

    This will only happen in the first layer of printing, but when you have multiple objects and sliced for "one object at a time", this may be late in the print process.

     

    Like I wrote, sometimes an Active Leveling probe fails and this is not always properly detected. Later, during printing the printer will follow the contours of the build plate and adjusts the Z-height according to the measured heights. When the print head moves into the grid area belonging to the failed probe, then the 'line error' pops up.

    • Like 1
    • Thanks 1
    Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3

    @CarloK - thanks for this info!  This is valuable for me to know to be able to help people and this is the first I heard of it.  In the future I can tell them to update their firmware.

     

  • Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3

    Hi @CarloK,

     

    Thanks for this information.

    As for 5.8.1 and 5.8.2, I'll think most S3 users (including me) thought that this two firmware versions only matter to the S5 and pro bundle versions. If my memory serves me right, I'll think this was mentioned in one of the tread following the issue of version 5.8.2..

     

    Is the firmware version 5.8.1 still available?

     

    Thanks

    Torgeir

     

     

  • Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3

    @Torgeir Check your mail

  • Link to post
    Share on other sites
    Posted · Recurrent Issue with "Line Error" on S3

    Thanks. 👍

     

    Torgeir

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker Transformation Summit

        On April 20 - April 23 we will host the Ultimaker Transformation Summit. Come talk to us via Live chat and get inspired by any of our relevant presentations!
        • 6 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...