Jump to content
UltiMaker Community of 3D Printing Experts

Shifting Along Y Axis Due To Slicing, I Think


Recommended Posts

Posted · Shifting Along Y Axis Due To Slicing, I Think

I am using Ultimaker Cura 4.8.0.  Lately, I have been having Layer shifting along the Y axis.  My first thought was to check for loose belts or other mechanical problems.  I noticed that it didn't do this all of the time.  It seemed to do it while printing large cylinder shapes (about 3" Dia.).  I was starting to suspect that the Cura program was the problem, so I uninstalled and re-installed it, but that didn't help.  Finally, I sliced the file I was working on with Slic3r and it worked great.  I'm pretty sure that the Cura program on my machine is the problem.  Does anyone know how to fix this?


  • Link to post
    Share on other sites

    Posted · Shifting Along Y Axis Due To Slicing, I Think

    The Y axis on many printers is the bed which has a lot more momentum so it's not as surprising to lose steps on the Y stepper.  Usually though it's a pulley slipping on a shaft (no problem with belts).  There are these tiny set screws in the pulleys to attach them to the shafts in your printer.  Tighten the hell out of these.  If you don't believe me then use a sharpie to mark the edge of the shaft and the pulley and see if the marks move apart as you print.


    The set screws have to be tightened so tight you won't believe it.  If you use an L shaped allen wrench with short end in your fingers it should hurt your fingers.  Quite a bit.  Go for maximum pain.  The hex shaft should twist slightly.


    NOW - why does it happen in cura and not other slicers?  The infill path can be more vigorous in Cura - sharper corners - higher overall acceleration.  But your printer has Marlin as the firmware which has settings for max acceleration and the manufacturer should have set that properly for your machine so most likely it's a loose pulley or friction is insanely high due to some other malfunction.


    DON'T TIGHTEN THE BELTS.  It's not that - it's the pulleys.  Usually the one on the stepper.

  • Link to post
    Share on other sites

    Posted · Shifting Along Y Axis Due To Slicing, I Think

    I tightened the set screws and marked the shaft and the pulley as you mentioned.  The pulley us not slipping on the shaft.  It doesn't shift the layers with other files. I have tested this with a test cube file that I use, a test file that I use for calibrating the height of the build plate, other small cylinder shapes, and a popular sculpture of Captain Picard from Star Trek. These all print out perfectly, but the cylinder-shaped objects that I'm trying to make fail miserably.


    I forgot to mention before that I have another printer that is the same make and model which is exhibiting the same behavior.  I thought it was probably the slicing program but I am not sure that is the case.  I have written to the people who sold me the printer to see what they think.  I have a third printer that seems to print the parts just fine using Cura.  Can you offer any other suggestions?

  • Link to post
    Share on other sites

    Posted · Shifting Along Y Axis Due To Slicing, I Think

    Well it could be there just isn't enough current and the stepper is losing steps.  Or the stepper drivers could be overheating - typically if it overheats it only shuts down for a few milliseconds and you get a massive loss in steps.  Is there any kind of fan blowing cool air on the stepper drivers?  I'd check their temp and see how much hotter the Y stepper driver is.  Anyway the fix is probably to lower the acceleration on the printer.  You should be able to do that from the menu system but you also have to save the new value.  Here's how to typically do it in gcode:


    I don't know if cura can send gcodes and receive results.  If not then maybe use pronterface/printrun.


    M501 - reads the values for acceleration and other limits such as max speed.  It will include the gcode to change it.  For example:

    M201 Y1000  sets max acceleration to 1000mm/sec/sec

    M202 Y1000 sets travel acceleration to 1000mm/sec/sec

    M204 P1000 T1000 sets nominal acceleration to 1000mm/sec/sec

    M205 X5 (sets X and Y jerk to 5)


    Most importantly, all these get lost on power cycle so if you like the new settings do:

    M500    <-- save current settings to eeprom so they are back after power cycle


    There are many flavors of Martin but the M501 will report back all these values.  You want to lower just acceleration and jerk.



  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Our picks

      • New here? Get ahead with a free onboarding course
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    • Create New...