Jump to content
Ultimaker Community of 3D Printing Experts

Why can't I see the imported stl's on the build plate sometimes? They are manifold, normal are fine... just shows a shadow.


rw3iss
 Share

Recommended Posts

Posted · Why can't I see the imported stl's on the build plate sometimes? They are manifold, normal are fine... just shows a shadow.

Many times when I import a .stl file into Cura, it only shows its shadow on the ground. 

I've verified the model has good normal, and is manifold everywhere.

The scale seems fine. 

Does anyone have any idea why this happens?

Please see pictures, and the included .stl files for reference. The '1_fixed.stl' file is the same as 1.stl, but run through Netfab's STL fixer service, just to see if that would work (it doesn't).

 

I would love to figure this out. I like Cura better than other slicers, but I often can't use it because of this problem.

 

2021-02-16_12-24.png

2021-02-16_12-25.png

1.stl 1_fixed.stl

  • Link to post
    Share on other sites

    Posted · Why can't I see the imported stl's on the build plate sometimes? They are manifold, normal are fine... just shows a shadow.

    I took a look at the file. The first thing I noticed was the scaling of the object. The object had an actual size of about 0.25mm in height. you can see the amount of automatic scaling on the object. And, it came in at the floor of the virtual baseplate. I do uncheck the auto-drop to plate in my basic setup. I am also still on Cura 4.4. No other reason than it is working for me right now and I am still re-learning the software as a whole.

    Scaling.thumb.Jpg.07e75fdc6db2ee99a7d028811b305b1a.Jpg

     

    I then ran it through 3DS MAX and did an STL Check and it came out ok. So, no errant vertices or polygons floating out in space. I have evaluated models before with the same problem and that one, unforgotten, tiny little piece of errant geometry have usually been the problem. But, before you print, you should look at the faceting of the image. See how it looks like the sides of a disco ball with a bunch of flat planes. This is how it will print. And, you can see it in MAX as well:

    Facets.thumb.Jpg.3648dc2255ff68d17b59bb85a8991136.Jpg

     

    No knowing the size you choose to print at, I scaled the original up to about 7 inches in height and that may make it easier for you to size it to your specs.

    209603569_OpeningTest2_Fixed.stl

     

    So, the meshfixer you ran the model through did not find errors, because technically, there were no errors in the geometry. It worked as designed. But I think the scaling was a huge issue. I also do not know if the Prusa setup is correct or if should behave differently. But it came into my Cura 4.4/S5 flawlessly.

     

    So, while I cannot say what your issue is (one issue of a combo of one or two things that are not model related) but I hope the 'fixed' model works for you. 🙂

     

    What was the source of the model? Program or download or....?

  • Link to post
    Share on other sites

    Posted · Why can't I see the imported stl's on the build plate sometimes? They are manifold, normal are fine... just shows a shadow.

    Hi @kmanstudios Many thanks for your effort in helping!

    I am using Blender 2.9 for the modeling.

     

    I did get the model to work after I applied some other modification and exported at 100x the scale.

    However, if I still load the original stl (attached above), and scale it up in Cura, I still don't see it. Maybe it's just an issue with Cura's lowest import setting or something. However, I *can* see the object if I scale it up to way beyond the build plate size, oddly... If I do re-export the original above at 100x scale, it shows up in Cura.

     

    I don't know why Blender by default exports everything so small. Even when my object is 100mm in height in Blender, exporting at x1 scale, it ends up in any other slicer at .01mm in height. So... seems it was an issue with the scaling, perhaps.

     

    I was confused in Cura because it shows a shadow at the normal/full size... but can't see the actual image, which didn't make sense. I guess I should have tried exporting at a larger scale first.

     

    Also noted on the faceted/square sides. I did smooth it out. Attached is the final, already in the printer 🙂

     

    Thank you, again.

     

    2021-02-16_14-03.png

  • Link to post
    Share on other sites

    Posted · Why can't I see the imported stl's on the build plate sometimes? They are manifold, normal are fine... just shows a shadow.

    In Blender, double check the scale you are modeling at.  It might be 1 meter instead of 1mm.

     

    If you see just a shadow then the model is WAAAYYY up in the Z.  Right click on the build plate and select "Select all Models".  Select the "Movement" tool at the top of the left toolbar and change all the dimensions to "0".  The model should drop to the plate and be centered.

  • Link to post
    Share on other sites

    Posted · Why can't I see the imported stl's on the build plate sometimes? They are manifold, normal are fine... just shows a shadow.

    @GregValiant Ahh that was the issue! It was way up in the Z! Thanks, will remember that one 😉
    Regarding the scale... Blender is set to 'millimeter' units, but it seems I also have the 'Unit scale' set to '10' (instead of 1), so the grid shows a better resolution for normal/printed models. However, changing this back to 1, and re-importing the above STL (it has a ~297mm z-height in Blender), then re-exporting at scale x1 (both in Scene Properties and the Export panel), still has it as very tiny in Cura. As to why, I don't know. Even if I ensure the origin is at (0,0,0), and trying to export with 'Scene Units' checked (and not), it is still importing at a tiny size, and also way up in the Z... doesn't make any sense. Blender bug?

  • Link to post
    Share on other sites

    Posted · Why can't I see the imported stl's on the build plate sometimes? They are manifold, normal are fine... just shows a shadow.

    It happens sometimes with Blender and with Sketchup.  Inventor and Fusion don't seem to have the issue.  I don't know Blender, but it's possible there are options for the STL Export Utility.

  • Link to post
    Share on other sites

    Posted · Why can't I see the imported stl's on the build plate sometimes? They are manifold, normal are fine... just shows a shadow.

    Nod. Someday I'll get into better Blender plugin/project management, probably soon 😛 

    I'd like to try Fusion more, just the web version is way too slow!

     

  • Link to post
    Share on other sites

    Posted · Why can't I see the imported stl's on the build plate sometimes? They are manifold, normal are fine... just shows a shadow.

    With DesignSpark Mechanical I also never had any problems: always correct solid and water-tight models, always nice on the build-plate, always correct size. But it is not suitable for artwork, only for technical models based on geometric shapes.

     

    I had occasional problems, but that was when I had made modeling errors, thus operator-errors, not software-errors.

     

  • Link to post
    Share on other sites

    Posted · Why can't I see the imported stl's on the build plate sometimes? They are manifold, normal are fine... just shows a shadow.

    Thanks @geert_2 I will give it a look!

  • Link to post
    Share on other sites

    Posted · Why can't I see the imported stl's on the build plate sometimes? They are manifold, normal are fine... just shows a shadow.

    I had the same issue, seeing a shadow instead of the STL. The solutions above did not work for me. I ran the inspector tool in meshmixer but it found no problems. I then used the Make Solid tool under Edit in meshmixer. In the object browser, you'll see the original STL and the new object that has solid added to it.

     

    I made the original STL invisible and exported the new solid STL and, Al-hamdulillah, it worked perfectly fine.

     

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...