Jump to content
Ultimaker Community of 3D Printing Experts

Recommended Posts

Posted · Cura slice problem

Hi All, 

 

New user and first time poster here. I just purchased a Tenlog TLD3Pro IDEX printer. They are a chinese company I know...But the printer is actually nice for the money. 

 

So the problem statement is that no matter what printer profile I use the slicer outputs the same start and end Gcode which my printer cannot use. 

 

The test prints are working great(these came on a SD card from the mfg and have the correct start and end gcode) and now I am attempting to slice files of my own in the CURA 4.8 engine that they provided an installer for, it has all the printer presets and materials from them pre-loaded in.  So this is not an official cura installer.  That said, it works well right up until the file is exported.

 

I have the correct printer profile selected and have even tried adding another non-Tenlog printer to see if that fixes the problem it does not.  (See printerprob.jpg)

 

I have attached a gcode file that is for my printer(see 40x300.gcode) and one that Cura is generating with my printer profile.  (See 3DTest.gcode) Youll see the difference right away.

 

Another piece of background is that I did install the official version of CURA from Ultimaker prior to the custom version.  The Tenlog website clearly stated that I had to remove old versions and delete the "cura" folder from the %AppData% and %AppDataRoaming% prior to installing their versions.  I did this.

 

After I installed their version and I noticed I was having the problem I removed cura, deleted the folders again and made sure there was no mention (in hidden folders or otherwise) of ultimaker or CURA on my machine.  Then I reinstalled it and am still having the same problem, no matter what printer preset is chosen, the same gcode is put at the start and end of the files generated.

 

Thanks for your help!  Excited to be part of this community.

 

Screenshot 2021-02-20 092742.png

TD3P-40X300-4h.gcode TLD_3D_Printer_test_fixed_stl_3rd_gen.gcode

  • Link to post
    Share on other sites
    Posted · Cura slice problem

    What exactly is happening that's troublesome?  Is the printer processor locking up?  Wrong temps?  Although the order of the commands is different they appear to be workable.  Cura explicitly calls out T0 at the start and the other file does not.  The other file has M107 P1 (turning off the layer cooling fan of the second extruder) and the Cura file turns off the fan of the active extruder which appears to be T0.

  • Link to post
    Share on other sites
    Posted · Cura slice problem

    I got this working, I am actually not sure what did it but now the start and end gcode appear to be what I want them to be. I uninstalled again and then started messing with the .json definition files.  Adding some dummy lines to see if they show up both in the config and in the posted gcode.  I am not exactly sure what did it but now the correct start and end codes are loading.

     

    I guess I could call this closed but I have no clue what I actually did to fix it.  Not gonna look a gift horse in the mouth tho..

     

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker Transformation Summit

        On April 20 - April 23 we will host the Ultimaker Transformation Summit. Come talk to us via Live chat and get inspired by any of our relevant presentations!
        • 7 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...