Jump to content
Ultimaker Community of 3D Printing Experts

Recommended Posts

Posted · Fans don’t start

Hello, I’m having the following problem every time I start a print. The cooling fans don’t start automatically. I have to turn them on from the printer’s menu. Is there a bug in cura or in printer’s firmware? I use cura 4.8 and marlin firmware. Thank you. 

  • Link to post
    Share on other sites
    Posted · Fans don’t start

    Yeah, it's hard to tell what's going on without seeing your settings.

    After posting your profile, on the right end of the "settings search" box is a drop-down for settings visibility.  One of the options is "All".  When they all show up go down to "Cooling" at look at all the settings.

     

  • Link to post
    Share on other sites
    Posted · Fans don’t start

    What model printer are you using?


    For most Ultimaker printers the hot end cooling fan turns on when your nozzle or Print Core heat to 50C. It cannot be controlled in the settings.


    For your model cooling fans--how long are you waiting for those to turn on? They don't kick on until the second or third layer, in order to prevent adhesion issues.

  • Link to post
    Share on other sites
    Posted · Fans don’t start

    Thank you all for the response but I know about the settings and what to they do and also about the delay until the second layer. I believe it is a software problem. My printer is Sapphire pro by TwoTrees. I attached a photo of my settings for you to see. 

    043F99C7-AFFA-4A1A-8726-CA91C7426C26.jpeg

  • Link to post
    Share on other sites
    Posted (edited) · Fans don’t start

    With the Initial Fan Speed set to 100% and Regular Fan Speed Height at 0 (Cura layer 1) you should see this in the Gcode as the fan should be at 100% right from the start.

    ;LAYER:0
    M106 S255  ;Layer cooling fan at 100%
    ;TYPE:SKIRT

     

    Using the settings you show you will see something like this.

    ;LAYER:0
    M107  ;Layer cooling fan off
    ;TYPE:SKIRT

    then later...

    ;LAYER:1
    M106 S255  ;Layer cooling fan 100%
    ;TYPE:SUPPORT

     

    Open the Gcode file and search for M106.  The units are PWM so they can be from 0 (0%) to 255 (100%).  If they are there, and if you can turn the fan on using the LCD control, then it's a firmware problem.  If there aren't any M106 lines then it's a Cura problem because they are supposed to be there.

     

    EDIT:  The original 4010 layer cooling blower on my Ender 3 Pro would not start to spin until the M106 setting was 30% (PWM 77).  It had sleeve bearings.  The current ball bearing 5015 will start to spin at 12% (PWM  31) and will continue to spin as low as 8% (PWM 20).  So it's possible that the start-up speed of your layer cooling blower is high and the initial M106 settings are just to low to get it to spin.  With my original 4010 - if I asked Cura to increase fan speed to 28% over 5 layers the fan would get the signal, but it wouldn't start to spin. 

    Edited by GregValiant
    Another thought
    • Like 1
    Link to post
    Share on other sites
    Posted (edited) · Fans don’t start

    So I guess it is a firmware problem because the M106 code exists in the file, as you said. Can anyone provide me with a marlin firmware? Do you know if I can load a different firmware on my printer?

    Edited by faraso
  • Link to post
    Share on other sites
    Posted · Fans don’t start

    It depends on the printer.  Some need a bootloader installed first.  On others you can simply load from an SD card.  It's hard to believe that M106 and M107 weren't enabled in the firmware.  Controlling the fan is very basic to 3D printing.  You never mentioned the printer manufacturer or model.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker Transformation Summit

        On April 20 - April 23 we will host the Ultimaker Transformation Summit. Come talk to us via Live chat and get inspired by any of our relevant presentations!
        • 5 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...