Jump to content

Disable Z hop after a certain layer height


valemaio2

Recommended Posts

Posted · Disable Z hop after a certain layer height

Hi all, following this video I was playing with Z hop to print an inlay on the bottom of my print (the TL;DR is print the small inlay first, then print the rest with Z hop enabled to a value higher than the inlay height). It works well, but there's a caveat: on a printer with an imprecise Z axis (like my Ender 3), having Z hop enabled can lead to a messy print, as the imprecisions on the Z will sum up quickly with every hop.

 

Leaving aside the obvious fact that the Z precision should be high enough to be able to use Z hop for the whole print, the next best way would be to disable the Z hop right after the second print height has gone above the first inlay height. I couldn't find an easy way to do so (I had to manually edit the gcode), would it be possible to have this option, either in the post-processing or as an option for the Z hop?

 

Thank you.

  • Like 4
Link to post
Share on other sites

  • 3 months later...
  • 4 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Our picks

    • UltiMaker Cura 5.4 stable released
      The full stable release of UltiMaker Cura 5.4 is here and it makes it easier than ever to remove brims and supports from your finished prints. UltiMaker S series users can also look forward to print profiles for our newest UltiMaker PET CF composite material!
        • Like
      • 58 replies
×
×
  • Create New...