Jump to content
Ultimaker Community of 3D Printing Experts

Recommended Posts

Posted (edited) · Print Starts off the bed

Open the gcode file in a text editor like Notepad.  Go down to "Layer:0" and see what the "Z" is.  It should be at your "Initial Layer Height".  It should be noted just above or below Layer:0 line.

If it isn't your Initial Layer Height, then maybe you have a Z-offset in Cura?  Was the model located on the bed or above it?

If that Z in the gcode is at the Initial Layer Height, then are your Home Offsets correct?  Is the bed in the correct Z relation to the nozzle?  Getting the Z to zero is part of the leveling process.  If you have an ABL maybe the Z-offset there is incorrect.

Edited by GregValiant
  • Link to post
    Share on other sites
    • 3 weeks later...
    Posted · Print Starts off the bed

    Thanks, but the problem is not with z axis. It prints the right height, but it starts printing too far off the left of the board as you're facing it (that means the x axis is starting negative numbers right?). How do we fix that?

  • Link to post
    Share on other sites
    Posted · Print Starts off the bed

    Sorry.  I misinterpreted "off the bed".

     

    Open the Gcode file.  Right near the beginning will be a line ";MINX" and  one for ";MINY".  If either of them is negative then that's the problem.

    In Cura click on the name of your printer.  Choose Manage Printers and then Machine Settings.  On the left there is a box "Origin at Center".  Make sure that is de-selected.  Most printers have the origin at the left front corner.  Delta printers have the origin at center.

     

    The Home Offsets in the printer, coupled with the Bed Size in Cura also determine where a print will be on the bed.  But first make sure Origin at Center is not checked and then slice something.  You don't have to print it, just check the MINX and MINY to insure it will print in the positive octant.

    • Thanks 1
    Link to post
    Share on other sites
    • 2 weeks later...
    Posted · Print Starts off the bed

    My MINX and MINY is negative. That is my problem. Do I just delete the negatives or change the numbers too? Also, when I try to edit the gcode it doesn't change anything. Thanks!

  • Link to post
    Share on other sites
    Posted (edited) · Print Starts off the bed

    The normal X=0, Y=0 is the left from corner.  Delta printers use "Origin at Center", but essentially no other printers use it, so make sure it's turned off in the Machine Settings in Cura.

     

    You cannot just replace the negative signs in a gcode file to fix it.  Consider that if an extrusion went from X-100 to X+100 and you removed the negative sign, instead of an extrusion 200mm long it would be 0mm long.

     

    You didn't mention the printer, but if you absolutely gotta haveta print that particular gcode file you can change the Home Offsets by adding a line to the beginning of the gcode file:

    M206 X115 Y115

    Where the "115"'s are 1/2 the X and 1/2 the Y of the build plate size.  You would also need to add a line to the end of the gcode - M206 X(original X home offset) and Y(original Y home offset) to reset the numbers or it might be off for the next print (powering the printer off and then on will reset it also).

     

    Edited by GregValiant
    • Thanks 1
    Link to post
    Share on other sites
    Posted · Print Starts off the bed

    Did you re-slice that and make a new Gcode file?

     

    The MinX and MinY show as positive numbers in the file heading but that isn't true.  There are negative values throughout the gcode file.  MinX is listed as 34.8 but in the lines of gcode it is -34.8.  MinY is shown as 18.8 but it's really -18.8

    These are some lines I picked out of the gcode.  All these points are negative numbers and are off the build plate.

    G1 X-34.6 Y-3.986 E5.6557
    G1 X-34.564 Y-4.992 E5.73605
    G1 X-34.554 Y-5.127 E5.74686
    G1 X-34.452 Y-6.044 E5.82051

    That is what would be expected if "Origin At Center" was ticked in the Machine Settings.  It's wrong.  You can open the Gcode file in Cura and look at it in the preview (but you cannot change it).  The center of the model is in the left front corner and 3/4 of it is in negative areas.  If you have definitely UN-CHECKED "Origin At Center" when you sliced that model and generated the Gcode then you may need to re-install Cura.  What is happening is incorrect.

  • Link to post
    Share on other sites
    Posted · Print Starts off the bed

    Thank you so much! I reinstalled Cura to 4.9 and it prints dead center now. I will leave you updates on the other part. Thaks!

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker Transformation Summit

        On April 20 - April 23 we will host the Ultimaker Transformation Summit. Come talk to us via Live chat and get inspired by any of our relevant presentations!
        • 14 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...