Jump to content
UltiMaker Community of 3D Printing Experts

Hide walls on top of model


gone_bush
 Share

Recommended Posts

Posted · Hide walls on top of model

The problem: The external and internal walls go all the way to the top - the "top" layer is just an "insert" between these walls.

 

Q: How can I make the top layer a complete "cap"?

 

  • Link to post
    Share on other sites

    Posted · Hide walls on top of model

    I guess he doesn’t want the regular walls on the top layers, but I don’t know why there could be an issue with them.

    You can get rid of the extra wall around the top infill (the option is called „Extra skin wall count) but not the walls, or you can switch to concentric infill, then everything looks the same.

  • Link to post
    Share on other sites

    Posted · Hide walls on top of model

    I don't get it either, but it isn't hard to do.  I think.  Maybe.

     

    Let's assume a layer height of 0.2mm.  

    Using a cutting mesh for just the top layer you can set the Wall Line Count = 0 and the Extra Skin Wall Count = 0.  That will cause the top layer skin to go to the edges of the model with no walls.  In the picture below the part is 100 x 100 x 25.  The mesh is 100 x 100 x 0.2 and it's bottom is located at Z = 24.8.  This means no walls (and raggedy edges) around the top of the part.  Changing the Top/Bottom Line Directions to [0,90] helps a bit as seen in the second image.  It will still be messy on 2 sides.

     

    Untitled.thumb.png.ba51151e26165449f1762d8937e1f538.png

     

    UCS.thumb.png.f603c19ef9e7ba82d6523dbb707b432f.png

    • Like 1
    Link to post
    Share on other sites

    Posted (edited) · Hide walls on top of model

    Bring in a support blocker.  Select the Support Blocker.

    Using the SCALE tool, de-select "Uniform Scaling"

    • Set the X and Y sizes sufficient to cover the area you want to change.
    • Set the Z = {Layer Height} * {number of layers you want to change}.  You only want the top layer, then the Z dimension would be 1 layer thickness.
    • Select the Move tool and move the Support Blocker into position over the model.
    • Select the tool above the Support Blocker tool (it has 4 small shapes on it).
    • Select "Modify Settings for Overlaps".
    • Select "Infill Mesh Only" and change it to "Cutting Mesh"
    • Select "Select Settings" and under Shell select Wall Line Count and Extra Skin Wall Count.  Close the dialog.
    • Set the Wall Line Count to 1.
    • Set the Extra Skin Wall Count to 0.
    • Move what was a Support Blocker and is now a Cutting Mesh into the correct Z position so the top of the mesh is the same as the top of the model.

    Here is a block with a single wall for the top 4 layers.  If you select the "Eraser" you can change the Wall Line Count to 0 and there will be no walls for the top 4 layers.

     

     

    GregV_cubetestv6.3mf

    Edited by GregValiant
    • Like 1
    • Thanks 1
    Link to post
    Share on other sites

    Posted · Hide walls on top of model

    I'm trying to return to Cura for reasons of (hopefully) better control of preventing the nozzle from crossing through the inner contour of cylindrical objects (I don't want any stringing on the inside of my "tubes", on the outside is not a problem).

     

    But I've been using Super Slicer for a long time now (started with Cura) and there is a nice option for this (Walls are Perimeters there):
    Print Settings > Perimeters & Shell > Quality > Only one perimeter - On first layer [...]  On top surfaces [...]

     

    That way it'll print one single wall (takes care of ugly edges of line or zigzag solid infill) and then fill up the entire surface with infill. Very neat option which I used a lot, but I can't find a similar "easy" option in Cura. So using a modifier for the top layer indeed appears to be the only way...

  • Link to post
    Share on other sites

    Posted · Hide walls on top of model

    A picture would really be helpful.  I'm not sure what you're trying to do.

    "Stringing on the inside" can be taken care of by adjusting the combing style and setting the layer start point near the Z seam location.  That way it shouldn't have to cross the center.

     

    Here is a project file.  I added two support blockers, configured them as Cutting Mesh and set the Per Model settings to a single wall and no extra skin wall.  They are 0.2mm thick and one is on the bottom and one is on the top.

     

    Here is the top layer.

    image.thumb.png.6331605c8f0cb1edc9bf0f0443004c79.png

     

    This is the layer below the top.

    image.thumb.png.9e6868e79ef324d4e41f27bbd29298f4.png

     

    SingleWallTopBtm.3mf

  • Link to post
    Share on other sites

    Posted · Hide walls on top of model

    @kayazuki - pictures please.  It's unclear if you want to remove extra lines only on the top layer maybe?  Or if you have hollow cylinders with air inside.  And are you printing a single cylinder at a time?  Really a picture would be very helpful.

     

    If you are printing hollow cylinders with an open top and you don't want internal stringing there are 3 things to try.  The first is "combing".  Make sure that is enabled.  If the cylinder is very large it may be disabling combing for some layers but in layer view if it is doing "combing" there should be zero internal travel moves inside your cylinder.  If there are some let us know (another photo would help) and there are a few settings that override combing that we can look at.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    ×
    ×
    • Create New...