Jump to content

Cura won't connect to my printer.

Recommended Posts

Posted · Cura won't connect to my printer.


I'm unable to connect Cura to my printer. I've tried

sudo adduser xxx dialout
sudo usermod -a -G dialout xxx


Neither help (I replaced xxx with my username of course).


I have to boot into windows to update firmware which is annoying.


Anything else to be tried?




davidramiro v1.4.6 firmware (Marlin 1.1.9)

Anycubic Mega S

Cura 4.8.0


Ubuntu connected to printer


  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.4 stable released
        The full stable release of UltiMaker Cura 5.4 is here and it makes it easier than ever to remove brims and supports from your finished prints. UltiMaker S series users can also look forward to print profiles for our newest UltiMaker PET CF composite material!
          • Like
        • 58 replies
    • Create New...