Jump to content
Ultimaker Community of 3D Printing Experts

Ultimaker Cura 4.9


fvrmr

Recommended Posts

Posted · Ultimaker Cura 4.9

We missed the dual extrusion issue. It's something that we should have caught but didn't. Since a lot of people have also reported this on github (thanks for that!), we already have fix for this and have changed the tests that we run per release so that this shouldn't happen anymore. We do print a dual extrusion model every release, but the model that we used didn't exhibit the problem (Which was unfortunately one of the few models that didn't have the issue...). As people might have noticed, we also didn't get any reports about this during the beta (which is unfortunate, but the primary responsibility for it not being found is with us and not with the beta users!)

We've also found a fix for the X:/ drive issue, which should also prevent the slowdown that some people experienced.

As you might have noticed, it's a bit hard to keep track of things on the forum, so please provide bug reports on our issue tracker on github (and again thanks to those that did and helped us find out what was going on).

An update for 4.9 is almost done and should be out soonish.
 

  • Like 2
  • Thanks 1
Link to post
Share on other sites

Posted · Ultimaker Cura 4.9
1 hour ago, nallath said:

We missed the dual extrusion issue. It's something that we should have caught but didn't. Since a lot of people have also reported this on github (thanks for that!), we already have fix for this and have changed the tests that we run per release so that this shouldn't happen anymore. We do print a dual extrusion model every release, but the model that we used didn't exhibit the problem (Which was unfortunately one of the few models that didn't have the issue...). As people might have noticed, we also didn't get any reports about this during the beta (which is unfortunate, but the primary responsibility for it not being found is with us and not with the beta users!)

We've also found a fix for the X:/ drive issue, which should also prevent the slowdown that some people experienced.

As you might have noticed, it's a bit hard to keep track of things on the forum, so please provide bug reports on our issue tracker on github (and again thanks to those that did and helped us find out what was going on).

An update for 4.9 is almost done and should be out soonish.
 

Great to hear that!

I have multiple Ultimaker printers and was really excited to try out the digital library function when 4.9 was announced. Sadly, with those bugs it was better to switch back to 4.8 which didn't have the "save to library" function.

Looking forward for it!

  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker Cura 4.9

    Hello,

    using 4.8.0.

    Installing 4.9.0 / 4.9.1 will be done, but when I start after "Loading UI" very short the headline of the software will shown.

    So, actually I´m not able to use the latest release on Windows 7 which is on the support list.  Found the file stderr.log, it means that there are a lot of problems with Python.

     

    stderr.log

    Edited by mrpresident
  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker Cura 4.9

    This update is already installed the file told me.

    Any other suggestions?

     

    As I discribed above.... 4.9.x was loaded until "Loading UI". Then a frame with the headline appears for a second, you can read Cura and so on. Then all of them close and nothing happens anymore. For more details watch out the logfile in the mail before. Python will be pointed as the troublemaker 🙂

     

    Here you can see whats happened.... the second pic shows for a short time these part of the windows/frame

     

    grafik.png.1a42e19f43f46ad5b7db4060e2597404.pnggrafik.png.d5e8b80819101d43b995820b664f5ed3.png

     

    Edited by mrpresident
  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker Cura 4.9

    You could try https://www.microsoft.com/en-us/download/confirmation.aspx?id=26764

     

    Another thing to check is gpu drivers. The logs show that the error happens when loading shader programs into the gpu.

    Edited by ahoeben
  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker Cura 4.9

    Download is no longer accessible 😞

    If you meant my graphic card, there is no newer driver as already is installed.

    If so, something in 4.9.x has been changed!!

    Don´t worry, I´ ´m happy with 4.8.0 🙂

     

    Edited by mrpresident
  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker Cura 4.9

    same issue with win 7... before (cura 4.8) all is fine...

     

    all suggested windows update are alreeady installed... cleaned also appdata folder...

     

    no way to run cura 4.9

    Edited by sminervini
  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.9

    hi all .

    I hope I'm in the right place.

    I've now installed 4.9.1.

    now when I send print from fusion 360 to open cura it fails saying priverliges not available .

    works fine on 4.8.0.

    I've read lots about using custom and picking cura in applications. still no good.

    does any one now how to fix this.? or any  advise that might help.

    thanks d

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.9

    Will be following this thread with interest.

     

    As much as I love my Ultimaker S5 (and that's a lot), I will not be upgrading from Cura 4.8.0 to any other version, unless I see a unanimous positive reaction to the new version from the community. I've wasted two days trying to "fix" my printer, and it was all due to a buggy Cura 4.9.0. Most importantly, I unsealed a brand-new spool of Ultimaker PVA (I thought the old one was to blame) which is now slowly degrading and absorbing moisture.

     

    I know we should all be trying new things, helping out, etc., but I'm afraid I cannot afford any more printer downtime right now, so I will stick to the excellent and stable Cura 4.8.0 for the time being.

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.9

    this my sterr

     

     

     

    Fatal Python error: Aborted

    Thread 0x00002568 (most recent call first):
      File "C:\Program Files\Ultimaker Cura 4.9.1\plugins\USBPrinting\USBPrinterOutputDeviceManager.py", line 79 in _updateThread
      File "threading.py", line 870 in run
      File "threading.py", line 932 in _bootstrap_inner
      File "threading.py", line 890 in _bootstrap

    Thread 0x00002244 (most recent call first):
      File "threading.py", line 306 in wait
      File "zeroconf\__init__.py", line 2117 in wait
      File "zeroconf\__init__.py", line 1434 in run
      File "threading.py", line 932 in _bootstrap_inner
      File "threading.py", line 890 in _bootstrap

    Thread 0x00000a64 (most recent call first):
      File "threading.py", line 306 in wait
      File "threading.py", line 558 in wait
      File "C:\Program Files\Ultimaker Cura 4.9.1\plugins\UM3NetworkPrinting\src\Network\ZeroConfClient.py", line 81 in _handleOnServiceChangedRequests
      File "threading.py", line 870 in run
      File "threading.py", line 932 in _bootstrap_inner
      File "threading.py", line 890 in _bootstrap

    Thread 0x00002e94 (most recent call first):
      File "threading.py", line 306 in wait
      File "zeroconf\__init__.py", line 2117 in wait
      File "zeroconf\__init__.py", line 1262 in run
      File "threading.py", line 932 in _bootstrap_inner
      File "threading.py", line 890 in _bootstrap

    Thread 0x00000c2c (most recent call first):
      File "zeroconf\__init__.py", line 1183 in run
      File "threading.py", line 932 in _bootstrap_inner
      File "threading.py", line 890 in _bootstrap

    Thread 0x00002c8c (most recent call first):
      File "C:\Program Files\Ultimaker Cura 4.9.1\plugins\RemovableDriveOutputDevice\RemovableDrivePlugin.py", line 61 in _updateThread
      File "threading.py", line 870 in run
      File "threading.py", line 932 in _bootstrap_inner
      File "threading.py", line 890 in _bootstrap

    Thread 0x00002690 (most recent call first):
      File "C:\Users\ultimaker\AppData\Local\Temp\cura-build-4.9-exe\build\inst\lib\python3.8\site-packages\UM\Backend\Backend.py", line 165 in _storeStderrToLogThread
      File "threading.py", line 870 in run
      File "threading.py", line 932 in _bootstrap_inner
      File "threading.py", line 890 in _bootstrap

    Thread 0x00002c3c (most recent call first):
      File "C:\Users\ultimaker\AppData\Local\Temp\cura-build-4.9-exe\build\inst\lib\python3.8\site-packages\UM\Backend\Backend.py", line 153 in _storeOutputToLogThread
      File "threading.py", line 870 in run
      File "threading.py", line 932 in _bootstrap_inner
      File "threading.py", line 890 in _bootstrap

    Thread 0x000010c4 (most recent call first):
      File "threading.py", line 302 in wait
      File "threading.py", line 433 in acquire
      File "C:\Users\ultimaker\AppData\Local\Temp\cura-build-4.9-exe\build\inst\lib\python3.8\site-packages\UM\JobQueue.py", line 98 in _nextJob
      File "C:\Users\ultimaker\AppData\Local\Temp\cura-build-4.9-exe\build\inst\lib\python3.8\site-packages\UM\JobQueue.py", line 124 in run
      File "threading.py", line 932 in _bootstrap_inner
      File "threading.py", line 890 in _bootstrap

    Thread 0x00002f58 (most recent call first):
      File "threading.py", line 302 in wait
      File "threading.py", line 433 in acquire
      File "C:\Users\ultimaker\AppData\Local\Temp\cura-build-4.9-exe\build\inst\lib\python3.8\site-packages\UM\JobQueue.py", line 98 in _nextJob
      File "C:\Users\ultimaker\AppData\Local\Temp\cura-build-4.9-exe\build\inst\lib\python3.8\site-packages\UM\JobQueue.py", line 124 in run
      File "threading.py", line 932 in _bootstrap_inner
      File "threading.py", line 890 in _bootstrap

    Thread 0x00002788 (most recent call first):
      File "threading.py", line 302 in wait
      File "threading.py", line 433 in acquire
      File "C:\Users\ultimaker\AppData\Local\Temp\cura-build-4.9-exe\build\inst\lib\python3.8\site-packages\UM\JobQueue.py", line 98 in _nextJob
      File "C:\Users\ultimaker\AppData\Local\Temp\cura-build-4.9-exe\build\inst\lib\python3.8\site-packages\UM\JobQueue.py", line 124 in run
      File "threading.py", line 932 in _bootstrap_inner
      File "threading.py", line 890 in _bootstrap

    Thread 0x0000178c (most recent call first):
      File "threading.py", line 302 in wait
      File "threading.py", line 433 in acquire
      File "C:\Users\ultimaker\AppData\Local\Temp\cura-build-4.9-exe\build\inst\lib\python3.8\site-packages\UM\JobQueue.py", line 98 in _nextJob
      File "C:\Users\ultimaker\AppData\Local\Temp\cura-build-4.9-exe\build\inst\lib\python3.8\site-packages\UM\JobQueue.py", line 124 in run
      File "threading.py", line 932 in _bootstrap_inner
      File "threading.py", line 890 in _bootstrap

    Current thread 0x00002e6c (most recent call first):
      File "C:\Users\ultimaker\AppData\Local\Temp\cura-build-4.9-exe\build\inst\lib\python3.8\site-packages\UM\View\GL\ShaderProgram.py", line 138 in setFragmentShader
      File "C:\Users\ultimaker\AppData\Local\Temp\cura-build-4.9-exe\build\inst\lib\python3.8\site-packages\UM\View\GL\ShaderProgram.py", line 95 in load
      File "C:\Users\ultimaker\AppData\Local\Temp\cura-build-4.9-exe\build\inst\lib\python3.8\site-packages\UM\View\GL\OpenGL.py", line 197 in createShaderProgram
      File "C:\Program Files\Ultimaker Cura 4.9.1\plugins\SolidView\SolidView.py", line 156 in _checkSetup
      File "C:\Program Files\Ultimaker Cura 4.9.1\plugins\SolidView\SolidView.py", line 212 in beginRendering
      File "C:\Users\ultimaker\AppData\Local\Temp\cura-build-4.9-exe\build\inst\lib\python3.8\site-packages\UM\Qt\Bindings\MainWindow.py", line 238 in _render
      File "C:\Users\ultimaker\AppData\Local\Temp\cura-build-4.9-exe\build\inst\lib\python3.8\site-packages\UM\Qt\QtApplication.py", line 383 in exec_
      File "C:\Users\ultimaker\AppData\Local\Temp\cura-build-4.9-exe\build\inst\lib\python3.8\site-packages\cura\CuraApplication.py", line 862 in run
      File "C:\Users\ultimaker\AppData\Local\Temp\cura-build-4.9-exe\build\inst\bin\cura_app.py", line 241 in <module>
      File "Console.py", line 36 in run
      File "__startup__.py", line 74 in run
     

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.9

    I´  m agree with you, guys.

     

    @mechanic75

    To give priviliges to folder and files add the user who should in the admin group to drive 😄 and submid all files and folders to add fullly rights.

     

    @DrCeeVee

    I´´ m going back to 4.8.0. Even I could really find some benefits the new release. At least I´´ m sorry to tell mostly using Prusa slicer with works through all releases perfectly.

     

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.9

    Hi the graphic for my current printer is really skewed.  The zoom point or vanishing point is high off to the right behind the printer so the printer and hence the build surface/plate is almost always on an angle which means the object you're printing is always viewed at an skewed angle which makes it impossible to position and view properly.  No amount of rotating or shifting levels it up.

    Screen Shot 2021-05-17 at 2.01.09 pm.png

    Screen Shot 2021-05-17 at 2.02.50 pm.png

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.9

    What does your problems refers to not running Cura 4.9.x on Windows 7???

    Update your grahpic card driver could help. If not able while to old, bad luck 🙂

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.9

    Am running on mac. The problem is the zoom point is high and behind the printer instead of where the zoom point should be which is the middle of the print bed.

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.9
    On 5/16/2021 at 10:03 AM, DrCeeVee said:

    Will be following this thread with interest.

     

    As much as I love my Ultimaker S5 (and that's a lot), I will not be upgrading from Cura 4.8.0 to any other version, unless I see a unanimous positive reaction to the new version from the community. I've wasted two days trying to "fix" my printer, and it was all due to a buggy Cura 4.9.0. Most importantly, I unsealed a brand-new spool of Ultimaker PVA (I thought the old one was to blame) which is now slowly degrading and absorbing moisture.

     

    I know we should all be trying new things, helping out, etc., but I'm afraid I cannot afford any more printer downtime right now, so I will stick to the excellent and stable Cura 4.8.0 for the time being.

    Well Spoken ......I am doing the same  

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.9

    @gsar333 What printer is that?  I haven't seen that sort of problem before.

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.9

    This is not related to the main topic which was the not loading 4.9.x on Windows 7....

    I´m not interested about failures on a MAC!!!

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.9

    Actually the main topic is stated by @fvrmr in the opening post and is "We are happy to announce that the Ultimaker Cura 4.9 is here.".  (I'm not sure how long the happiness lasted.)  Many of the following posts are in regard to various issues that user's have had with the release.

    • Like 2
    Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.9

    @GregValiant: you might be right, but the most intention is to find out why 4.9.x does not run under Windows 7. W7 does not related to MAC, so MAC should have surely a own section....

  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker Cura 4.9
    On 5/19/2021 at 8:53 AM, mrpresident said:

    @GregValiant: you might be right, but the most intention is to find out why 4.9.x does not run under Windows 7. W7 does not related to MAC, so MAC should have surely a own section....

    Not quite. This is the general release thread for Cura 4.9, not specifically for issues with Cura on Windows 7. You are welcome to keep discussing with others the issues you are seeing, but please be mindful that this thread is open to all Cura users, regardless of if they are using Windows, Mac, or Linux.

     

    The Cura developers recommend reporting issues on the GitHub for Cura, which allows them to get additional information from you and better help resolve issues:  https://github.com/Ultimaker/Cura/issues

    Edited by Priddy
    formatting
    • Like 2
    Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.9
    1 hour ago, mrpresident said:

    to find out why 4.9.x does not run under Windows 7

    But: Cura 4.9.x DOES run under Windows 7 -with no issues. Believe me, I use Win7. So your problem might be hardware-related

    • Like 1
    Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.9

    Win 7 64 bit.

    For Win 7 32 bit you have to use the SmartAvionics 32 bit branch/version.

    • Like 1
    Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.9

    Greg makes a good point - do you have win7 32 or 64 bit?  You can check by hitting window key, right clicking on computer and show properties (this is from memory so could be off a bit but google is your friend).

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share


    • Our picks

      • The Ultimaker Showcase — October 14. What's new?
        Your dear friends at Ultimaker have some exciting news and insights for you!
         
        • 0 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 10 replies
    ×
    ×
    • Create New...