Jump to content
UltiMaker Community of 3D Printing Experts

Cannot select specific printer in Cura with 4.9


Recommended Posts

Posted · Cannot select specific printer in Cura with 4.9

I own two UM3's, normal and extended. I rely on being able to select the specific printer I send my files to since each runs different filaments.


Now in 4.9, I cannot choose which printer to send the file to. The selection is disabled for anything besides "Automatic". Worse, I can't seem to target a specific printer from the web manager.


Help? How am I supposed to manage targeting a specific printer? I had to spend hours connecting and disconnecting printers to get this workflow figured out in the first place, it's very unintuitive. Cura and digital factory are always yelling with notifications that groups aren't supported anymore, then I'm forced to make a group to target a specific printer, now I can't even do that anymore.


Was planning on buying two more UMs by the end of the year but if this basic feature can't be sorted in a somewhat intuitive way I'm not sure how to move forward.


  • Link to post
    Share on other sites

    Posted · Cannot select specific printer in Cura with 4.9

    If you add both of the printers individually to DF and login via cura, it will add two machines in cura.

    So in your case it would add a machine called "Noah" and another one called "LongBoi". If you select LongBoi in cura, it will send the print to that machine.

    So basicly the machine selection is done in the top left corner (if both machines are connected to the cloud, you should have 2 machines listed under "connected printers")


  • Link to post
    Share on other sites

    Posted (edited) · Cannot select specific printer in Cura with 4.9

    @nallath I have tried doing that, though it keeps trying to put the printer in a group. All day yesterday I could toggle between the two, then just now I tried to print and it said I couldn't send something directly to LongBoi because it's not configured as part of a group. Really inconsistent behaviour.

    I've already set up each printer individually, twice. Per the screenshots below it keeps shoving LongBoi into a group which is super frustrating since it's random if I can print to it or not. 



    Edited by ddrsarah
    Adding screenshots
  • Link to post
    Share on other sites

    Posted · Cannot select specific printer in Cura with 4.9

    If the printer is in a group, that's something that is handled in the firmware, not in Cura. I can't really help you debug the firmware, since it's been a few years since i last worked on that, sorry.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Our picks

      • New here? Get ahead with a free onboarding course
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    • Create New...