Jump to content
Ultimaker Community of 3D Printing Experts

Neueinsteiger mit Cura


Pali64
 Share

Recommended Posts

Posted · Neueinsteiger mit Cura

Hallo alle miteinander.

Ich arbeite seit x Jahren auf dem WANHAO Duplicator 4 mit ReplicatorG software.

Da aber die Anforderungen immer komplexer wurden versuche ich seit einer Woche auf CURA umzusteigen was einfach nicht klappen will :-(

Zu meinem Problem:

Ich habe die Firmware vor einiger Zeit auf "Sailfish" umgestellt was fiele Vorteile brachte.

 

Nun zu meinem Problem:

Wenn ich mit ReplicatorG ausdrucke stimmt alles ausser man halt einfach nicht gerade perfekte ausdrucke erhält, da die Software einfach zu alt ist

und auch der Slicer nicht umbedingt gerade TOP....

Wenn ich nun mit CURA die selben STL Importiere scheint auch alles in ordnung zu sein, zumindest in der Vorschau.

Drucke ich nun aber das File aus, ist das Objekt gerade mal noch halbsogroß wie es sein soll, und die beiden düsen drucken

nebeneinander! ich habe zig Seiten durchgeschaut und auch versucht einstellungen zu ändern (bspw. Versatz des rechten Extruder um 33.3mm),

Aber egal was ich einstelle das ergebnis bleibt das selbe! ..nur halb so gross und um 33.3 mm versetztder Extruder 2!

Was mache ich da falsch?

Habe auch versucht Profile von Tingsverse zu installieren die die Configuration einladen,

Trotzdem immer noch das selbe Resultat

Habe versucht die Steps X,Y und Z Achse von 50 auf 25 pro mm zu stellen, aber das macht keine änderung im ausdruck?!?

Wie schon gesagt, ich habe keinerlei Erfahrung mit cura !!

Auf meinen anderen 3D Drucker habe ich komplett andere Software damit habe ich keinerlei probleme nur CURA und ich können wohl so grad garnicht miteinander :-(

 

Kann mir einer Halfen was mache ich falsch?

 

 

  • Link to post
    Share on other sites

    Posted (edited) · Neueinsteiger mit Cura

    Hallo,

     

    Kurz vorweg ich kenne deinen Drucker nicht

     

    13 hours ago, Pali64 said:

    Drucke ich nun aber das File aus, ist das Objekt gerade mal noch halbsogroß wie es sein soll, und die beiden düsen drucken

    nebeneinander!

     

    Du kannst mal ein gcode teilen evtl. einen von Cura + von deinen alten Slicer Programm

     

    Aber ich glaub nicht das dass von Cura kommt, sondern an deinen Drucker liegt und wenn das der fall ist kann ich dir da nicht viel helfen

     

    13 hours ago, Pali64 said:

    Aber egal was ich einstelle das ergebnis bleibt das selbe! ..nur halb so gross und um 33.3 mm versetztder Extruder 2!

     

    Also falls du das in Cura änderst bringt das dir je nachdem welche Einstellung gesetzt ist Garnichts bzw. dein 2ter Extruder ist doch fest, also was bezweckst du mit dieser Änderung???

    Es gibt eine Einstellung die man mit den Plugin "Printer Settings" sehen kann diese heißt "Versatz mit Extruder" wenn diese aktiviert wird der Versatz von Cura berechnet aber gleichzeitig drucken kommt aber trotzdem nicht von Cura

    Vielleicht hängt es mit der Einstellung "Extruder teilen sich Heizelement" zusammen glaub ich aber nicht.

     

    13 hours ago, Pali64 said:

    Habe versucht die Steps X,Y und Z Achse von 50 auf 25 pro mm zu stellen, aber das macht keine änderung im ausdruck?!?

     

    Wo hast du das geändert

    Cura überträgt keine Firmware Einstellungen an deinen Drucker da kannst du reinschreiben was du willst in Cura.

     

    Also ich glaub du hast ein Drucker Problem mit deiner Firmware Einstellungen und du kennst dich zusätzlich zu Cura mit deiner Drucker/Firmware nicht aus.

    Kann sein das ich mich täusche aber mit dieser Info, die ich noch recht wirr finde, kann ich dir nicht mehr Helfen

    Also Teile mal ein paar handfeste Daten, gcode evtl. Cura Projekt, alter gcode von deinen Alten Programm und dann kann ich dir evtl. sagen das es nichts mit Cura zu tun hat, deine Probleme

     

    Gruß

    Edited by zerspaner_gerd
  • Link to post
    Share on other sites

    Posted · Neueinsteiger mit Cura

     

    Hallo zerspaner_gerd, erst einmal Danke für deine Antwort.

     

    16 hours ago, zerspaner_gerd said:

    Hallo,

     

    Kurz vorweg ich kenne deinen Drucker nicht

     

    Die  Firmware ist Sailfish 7.7 der Drucker ist ein Wanhao Duplicator 4

    16 hours ago, zerspaner_gerd said:

    Aber ich glaub nicht das dass von Cura kommt, sondern an deinen Drucker liegt und wenn das der fall ist kann ich dir da nicht viel helfen

     

    Mit dem ReplicatorG zeigt der Drucker kein Versatz und mit dem FlashPrint Programm als 

    "Flashforge Creator PRO" configuriert, drukt er ebenfalls ohne Probleme (größe stimmt und der Versatz der düsen ebenfalls

    16 hours ago, zerspaner_gerd said:

    Also falls du das in Cura änderst bringt das dir je nachdem welche Einstellung gesetzt ist Garnichts bzw. dein 2ter Extruder ist doch fest, also was bezweckst du mit dieser Änderung???

     

    ja der ist Fest um 33.3 mm in der X Achse versetzt was dan bei Ausdruck mit Cura auch deutlich erkennbar ist weil der druck dann genau um die 33.3 mm nach rechts gedruckt wird

    16 hours ago, zerspaner_gerd said:

     

    Es gibt eine Einstellung die man mit den Plugin "Printer Settings" sehen kann diese heißt "Versatz mit Extruder" wenn diese aktiviert wird der Versatz von Cura berechnet aber gleichzeitig drucken kommt aber trotzdem nicht von Cura

    Vielleicht hängt es mit der Einstellung "Extruder teilen sich Heizelement" zusammen glaub ich aber nicht.

     

    Er druckt nicht "Gleichzeitig, sondern korrekt Sequentiell zuerst Extruder links die Stützstruktur dann Extruder rechts das eigentliche Objekt. aber eben Versetzt um die 33.3 mm so als ob CURA den Versatz welcher in der Firmware gespeichert ist deaktiviert oder überschreibt.....

    16 hours ago, zerspaner_gerd said:

     

     

    Also ich glaub du hast ein Drucker Problem mit deiner Firmware Einstellungen und du kennst dich zusätzlich zu Cura mit deiner Drucker/Firmware nicht aus.

     

    Der Drucker arbeitet definitiv richtig da mit der ReplicatorG und der FlashPrint software keine der Probleme auftauchen. Die Firmware des Druckers ist mir bekannt und habe sie auch selber von der Orginal Wanhao software auf die einiges bessere Sailfish (aus Thingsverse) Software aktualisiert. ebenfalls habe ich die aalten MK3 Extruder gegen neuere MK8 Extruder ersetzt auch habe ich zum verhindern desFilamentabriebs an den hinteren kanten des Druckers die Führung mit Bowden-Rohr von der Filament rolle zum Direktextruder geführt.

    16 hours ago, zerspaner_gerd said:

     

    Also Teile mal ein paar handfeste Daten, gcode evtl. Cura Projekt, alter gcode von deinen Alten Programm und dann kann ich dir evtl. sagen das es nichts mit Cura zu tun hat, deine Probleme

     

    Gruß

    Die gcode Datei des Teils darf ich leider nicht veröffentlichen, da sie Patentrechtlich durch meinen kunden geschützt sind! aber trotzdem gehe ich davon aus dass es einfach mein "Nichtkennen" von cura ist ich habe das ( Plugin "Printer Settings")bei cura installiert welches mir die Parameter zeigt, aber egal wass ich dort einstelle es ändert sich einfach nichts! vieleicht muss ich ja bei Cura irgend ein Haken setzen aber wo? Bei FlashPrint kann ich die Düsenversatz parameter eingeben, und der ausdruck reagiert auch auf die Änderungen!

    auch wenn ich bei Flashprint die Stromstärke der Steppermotoren ändere reagiert der Drucker darauf.

    also ist kein Problem mit der Firmware sondern einfach mein "Keine Ahnung mit CURA" daran schuld :-)

  • Link to post
    Share on other sites

    Posted · Neueinsteiger mit Cura

    Hallo

     

    1 hour ago, Pali64 said:

    Die  Firmware ist Sailfish 7.7 der Drucker ist ein Wanhao Duplicator 4

     

    Sagt mir trotzdem null

    Bin ein Ultimaker Benutzer habe ihn zwar mittlerweile stark modifiziert

     

    1 hour ago, Pali64 said:

    Die gcode Datei des Teils darf ich leider nicht veröffentlichen, da sie Patentrechtlich durch meinen kunden geschützt sind!

     

    Dan teile doch einfach zwei Test Würfel und fertig

    Und das in beiden Programmen

     

    1 hour ago, Pali64 said:

    vieleicht muss ich ja bei Cura irgend ein Haken setzen aber wo?

     

    Mehr haken gibt es nicht in Cura nicht wo ich dir durch das Printer Plugin gezeigt hatte und normal sollten die auf den gcode Auswirkung haben.

     

     

    1 hour ago, Pali64 said:

    auch wenn ich bei Flashprint die Stromstärke der Steppermotoren ändere reagiert der Drucker darauf.

     

    Das mach Cura auf jedenfalls nicht

    Nicht mal bei Ultimaker Drucker

     

    Sorry mehr Hilfe kann ich dir nicht anbieten

     

  • Link to post
    Share on other sites

    Posted · Neueinsteiger mit Cura
    On 5/4/2021 at 10:10 AM, Pali64 said:

    Drucke ich nun aber das File aus, ist das Objekt gerade mal noch halbsogroß wie es sein soll, und die beiden düsen drucken

    nebeneinander! ich habe zig Seiten durchgeschaut und auch versucht einstellungen zu ändern (bspw. Versatz des rechten Extruder um 33.3mm)

     

    Für diesen Drucker wird in Cura keine vorgefertigte Definition mitgeliefert, oder? Hast Du einen "Custom"-Drucker angelegt, oder was ist die Grundlage?

     

    Der Extruder-Offset wird doch einfach in den "Machine Settings" eingestellt, dafür wird kein Plugin gebraucht.

    Wenn sich die Firmware darum kümmert kann es aber auch sein, das hier alles auf Null stehen bleiben muss?

     

    image.thumb.png.6abee6b35f6c32c1fee884ee712c5f77.png

     

    On 5/4/2021 at 10:10 AM, Pali64 said:

    Habe versucht die Steps X,Y und Z Achse von 50 auf 25 pro mm zu stellen, aber das macht keine änderung im ausdruck?!?

     

    Wo hast Du das geändert? In der Drucker-Definition? Das wird sicher von Cura nicht automatisch an den Drucker gesendet. Ich vermute, das musst Du im Startskript hinzufügen, wenn der Drucker das nicht selbst verwaltet.

     

    9 hours ago, zerspaner_gerd said:

    Dan teile doch einfach zwei Test Würfel und fertig

    Und das in beiden Programmen

     

    Das ist ein guter Tipp!

    Vergleiche einfach mal den Anfang von beiden gcode-Dateien, damit sollte sich herausfinden lassen, was in der Cura-Variante noch fehlt.

    Dann passt Du das Startskript in Cura entsprechend an und fertsch! 

     

    https://drucktipps3d.de/startcode-im-cura/

     

     

     

     

     

     

     

  • Link to post
    Share on other sites

    Posted · Neueinsteiger mit Cura

    Hallo  zerspaner_gerd, erst einmal Danke für deine Antwort.

    Besten Dank aber du hast es doch Versucht 😉 danke dafür

    Hallo tinkergnome auch dir danke für die antwort

    7 hours ago, tinkergnome said:

     

    Für diesen Drucker wird in Cura keine vorgefertigte Definition mitgeliefert, oder? Hast Du einen "Custom"-Drucker angelegt, oder was ist die Grundlage?

     

     

    ich habe die Konfiguration von Thingsverse runtergeladen dann  ein Custom angelegt und die Werte eingetragen,

    inklusive "Start G-Code" und "END G-Code"

    7 hours ago, tinkergnome said:

     

    Der Extruder-Offset wird doch einfach in den "Machine Settings" eingestellt, dafür wird kein Plugin gebraucht.

    Wenn sich die Firmware darum kümmert kann es aber auch sein, das hier alles auf Null stehen bleiben muss?

     

    image.thumb.png.6abee6b35f6c32c1fee884ee712c5f77.png

     

     

    Wo hast Du das geändert? In der Drucker-Definition? Das wird sicher von Cura nicht automatisch an den Drucker gesendet. Ich vermute, das musst Du im Startskript hinzufügen, wenn der Drucker das nicht selbst verwaltet.

     

    Die werte für den Versaz habe ich in dem Fenster der Extruder eingetragen, wie in deinem Bild.

    Die Stepper habe ich im Maschinen-Setting eingetragen

    die man danach mit dem Tool anschauen bzw kontrollieren kann.

    7 hours ago, tinkergnome said:

    Das ist ein guter Tipp!

    Vergleiche einfach mal den Anfang von beiden gcode-Dateien, damit sollte sich herausfinden lassen, was in der Cura-Variante noch fehlt.

    Dann passt Du das Startskript in Cura entsprechend an und fertsch! 

     

    Ich werde das mit dem Würfel mal versuchen sobald ich den 3D-Drucker frei hab, zur zeit drucke ich damit gehäuse für einen Kunden und kann deshalb kein anderen Druckauftrag geben bis die zig gehäuse fertig sind.

    Besten Dank mal soweit auch für deine Tips

     

  • Link to post
    Share on other sites

    Posted · Neueinsteiger mit Cura

    Wenn ich das richtig nachvollzogen habe geht es um den Versatz der 2. Düse.

     

    Bei den Ultimakern kann man unter Cura ->Einstellungen ->Cura konfigurieren ->Drucker ->Drucker auswählen (verbundene Drucker) ->Geräteeinstellungen ->Extruder 2 ->X-Versatzdüse den Wert editieren.

     

    Ist halt die Frage ob du soweit bei den Einstellungen kommst, weil du ein "Custom" Drucker hast.

     

    Extruder 2 X Versatz.JPG

  • Link to post
    Share on other sites

    Posted · Neueinsteiger mit Cura
    On 5/6/2021 at 11:21 AM, Pali64 said:

    ich habe die Konfiguration von Thingsverse runtergeladen dann  ein Custom angelegt und die Werte eingetragen,

    inklusive "Start G-Code" und "END G-Code"

     

    Wennst du doch schon eine Konfiguration heruntergeladen hast wofür brauchst du dann noch eine Costum Drucker.

    Für was war dann die Konfiguration?

     

    On 5/6/2021 at 11:21 AM, Pali64 said:

    Würfel mal versuchen sobald ich den 3D-Drucker frei hab

     

    Für was musst du warten bist der Drucker frei ist, Druckst du über USB oder wie verstehe ich das?

    Man kann doch in Cura einfach einen Würfel (bzw. zwei weil Dual) und slicen lassen und diese teilen

     

    On 5/6/2021 at 3:32 AM, tinkergnome said:

    Der Extruder-Offset wird doch einfach in den "Machine Settings" eingestellt, dafür wird kein Plugin gebraucht.

    Wenn sich die Firmware darum kümmert kann es aber auch sein, das hier alles auf Null stehen bleiben muss?

     

    Nur mal kurz nebenbei. Wenn man in Cura 0 einträgt kann es den Bauraum nicht mehr richtig begrenzen.

    Über den Plugin ("Versatz mit Extruder") kann man einstellen ob der Versatz mit in gcode einfließt oder nicht und je nach­dem was eingestellt ist wurde der Extruder Versatz gar nicht in gcode angewendet

    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...