Jump to content
Ultimaker Community of 3D Printing Experts

Failed firmware update with Cura (WitBox) - WitBox won't start up afterwards

Recommended Posts

Posted · Failed firmware update with Cura (WitBox) - WitBox won't start up afterwards

Hi Guys,


At work, we have an old WitBox printer (BQ), which used to work perfectly fine.

However, a coleague of mine tried to do a firmware update within Cura. At first, the program would not find the printer, while Windows did notice it being connected. 

When he changed the cable, the printer was found be Cura and he started the firmware update protocol. Halfway through the process, Cura stated that the connection with the printer was interrupted somehow and the process could not continue. Since that moment, the printer won't properly boot up and the display on the printer only shows white blocks on line 1 and 3. The wheel/button does not make a sound when pressed. 

Trying to find the printer within Cura does not result in succes, even after changing the USB cables, removing the device from Windows 10 (device manager) and updating drivers.

Using the latest version of Cura (4.9.1). Does anyone know how I can reset the printer/fix the firmware/manually approach the printer to fix the issue (ABD or similar)?



  • Link to post
    Share on other sites
    Posted · Failed firmware update with Cura (WitBox) - WitBox won't start up afterwards

    Yikes.  Where did he get the witbox hex file?  Ultimaker firmware is for Ultimaker printers only.  It will not work on any other printer - not even clones of ultimaker printers as even the clones are slightly different.  Just one change in one pin is enough to keep the display from working.


    So... your printer is not exactly bricked - you need the witbox hex file and then you can upload within Cura using a "custom hex file".  There are many many other programs that can update the hex file.  Any arduino IDE can do it or (better) you can use pronterface.  Or stick with Cura - it worked last time - it should work again.


    But you need to find the correct hex file that is meant for your exact printer.  There may even be a few different versions of your printer with a few different hex files but probably only one.


    Contact witbox or google around.


    If I misunderstood you and you already used the "correct" witbox file then try using pronterface instead of cura.  It's a little more dependable (not a lot).  Also try powering up the printer just about the same moment you start the upload.  And vary the timing until it works.  The arduino inside the witbox is more receptive when it first powers up.  That's my experience anyway.

  • Link to post
    Share on other sites
    Posted · Failed firmware update with Cura (WitBox) - WitBox won't start up afterwards
    12 hours ago, gr5 said:

    Where did he get the witbox hex file?


    Because you asked: "MarlinWitbox.hex" is included in the Cura firmware resources. It's there for ages and the comment says:


    The MarlinWitbox.hex firmware is build from https://github.com/bq/Marlin and released under GPLv3


    No more details though 🤷‍♂️

  • Link to post
    Share on other sites
    Posted · Failed firmware update with Cura (WitBox) - WitBox won't start up afterwards



    The actual official manual of the WitBox uses Cura to update the firmware. As far as I know, the firmware has been included within Cura (Marlin) and we used this method before. 
    (https://www.gebruikershandleiding.com/BQ-Witbox/preview-handleiding-682987.html#pf2a , page 42 shows the procedure as followed (except for a few alterations in buttons due to newer version of Cura). 


    Unfortunately, BQ no longer exists as a company. 

    I can't seem to find the proper .HEX file just yet, but I will give it another try as I am currently working the night shifts. 

    Thank you for your replies!


  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker turns 10: A look back
        Ultimaker is turning 10 years old and that means it is story telling time! We'll explore 2010-2014, traveling through the evolution of the business from the Protobox and Ultimaker Original, to the major leaps forward with the Ultimaker 2 and Ultimaker 3.
          • Like
        • 0 replies
      • Ultimaker Transformation Summit
        Visit our virtual showroom and learn more about the Ultimaker ecosystem!
        • 14 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 4 replies
    • Create New...