Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  

Cura 14.01 failed to write firmware 'Timeout' - solved

Recommended Posts

I am having this problem too.

Yesterday i downloaded new CURA and run "first run wizzard " from CURA and flash MARLIN firmware.

After that I cant connect to printer, neither flash again firmware. It stays at "Please connect the printer to your computer....." and nothing happens.

I tried to compile and flash with ARDUINO, again no answer from Ultimaker....

Tried all USB ports, and nothing happens.

But I see after that, when I power ON Ultimaker, all three motor are locked(i cant move extruder and hotend.)

Please can someone help me? Is there any hard reset on UM or something like that ?

Thanks !


Share this post

Link to post
Share on other sites

Hi at all....

i have same problem,im remove ad reinstall arduino,all ok,is a com8 115200

im restart cura 14.09 but is not possible connect to printer,im power off the printer,remove all cable,wait few second,connect only usb,retest the connection for insert a firmware and after more test it run,im very happy,and continue,at second step,cura not connected at UM...

you have a solution for me ??



Share this post

Link to post
Share on other sites

I have the same problem: see my topic about "Ultimaker original Printer seems to be dead".

After some e-mails to Ultimaker, they concluded that my Motherboard should be defect. So I build in the new motherboard I had to buy. No results. Only the extruder could be heated, but my heated bed, nor the movement of the axes worked.

Than I got the suggestion to build custom Marlin firmware, which I did. I made a dozen different configurations. Again no results.

The problem started when I installed Cura 14.9 and downloaded the default firmwere. Before My system worked excellent.

So I am also desperate and still can not work with my Ultimaker original.


Share this post

Link to post
Share on other sites

hi,im now wait a new original arduino maga....

one question...please,write me exactly the step for run the ultimaker,im thin im make a mistake....

im test blink on arduino and it run ok...

im insert mega on ultimaker board,install the firmware(Run Cura,open first run.....) the firmware go inside arduino,but on display not look nothing,the otor not move,only the motor of Z make a little sound,it have little torque.

other my test of run this 3d printer,the Y axis move to end stop,but one step per second....

im not undestand where is the problem and difficoulty,im look more videos of first start and the boy run he ultimaker at fist

You have a original arduino ??

i have this kit for ultimaker...Ebay auction

151256292420 but not run nothing and the seller not undestand where is the problem...


Share this post

Link to post
Share on other sites

unfortunately the seller answere at my "SOS"

it write me that:

"Thank you for your query. To be honest, this ultimaker 1.5.7 is an upgrade version. The connectors are different with the original one. If you are not familar with ultimaker, I do not suggest you buy it. On the other hand, I would like to know some more details about your connection problem. Do you see any error message?"

im think for solve my problem,i have 2 road....1rewrite in my firmware the exact pin 2 search a firmware for this board....

but i have one question.....the other people if buy that board...have same my roblem ??


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 119 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!