Jump to content
Ultimaker Community of 3D Printing Experts

Bricked UM2 after trying to upgrade to 14.01 firmware - SOLVED


Recommended Posts

Posted · Bricked UM2 after trying to upgrade to 14.01 firmware - SOLVED

Hi,

I've tried to upgrade the UM2 firmware that comes with Cura 14.01, from Windows 7.

When "Uploading firmware" progress bar appears, it does not finish.

After 5 minutes or so of waiting, I cancelled manually with the upper right cross.

I power cycled the UM2 unit and now it seems bricked with a garbled displayed so I assumed it has begun - but not completed - the firmware image...

Bricked UM2 after 14.01 firmware failed update

I have read that the initial Cura 14.01 upload contained a wrong firmware, but I just downloaded it from software.ultimaker.com so it should contain the correct one I guess.

The file size as reported by Windows Explorer properties is

23,5 MB (24 659 879 bytes).

I even tried to uninstall Cura 14.01, re-download from another browser and re-install, but still hangs at "Uploading firmware". It should only take a couple of minutes at the most from what I recall?

I have not yet tried rebooting the computer as I have some other tasks running that I can't disturb right now.

Anyone else with the same problem?

 

  • Share this post


    Link to post
    Share on other sites
    Posted · Bricked UM2 after trying to upgrade to 14.01 firmware - SOLVED

    Problem solved by - I was able to upload the new firmware using another Windows 7 computer!

    It actually took two tries - it seems somehow important that the UM2 is powered on before the USB cable is inserted...or perhaps it's because I bricked it first?

    Also it might be that my primary workstation has a bit overcrowded USB chain with a lot of devices attached? But it has worked well in the past.

    It's a bit ironic that Cura 14.01 states "Improved USB communication stability" but people seems to be having problems updating the firware over USB :p

     

  • Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Talking additive | The 3D printing podcast
        Why should we be the only ones asking questions? Join us and ask Jabil all your questions on September 22nd 5pm CET
          • Like
        • 3 replies
      • Ultimaker masterclass: Optimizing your Ultimaker Cura workflow
        Save your seat for either broadcast on September 23.
        What will you learn?
        · Best practices for iterative print preparation and every lesson you should learn from each print
        · The right way to use per-object settings and when they are most useful
        · Easy-to-use resources for anyone who wants to develop their own printer definitions, plugins, or print profiles
        · How to optimize print profile settings and whether to “keep” or “discard” changes
        · When is the right time to export your drawing from CAD? (Based on Ultimaker Cura’s surprising power as 3D control software)
        · And a whole lot more tips and tricks!
         
        How can I join?
        This free masterclass will take place twice:
        1. 11am CEST (5pm SGT, 5am EDT)
        2. 5pm CEST (11am EDT, 8am PDT, 11pm SGT)
          • Like
        • 0 replies
      • Do you use 3D printing at work? Let us know
        It doesn't matter if you are using 1 Ultimaker or 10, there is inspiration in everything. We're looking for ...
        • 1 reply
    ×
    ×
    • Create New...