Jump to content
Ultimaker Community of 3D Printing Experts

Cura 4.10.0 creating useless support


Holly
 Share

Recommended Posts

Posted · Cura 4.10.0 creating useless support

Hi, I'm using Cura for quite a while now, but this is the first time I see Cura creating some obvious useless support.

On the inside of my model it creates 3 support parts, that "connect" to nothing. Does anyone have a clue?

 

I added the STL, the G-code and the project file.

 

 

Cheers, Henk

 

 

 

LED_module_4.stl LED_module_4.gcode LED_module_4.3mf

  • Link to post
    Share on other sites

    Posted · Cura 4.10.0 creating useless support

    Cura never builds useless supports.  Questionable supports yes, useless no.

     

    If you change the support type to Tree and make the XY distance 0.1 and the Z distance 0.1 you'll see that it's attempting to support the threads.  The thread angle is 60° (and the helix angle is involved) and your Support Overhang Angle is 50°.  If you change Support Overhang Angle to 63° (or simply turn support off) the problem goes away.  Your settings say supports should be required, but "Normal" supports can't get past the internal chamfer and so you get those partial "questionable" supports.

    The maximum support angle in most situations is 63°.  Anything above that and the next layer prints over air.  Your threads are pushing that and in the case of your model - if the thread was an M50 you might want supports in there.  Internal threads often require a decision by the user regarding supports.

    If I have a 2.5mm diameter horizontal hole I put a support blocker in it.  If the hole is 75mm diameter I probably want to allow support.

  • Link to post
    Share on other sites

    Posted (edited) · Cura 4.10.0 creating useless support

    Hi Greg, thanks for your answer. Changing some of the support parameters indeed shows what it is trying to do. At some points (only a few) it is trying to support the thread. I have to tinker a bit more with these parameters, as it is now unclear to me why it only tries to support the thread at a few points. I would have expected more and more evenly spread support as a result.

    Edited by Holly
  • Link to post
    Share on other sites

    Posted · Cura 4.10.0 creating useless support

    Here is a view in Cura.  This gets drawn by the GPU and is layer by layer.  There is no accounting for the incremental Z moves in a spiral file.

     

    Untitled.thumb.png.9b911a3c23b35a87035c59567327c052.png

     

    Here is the same area as read into AutoCad.  You can see where spiralize starts above the bottom layers and that the spiral is there as the individual line segments are exact instead of being an approximation by layer.  It's one of the reasons I like it as a tool.

    Untitled1.thumb.png.0f35eb8d617d03c27d8237f7e47f466b.png

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...