Jump to content
Ultimaker Community of 3D Printing Experts

Hotend Movement During Print


Recommended Posts

Posted · Hotend Movement During Print

Hello all hopefully someone can explain what im doing wrong or there is a setting i need to adjust. I have a Creality ender 3 and i use Cura as my slicer.

The issue is the printer prints fine but some times the hotend will move away from the print move around the outside of the bed in a anticlocwise direction while extruding filament then return to the print and carry on. Sometimes it will cause layer shift by about 3 to 5 mm but most of the time it will carry on but repeat the anticlocwise movement again later in the print.

This has been happenning in Cura 4.11 and now in the latest version. I have tried reinstalling Cura and i have just tried using the basic Esun PLA+ grey fillment  profile (Esun Pla+ is the main filament i use)  with hot end temp set to 205 degress heated bed set to 60 degrees Z hop/ Z lift set to 0.2.

i have tried printing with Prusaslicer the same print and this does not happen any help will be appreciated.

 

regards Lee

  • Link to post
    Share on other sites

    Posted · Hotend Movement During Print

    Post one of those "bad" gcode files here.  You can also use "File | Save Project" to create a 3mf file with your settings, the model, and your printer and you can post the 3mf file here as well.

     

    Are you using USB Printing or Octoprint?  Are any post-processors being used?

     

    As long as you didn't use ArcWelder you can check the gcode file yourself by opening it in Cura.  The Cura gcode reader is separate from the slicer and you will get a good view of where the gcode is telling the printer to go.  I can read the file into AutoCad even if ArcWelder was used.  That takes Cura totally out of the loop for "post-viewing" a gcode file.

    You may have a corrupt SD card.  Formatting usually fixes that.  The fact that the PrusaSlicer files were OK kind of eliminates that possibility though.

  • Link to post
    Share on other sites

    Posted · Hotend Movement During Print

    Hello Greg thankyou for replying

    I have Octoprint connected and a bought a new sd card a few months ago as the one that came with it was to say the least crappy. i always transfer the files through the Octoprint connection never through sd card if that helps. i have added the 3mf file fo you to look at and i think i might have found the cause. You mentioned arcwelder i dont use Arcwelder but i noticed in the settings it was enabled along with G90 Influences. i have the silent board with the Th3D Unified Firmware installed and Bltouch and i dont remember enabling Arcwelder when i compiled the firmware over a year ago.

    I have checked Octoprint and i havent got the Arcwelder Plugin installed. Hopefully i might have found the problem with your help with just the Arcwelder Comment but if you find something else i will be pleased to know.

    Thanks for your help Lee

     

    CE3_Body_front_HPC.3mf

    • Like 1
    Link to post
    Share on other sites

    Posted · Hotend Movement During Print

    I don't know Octoprint but from what I've read it can be configured to send some commands and sometimes those can interfere with a print.

    If you didn't enable the G2/G3 commands in your firmware then ArcWelder cannot be used.  The reason is that when a G2/G3 command is read by the printer it gets ignored.  The result is that the next move is from (what is now) the wrong location to a new location.  If there are a lot of G2/G3 commands in a row then that distance can be a long ways.

     

    G90 just sets the printer to Absolute mode.  The normal situation is for the Startup Gcode to end with the printer in absolute movement mode (G90) and absolute extrusion mode (M82).  If you are using Relative Extrusion then Cura should add an M83 after the end of the StartUp Gcode.

  • Link to post
    Share on other sites

    Posted · Hotend Movement During Print

    Hello Greg

    Thanks for getting back to me i see  your point thankyou for explaining it to me any other ideas why it randomly does this then ?.

    I have unchecked Arcwelder from the settings and i will try again later when the print i am doing now has finished by trying the file i sent you again.

     

    Regards Lee

     

  • Link to post
    Share on other sites

    Posted · Hotend Movement During Print

    CE3_Body_back_B_HPC.gcodeCE3_Body_front_HPC.gcodeCE3_HIP.gcode

     

    Hello Greg here are three Gcode files that have gave me the issue when sliced and printed with Cura i have tried these with Prusaslicer and they print fine.

    I dont want to change to another slicer as i prefer Cura so any light you can shed on this will be helpful.

     

    Thanks Lee

     

  • Link to post
    Share on other sites

    Posted (edited) · Hotend Movement During Print

    There isn't any problem within the gcode files.  No G2 or G3 moves, no weird movement away from the part.  The first image is the "Body_back" file read into AutoCad.  The green line at the top is the wipeout move that is in your End Gcode and the magenta line coming from the lower left is the first travel after the purge lines.  (The magenta lines filling the part are the travel moves.)

    I read in the other two files as well and they show the same lack of a problem.  No moves outside of the part.

    Back.thumb.jpg.a163d87824a389a198d60b07b6ee9d2e.jpg

     

    Here is the Front part with the travel lines turned off.

    front.thumb.jpg.5f0879e032e5a121ea9aca470696d9a8.jpg

     

    The fact that the PrusaSlicer files print OK is odd.  If not for that, I'd say the most likely possibilities are:

    1)  Octoprint has something enabled in it's setup that is interfering.  One way to check is to bypass Octoprint and print from the SD card.  If Octoprint is somehow dropping lines or characters or is causing buffer over-runs then the printer will act oddly.  The printer just goes where it's told.

    2)  The firmware in your Ender has gotten boogered.  I've had to do a reset on my 3 Pro a couple of times as the firmware just got weird.  If you write down your PID, Home Offsets, steps/mm, etc. then you can send M502 to the printer and it will re-set the firmware back to factory defaults.  Then re-enter your settings and then "Save Settings".

    3)  I'm not sure how you have your Ender configured but the line "M117 Autobots! Roll Out!" can cause a problem if you are using Decepticon firmware.

     

    As an aside - those are tough models to print without support.

    Edited by GregValiant
  • Link to post
    Share on other sites

    Posted · Hotend Movement During Print

    Hello Greg Thanks for looking. Yeah its definatley a weird problem i have tried printing directly form the sd card i would say 2 times out of ten when sliced from Cura i get the strange movement around the bed while still extruding then beck to the print but it doesent do it on the Prusaslicer files on sd card at all on the sd card. i think i will try reinstalling the firmware and tehn try if possible a earlier version of Cura see how i go.

    The callouts for autobots i forgot to delete lmao i pick up the Bltouch starting Gcode from somewhere and just forgot to change it.

    All i can say thanks so much for your help i will reinstall the firmware etc and update in a week or so once again thankyou.

    Regards Lee 

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...