Jump to content
UltiMaker Community of 3D Printing Experts

Adding Flashforge Dreamer as a printer


Recommended Posts

Posted · Adding Flashforge Dreamer as a printer

I recently switched to using Cura from Slic3r and have been having some difficulties adding my Flashforge Dreamer as a printer. So far I have looked for an existing definition and found Egon's version that he had made for a previous version of Cura. I managed to get their version to work on Cura 4.11 briefly before the 4.12 version came out however after updating the printer definition shoed as corrupted. Since then I have found the Dreamer NX profile to work for my printer but doesn't allow for using my second extruder. I have tried to copy and edit the .json files to allow for adding a second extruder without corrupting the existing Dreamer NX profile that exists in Cura but all my efforts return as the new definitions being 'corrupted.' I have also tried to make a version of the printer as a custom printer but needed to fun several post scripts to tweak the g code when slicing a model in order to change the nozzle temperatures correctly. Can someone help me be able to print with my printer?

  • Link to post
    Share on other sites

    Posted · Adding Flashforge Dreamer as a printer

    Printer definition files tell Cura how to set up for the particular machine.  If a printer has multiple extruders it must say so in the definition file and then in the Extruders folder there must be an extruder definition file for each possible extruder.  If you have copied your Flashforge definition file into Cura's "resources\definitions" folder then go into the 4.11\resources\extruders" folder and copy the FlashForge extruder files into the correct folder in the new version of Cura.  One file might be "flashforge_dreamernx_extruder_0.def.json" and the second might be "flashforge_dreamernx_extruder_1.def.json".

     

    This has come up before around here.  If you search for FlashForge on this forum you will find what other people have done.

     

  • Link to post
    Share on other sites

    Posted · Adding Flashforge Dreamer as a printer

    I copy and pasted all the related files that it saved from 4.11 into 4.12 and the printer doesn't appear as a printer in Cura, but I get no error messages either. 

    However, I was able to modify the .json files to add a second extruder. I had failed to notice the commas when copy and pasting pieces from working definitions and have gotten my printer to print using Octoprint, I haven't messed with it enough to say whether this is required.

     

    Thank you for your help, I did look back at the previous discussions and learned about a different dreamer profile which didn't seem to work for me. It also showed me that I had used too specific of keywords when searching about this issue previously.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • Here it is. The new UltiMaker S7
        The UltiMaker S7 is built on the success of the UltiMaker S5 and its design decisions were heavily based on feedback from customers.
         
         
        So what’s new?
        The obvious change is the S7’s height. It now includes an integrated Air Manager. This filters the exhaust air of every print and also improves build temperature stability. To further enclose the build chamber the S7 only has one magnetically latched door.
         
        The build stack has also been completely redesigned. A PEI-coated flexible steel build plate makes a big difference to productivity. Not only do you not need tools to pop a printed part off. But we also don’t recommend using or adhesion structures for UltiMaker materials (except PC, because...it’s PC). Along with that, 4 pins and 25 magnets make it easy to replace the flex plate perfectly – even with one hand.
         
        The re-engineered print head has an inductive sensor which reduces noise when probing the build plate. This effectively makes it much harder to not achieve a perfect first layer, improving overall print success. We also reversed the front fan direction (fewer plastic hairs, less maintenance), made the print core door magnets stronger, and add a sensor that helps avoid flooding.
         

         
        The UltiMaker S7 also includes quality of life improvements:
        Reliable bed tilt compensation (no more thumbscrews) 2.4 and 5 GHz Wi-Fi A 1080p camera (mounted higher for a better view) Compatibility with 280+ Marketplace materials Compatibility with S5 project files (no reslicing needed) And a whole lot more  
        Curious to see the S7 in action?
        We’re hosting a free tech demo on February 7.
        It will be live and you can ask any questions to our CTO, Miguel Calvo.
        Register here for the Webinar
          • Like
        • 13 replies
      • UltiMaker Cura 5.3.0-Alpha 🎄 Tree Support Spotlight 🎄
        Are you a fan of tree support, but dislike the removal process and the amount of filament it uses? Then we would like to invite you to try this special release of UltiMaker Cura. Brought to you by our special community contributor @thomasrahm
         
        We generated a special version of Cura 5.2 called 5.3.0 Alpha + Xmas. The only changes we introduced compared to UltiMaker Cura 5.2.1 are those which are needed for the new supports. So keep in mind, this is not a sneak peek for Cura 5.3 (there are some really cool new features coming up) but a spotlight release highlighting this new version of tree supports.  
          • Like
        • 17 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    ×
    ×
    • Create New...