Jump to content
Ultimaker Community of 3D Printing Experts

Outer wall defects, might be a slicer setting issue


Recommended Posts

Posted (edited) · Outer wall defects, might be a slicer setting issue

Hello everyone, I am using Cura 4.12.1 and having some trouble with one of my prints and I've spend almost 2 weeks on it but just can't figure out what went wrong.

 

All the prints are done with 60mm/s, Inner/Outer wall at 30mm/s, same temperature(200 nozzle, 60 bed)

 

The defects always happen on the same spot even with different printer(Anycubic Vyper and Creality Ender3 Pro)

vyper.thumb.jpg.26109cb63f7aa76e24063d6a25cc80ff.jpgender3.thumb.jpg.c602f624c85f292db2ecfc6a0dd74f37.jpg

 

After tried lots of calibration/firmware/turning the defects just won't go away. So I tried a different slicer with their default settings, it seems the defects does not show up in PrusaSlicer or IdeaMaker(Although they have other problems since I haven't got much time to change their settings yet)

slicer.thumb.jpg.26039a40ed372efee5c67946f1948858.jpg

 

I looked into the GCode preview where the defects happens, but can't find any problem with it, they looked like straight line in the preview.

cura.thumb.png.69b84acbe5abbf9eb36873c117f8700a.pngidea.thumb.png.a64ecd40366686199cbf1414b7fcabae.png

 

Since PrusaSlicer and IdeaMaker does not having this issue, I guess this might be some setting I used in Cura causing this, it will be greatful if anyone can help me find the right setting. Thank you.

 

I've attached the STL model "hueca cisne.zip" if it helps the diagnosis, I enlarged the model by increased the model Z axis to 70mm when slicing

 

hueca cisne.zip

 

Edited by Hibino
Remove duplicate image
  • Link to post
    Share on other sites

    Posted · Outer wall defects, might be a slicer setting issue

    Look through the different gcode files and see if you can determine the Acceleration and Jerk settings (M201, M204, and M205) as well as the speed settings (the "F" numbers).  The problem looks to be ringing (but might be an extruder issue).

    If you do not enable Accel and Jerk control in Cura then I believe that the printer will fall back on it's defaults which might be too high for that particular model.  For some reason (probably mechanical) you are getting a bounce in that axis.  It might be caused by different Accel and Jerk settings in the Cura file and a harmonic vibration is showing up in the print.

    In the Prusaslicer photo you can see an issue on the left that might be the same sort of thing, just in a slightly different location.

  • Link to post
    Share on other sites

    Posted (edited) · Outer wall defects, might be a slicer setting issue

    Thanks GregValiant.

     

    I checked all 3 GCode files they do have M204 S1200 at begining of file(except IdeaMaker which have M204 S2500 after every layer finish moves to layer start point and M204 S1200 again, guess the setting in IdeaMaker have travel acceleration set to 2500).

    There is no M205 since Jerk control is not ticked in slicer settings and the firmware I have is using junction deviation(set to 0.07). 

    Only PrusaSlicer's GCode has M201 X3000 Y2000 Z60 E10000 at begining of the file, there is no M201 in other two slicer's Gcode file.

     

    1200 is the default acceleration of Vyper and 500 is the default acceleration of Ender 3(acceleration control is disabled on Ender 3 profile)

     

    I thought it was extruder issue(uneven extrution) so I replaced the extruder on Vyper with the BMG extruter and a new nozzle but same defects happens at the same location, until I tried on Ender 3 having the same issue I starting believe it might not be hardware related.

     

    The print from PrusaSlicer does have some defects on the left where there is a L sharped corner, maybe it is running too fast around that corner.

     

    I am resizing the model to difference sizes and slicing with Cura see if it happens on a certain height at the moment, will take few days to test out again...

    Edited by Hibino
  • Link to post
    Share on other sites

    Posted (edited) · Outer wall defects, might be a slicer setting issue

    After few prints I got a very interesting result.

    The defects is not height related and always will be on the same spot so I can move the model down below the bed in Cura to only print where it happens.

     

    The top 4 is still sliced with Cura 4.12.1 with different model size/print speed/acceleration, even at 20mm/s speed the defects always be there.

     

    The last one is sliced with the Beta Cura Arachne which I saw on this forum. I installed it and it loads up all my current Cura 4.12.1 profile and settings, I didn't change any setting just used it to slice the model(resized model height to 70mm), and printed the section where defects happens, it came out like PrusaSlicer and Ideamaker with no defects on the outer wall. I feel there must be something weird with my Cura 4.12.1

    IMG_20220105_214912101.thumb.jpg.48a9e83c23fb1c5ae1f6c527b04c692b.jpg

    Edited by Hibino
    Correct version number
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...