Jump to content
Ultimaker Community of 3D Printing Experts

Cura keeps resetting start gcode


Ch3vr0n
 Share

Recommended Posts

Posted · Cura keeps resetting start gcode

I have a annoying issue since updating to 4.13.1 and its that cura is constantly resetting my start gcode for temperature values. My preferred config is as follows (slightly modified from default)

 

Quote

M82 ;absolute extrusion mode
M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration
M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate
M204 P500.00 R1000.00 T500.00 ;Setup Print/Retract/Travel acceleration
M205 X8.00 Y8.00 Z0.40 E5.00 ;Setup Jerk
M220 S100 ;Reset Feedrate
M221 S100 ;Reset Flowrate
; Setting pre-levelling temperatures
M117 Pre-Heating
M104 S160
M190 S{material_bed_temperature_layer_0}

; Homing and Levelling
M117 Homing & Autolevel
G28 ;Home
G29 ;Auto bed Level
G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up
G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position
; Final heating & nozzle Prime
M117 Final Heating
M109 S{material_print_temperature_layer_0}

; Starting Print
M117 Printing
G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up
G92 E0

 

However for some damn weird annoying reason cura keeps resetting the pre-levelling and final heating section temperatures to

Quote

; Setting pre-levelling temperatures
M117 Pre-Heating
M140 S60
M109 S160

 

; Final heating & nozzle Prime
M117 Final Heating
M109 S{material_print_temperature_layer_0
M190 S{material_bed_temperature_layer_0}

 

And to make it even more weird. When i change it, it's remembered for a few times closing and starting, and after a few times it's back to reset. I wanna know how to fix this without loosing my printer profile & custom quality& material profiles

  • Link to post
    Share on other sites

    Posted · Cura keeps resetting start gcode

    Are you perhaps loading old projects? Projects contain all settings, including start & end gcode.

  • Link to post
    Share on other sites

    Posted · Cura keeps resetting start gcode

    Well i just tried and it's a 3mf file that had the embedded image so i'm pretty sure it saved with 4.13.1. So you're telling me, start/endcode settings that may have changed since the project was created get overridden and i have to redo them all? That shouldn't be happening. I don't mind the sidebar stuff getting overridden, that's the job. But start/end gcode shouldn't get replaced

  • Link to post
    Share on other sites

    Posted · Cura keeps resetting start gcode
    16 hours ago, Ch3vr0n said:

    That shouldn't be happening.

    Well, that's how it works in Cura. Cura can't read your mind and know what settings you do or don't want to load from the project. It would be nice if you could select from a list of options which (sets of) settings you want to load from the project when loading a project.

  • Link to post
    Share on other sites

    Posted · Cura keeps resetting start gcode

    It probably does ask, but with limited choice. I'm guessing the first "dropdown" when you open is for the startcode as it asks if you want to update the printer or add a new one. But there's no way to select to KEEP the current one

  • Link to post
    Share on other sites

    Posted · Cura keeps resetting start gcode
    4 minutes ago, Ch3vr0n said:

    I'm guessing the first "dropdown" when you open is for the startcode as it asks if you want to update the printer or add a new one.

    You are guessing incorrectly.

     

    Loading settings from projects is currently "all or nothing". It would be nice if there were options to eg keep the current preferences, what settings are visible, and the machine settings. There are no such options. The whole state of the application is imported from the project file. All that dropdown does, is letting you select what "printer instance" these settings are loaded in to; you can have multiple of the same printers configured in Cura.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • Ultimaker showcase | April 2022 | 4pm CEST | 10am EDT
        I'm excited because I've personally produced this showcase event, so if you are curious what else I'm up to nowadays, come check it out and say hi in the chat! It would mean a lot! 
        • 4 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
        • 11 replies
    ×
    ×
    • Create New...