Jump to content
Ultimaker Community of 3D Printing Experts

Ultimaker Cura 5.0 beta


fvrmr

Recommended Posts

Posted · Ultimaker Cura 5.0 beta
On 4/28/2022 at 4:49 AM, Lupus52 said:

The previous USB implementation is a disgrace. Every decent programmer should be ashamed of such rubbish! You can't choose a port. And you can't specifically connect or disconnect. As is the case with Pronterface, for example. Cura does it randomly. Sometimes you can print to USB after slicing. Then again not. Sometimes the printing option comes when you unplug the printer and plug it in again, or even have to switch it off and on first. Sometimes you have to slice again. It's a gamble whether USB printing is offered after slicing or just saving to hard drive.

 

And Cura cheekily connects to anything that looks like "Arduino" at launch. And kills e.g. my weather station with Arduino on another port when starting.

 

Or Cura kills a running print job that is currently printing from the SD card if the USB cable is still plugged in when Cura starts.

 

 

Really good points!  yes.  It should probably be removed from Cura as I think it's one of those causes for: when people say "Cura is really slow".  Sometimes I think it's trying to talk to their weather station or their mouse or something.  Removed or at least have USB searching disabled by default.

 

Quote

But the arrogant attitude towards users of other printers here in the forum, some of which can be found here, pisses me off. And therefore I say Goodbye!

 

Oh my god.  What a drama queen.  The arrogance was only in your own mind.  I hear your anger but it's just that no one here listening deserves the focus of your ire.  Yes let us hear your frustration and motivate us/someone to fix it or at least think about fixes.  But don't get mad at *us*.  

 

  • Like 1
Link to post
Share on other sites

Posted · Ultimaker Cura 5.0 beta

It seems that anyone with a laptop running Intel HD3000 graphics adapter is out of luck with this version.  Just gives an error message before starting that it can't "probe" OpenGL 2.0 or later, which is not supported with Win 10 and this graphics adapter.

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 5.0 beta
    1 hour ago, kallend said:

    It seems that anyone with a laptop running Intel HD3000 graphics adapter is out of luck with this version.  Just gives an error message before starting that it can't "probe" OpenGL 2.0 or later, which is not supported with Win 10 and this graphics adapter.

    Tried another laptop.  Win 10 with OpenGL 3.1.  Still getting the message that it can't "probe" Open GL 2.0 or later, and still wont start.  v4.13 worked fine on both of them.

     

    I think you don't need to disenfranchise so many potential users.

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 5.0 beta

    When I first installed 5.0 I had problems with a glitch between 5.0 and my video system (Intel HD 4000).  @ahoeben was able to chase it down and put a fix in.  I'm sure when they get back to work on Monday this will get looked at.

    In the meantime could you report this on GitHub?  There have been bug reports for this happening on some Linux systems but I don't think a Windows bug report has been made yet.

  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker Cura 5.0 beta

    Looks like the libc fix that 4.13.1 needed to work on Linux Mint/Cinnamon needs to be made available for the 5.0 Beta.  This will not run on Linux Mint/ Cinnamon as it is supplied.  Help 🙂

    Edited by normanmcgeoch
  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 5.0 beta
    2 hours ago, GregValiant said:

    When I first installed 5.0 I had problems with a glitch between 5.0 and my video system (Intel HD 4000).  @ahoeben was able to chase it down and put a fix in.  I'm sure when they get back to work on Monday this will get looked at.

    In the meantime could you report this on GitHub?  There have been bug reports for this happening on some Linux systems but I don't think a Windows bug report has been made yet.

    Can't report on github  because it won't allow a submit without a log or project file.  Since 5.0 wouldn't even start, no such file was created.  It just wasted my time filling out the form which couldn't be submitted.

  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker Cura 5.0 beta

    I didn't know that.  I suppose I must have always had something to pass along.

     

    @fvrmr is there something the OP can do or that you can help with?  Looks to be a non-install because of the "Looking for OpenGL 2.0" thing (#11856?).

     

    @kallend I'm pretty sure nothing will happen until Monday.

    Edited by GregValiant
  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker Cura 5.0 beta

    Not sure if this is the right spot, but the "Multiply Selected" function does not work until you change the value from "1" (if you simply want a duplicate, you have to retype the "1" to add a single copy.

     

    VaughnR
    Creality CR-X

    Edited by VaughnR
    Add signature
  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 5.0 beta
    2 hours ago, VaughnR said:

    the "Multiply Selected" function does not

    Thanks, a fix for that has already been made, which will be part of the final release of Cura 5.0.

    • Like 1
    • Thanks 1
    Link to post
    Share on other sites

    Posted (edited) · Ultimaker Cura 5.0 beta
    8 hours ago, kallend said:

    Can't report on github  because it won't allow a submit without a log or project file.

    Most people find out that you can easily "lie" that you included a log file and not include one. Other people find the reference to the dxdiag log in the "Logging issues" section of the readme here: https://github.com/Ultimaker/Cura/#logging-issues

     

    The dxdiag log would actually be very helpful to diagnose your issue, because it will show what driver(-version) is installed on your computer.

     

    The HD Graphics 3000 GPU should suffice for running Cura, albeit in "compatibility mode" (ie: with some limitations, mainly in the Preview tab). It is however not someting that gets tested regularly AFAIK, so your feedback (and logs!) are welcome.

    Edited by ahoeben
  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 5.0 beta

    What is your opinion on the setting change that the outermost wall is printed first and then the inner walls in the Ultimaker profiles?
    I have now tried it on several objects and my experience here is ambivalent. With simple materials without using the second nozzle it works relatively well. The accuracy in the X and Y direction seems to be very good, but holes still need to be adjusted. 

     

    However, with all my nylon objects printed with PVA support, this adjustment change seems to have disadvantages. The Ultimaker nylon is a softer PA compound, so there are slight similarities to TPU in the printing behaviour. This means that after a print core change, nylon does not immediately come out of the nozzle with the correct material flow. A Primetower helps here, but there is still a slight offset until the material flow is complete. This can also be seen to a certain extent after retraction. The fact that the outermost wall is printed first has led to unusable printing results several times, because the outermost wall was under-extruded. 


    With manual changeover to "inner walls before outer walls" this problem no longer existed. Since I only print technically applicable objects here and have therefore also increased the number of outer walls (the same as in previous Cura versions), I have never had any problems with the quality of the outermost layer. 

    Since it is generally customary to print the inner walls first, I find this change somewhat questionable.

    Opinions? 

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 5.0 beta
    On 4/22/2022 at 3:54 PM, ahoeben said:

     

    Where can we get binaries with these newer fixes? Are there nightly builds available?

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 5.0 beta

    I have noted a slight difference but I think it is mostly aesthetics.  I have made a local change and made "Inside-Outside" the default.  It is one less adjustment that I have to make.

     

    It will be nice to get the dialog boxes working as they should but as to the internal changes to the slicing, it looks good to me.

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 5.0 beta
    11 hours ago, kallend said:

    Can't report on github  because it won't allow a submit without a log or project file.  Since 5.0 wouldn't even start, no such file was created.  It just wasted my time filling out the form which couldn't be submitted.

     

    Have a look in /home/<username>/.local/share/cura/

     

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 5.0 beta
    2 hours ago, DrLucasThompson said:

    Are there nightly builds available?

    There are not.

    It is fairly easy to "patch" your local install though. What OS do you use?

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 5.0 beta
    On 4/29/2022 at 4:48 AM, GregValiant said:

    I responded on Github.  What I found was 5.0 has a setting for "Split Middle Line Threshold" that doesn't exist in 4.13.  Try setting that to 50% (default is 70%).  That forces 5.0 to make two passes up each tine and eliminates the oozing during the travel move between tines that occurs with a single pass.

    (It's not quite 8:00AM here and I've already learned something today!  I printed the comb - but it will be for a mustache.  Z seam anywhere but "back" would be a better choice.)  After printing, I think a skirt would be better as well.  Adhesion was not a problem.

    DSCN2847.thumb.JPG.aff8c0397472e4a9bb376c6b87b8bc19.JPG

    Thank you, Greg!  It fixed the problem!  (I have attached the case for the comb for you...  Makes it a nice 'pocket comb')

    Folding Beard Comb (Greg).zip

  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker Cura 5.0 beta

    Hello guys, please tell me in which repository to write tickets for Cura 5.0. I have windows 10, I installed beta 5.0 but there is a problem in order to scroll through the print options hints.

    Screenshot_1.jpg

    And I would like to express my gratitude to the developers of Cura, I have been using it for a long time and the guys are a great product and it is very pleasant to use it and thanks that it is free.

     

     

    Edited by KonstantinDi
    • Like 2
    Link to post
    Share on other sites

    Posted (edited) · Ultimaker Cura 5.0 beta

    Bug reports go Here on GitHub.  If you have a screenshot, cura.log file...something to help them troubleshoot the problem that would help.

    Edited by GregValiant
    • Like 1
    Link to post
    Share on other sites

    Posted · Ultimaker Cura 5.0 beta
    On 4/30/2022 at 10:50 AM, ahoeben said:

    There are not.

    It is fairly easy to "patch" your local install though. What OS do you use?

     

    Linux (using the 5.0 beta appimage)

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 5.0 beta
    4 hours ago, DrLucasThompson said:

     

    Linux (using the 5.0 beta appimage)

     

    That one is the most work 😉

     

    First you have to "unpack" the AppImage:

    ./Ultimaker-Cura-5.0.0-beta+1-linux.AppImage --appimage-extract

    Then you can make the changes to the file(s) you want to change. After changing them, you run Cura with the following command:

     

    squashfs-root/AppRun

     

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 5.0 beta
    On 4/29/2022 at 3:36 PM, FlightRisk said:

    I'm curious to know which manufacturers are partners in some way. For example, Voxelab uses some form of Cura, do they not? Did they contribute in any way?

    None. We got a few pull requests from lulzbot in the past. That's it. I would love to have more companies contribute to Cura, as that would also make it easier for me to defend spending time on features that aren't priority for Ultimaker (since we would be getting something back for it).

    • Like 2
    Link to post
    Share on other sites

    Posted · Ultimaker Cura 5.0 beta
    3 hours ago, ahoeben said:

     

    That one is the most work 😉

    Always seems to be. 🙂

     

    3 hours ago, ahoeben said:

    First you have to "unpack" the AppImage:

    ./Ultimaker-Cura-5.0.0-beta+1-linux.AppImage --appimage-extract

    Then you can make the changes to the file(s) you want to change. After changing them, you run Cura with the following command:

     

    squashfs-root/AppRun

     

    Ah, yeah, I knew I could do that, and I already run it extracted anyway (toolhandle thing was a pretty simple fix) I was hoping you were going to reveal some magic solution where I could just 'git pull' (or diff/patch, rsync, etc... ) vs file by file replacement.

     

    I don't suppose the cura-build process has been super-simplified in the last 6 months? 😉

     

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 5.0 beta
    1 minute ago, DrLucasThompson said:

    I don't suppose the cura-build process has been super-simplified in the last 6 months?

    It hasn't

     

    1 minute ago, DrLucasThompson said:

    (toolhandle thing was a pretty simple fix)

    That sort of thing is what I was referring to as being fairly easy to patch.

    • Like 1
    Link to post
    Share on other sites

    Posted · Ultimaker Cura 5.0 beta

    i am not able to get the same result with Cura 5 and Cura 4.13.1 for the same part. Cura 5 does not allow me to have infill done, it keeps printing 2 walls and nothing inside.

    What should i check in Cura 5 parameters that influence this behaviour ? 

    Thanks.

     

     

    Capture d’écran 2022-05-02 à 11.41.23.png

    Capture d’écran 2022-05-02 à 11.41.32.png

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 5.0 beta

    @milcent, with reports like this project files are indispensable. Please use File -> Save project... to save a project and post a link to it here.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share


    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 12 replies
    ×
    ×
    • Create New...