Jump to content

Cura G-code not using {material_bed_temperature_layer_0}


benovitch

Recommended Posts

Posted (edited) · Cura G-code not using {material_bed_temperature_layer_0}

Hi,

 

As of this morning when starting a print my printer won't heat up the build late and the extruder. I looked in the G-code withe Note pad and saw that there is nothing filled in at the M104, M140, M109 and M190 commands.

Before this worked fine. The bed heats up, does a ABL probing, then heats up the extruder. And started printing

 

;FLAVOR:Marlin
;TIME:254
;Filament used: 0.0810043m
;Layer height: 0.2
;MINX:165.2
;MINY:171.2
;MINZ:0.2
;MAXX:184.8
;MAXY:178.8
;MAXZ:16
;Generated with Cura_SteamEngine 5.0.0
M82 ;absolute extrusion mode


M140 S{material_bed_temperature_layer_0} ; Start heating the bed to temperature
M190 S{material_bed_temperature_layer_0} ; Wait until the bed is at the desired temperature
M104 S{160}; Preheat Extruder

 

G28 ; Home all axes
G29;

G92 E0 ; Reset extruder

 

M104 S{material_print_temperature_layer_0}

 

G1 Z2.0 F3000 ;Move Z Axis up

G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position

 

M109 S{material_print_temperature_layer_0} ; Wait until the extruder is at the desired temperature

 

G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
G92 E0 ;Reset Extruder

 

This one is from before the problems started:

 

;Generated with Cura_SteamEngine 5.0.0
M82 ;absolute extrusion mode


M140 S60 ; Start heating the bed to temperature
M190 S60 ; Wait until the bed is at the desired temperature


G28 ; Home all axes
G29;


G92 E0 ; Reset extruder


M104 S220


G1 Z2.0 F3000 ;Move Z Axis up
G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position


M109 S220 ; Wait until the extruder is at the desired temperature


G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
G92 E0 ;Reset Extruder

Edited by benovitch
  • Link to post
    Share on other sites

    Posted · Cura G-code not using {material_bed_temperature_layer_0}

    Found the problem. I placed in the M104 command the preheat temp I want between { }. Tis trigered an error in the compiling

     

    M104 S {160}; Preheat Extruder

    should be

    M104 S 160; Preheat Extruder

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 27 replies
    ×
    ×
    • Create New...