Jump to content
xperiment

Cura verschliesst Öffnungen

Recommended Posts

Posted · Cura verschliesst Öffnungen

Folgendes Anliegen: Ein Objekt in Sketchup erstellt und im Boden eine Öffnung gelassen, die in das hohle Objekt führt.

Aber jedesmal wenn ich das Objekt in Cura lade, verschliesst er mir das Loch und produziert eine geschlossene Plattform am Boden! Egal welche Einstellung ich bei Cura ändere.

In der normalen Ansicht wird mir das Objekt zwar regulär angezeigt, jedoch sieht man den geschlossenen Boden in der Layer Ansicht :-(

 

Share this post


Link to post
Share on other sites
Posted · Cura verschliesst Öffnungen

schick mal die stl datei rüber und dann schauen wir uns das mal an,

nicht das schon ein fehler in der stl ist und deshalb das loch verschloßen wird.

ich habe bei meinen objekten löcher mit 0,6 mm durchmesser erfolgreich gedruckt

 

Share this post


Link to post
Share on other sites
Posted · Cura verschliesst Öffnungen

Kontrolliere doch mal, was in Cura unter Expert - Open Expert Settings... (oder CTRL + E) im Bereich 'Fix horrible' eingestellt ist.

Ich würde hier mal alle Hacken raus nehmen und dann nochmal überprüfen ob das Loch nun offen ist.

 

Share this post


Link to post
Share on other sites
Posted · Cura verschliesst Öffnungen

Alles schon probiert, ich druck es jetzt ohne Loch und bohr dann eins rein! Seit Stunden sitz ich daran!

Ist das Loch durchgängig, ist alles kein Problem. Aber ein Loch von unten in einen hohlen Raum ist wohl zu komplex ;-)

@Teddy: Das ist http://www.thingiverse.com/thing:31331

Ich wollte in die Bodenplatte halt ein Loch haben, damit ich dort Sand als Gewicht reinfüllen kann. Ich denke nicht das die Datei kaputt ist. Sketchup zeigt mir ja alles richtig an, auch Meshlab hat das Loch noch im Modell. Nur Cura verschliesst es in der Layer Ansicht! :-(

 

Share this post


Link to post
Share on other sites
Posted · Cura verschliesst Öffnungen

Falls es an der Definition der Lochöffnung liegt, könntest Du versuchen, das Modell 0.1mm o.ä. zu versenken (Offset-Feature) und so der CuraEngine eine bessere Ausgangslage zu verschaffen. Würde man kaum merken bei diesem Modell, oder?

 

Share this post


Link to post
Share on other sites
Posted · Cura verschliesst Öffnungen

Hey,

das Problem hatte ich auch schon bei diversen anderen Objekten. Meines Wissens gibt es da auch keine wirklich Lösung in cura,da das Objekt immer aus einer geschlossenen Hülle bestehen muss ( da die "wände" in 3D-Programmen faktisch keine Dicke besitzen).

Die einzige "Lösung" die ich für mich gefunf´den hatte,war das Objekt im 3D Programm Doppelwandig zu gestalten und dann mit infill zu drucken.

 

Share this post


Link to post
Share on other sites
Posted · Cura verschliesst Öffnungen

Wenn ich beim Loch quasi ein Rohr nach oben in den Hohlraum ziehe, wird lustigerweise das Loch richtig angezeigt, jedoch verschliesst Cura das Rohr dann oben beim Ende wieder. Das gibts doch nicht!

Gibt es noch Alternativen zu Cura?

 

Share this post


Link to post
Share on other sites
Posted · Cura verschliesst Öffnungen

Wenn ich beim Loch quasi ein Rohr nach oben in den Hohlraum ziehe, wird lustigerweise das Loch richtig angezeigt, jedoch verschliesst Cura das Rohr dann oben beim Ende wieder. Das gibts doch nicht!

Gibt es noch Alternativen zu Cura?

 

Wenn ich Dich richtig verstanden habe, bringt das mit dem Cut Offset in Cura auch nichts?

EDIT: Machst Du ein Loch irgendwo in die Oberfläche (sprich Löschen der Flächen) oder modellierst Du effektiv einen Hohlraum? Nur mit der zweiten Variante wird ein Slicer zurecht kommen...

 

Share this post


Link to post
Share on other sites
Posted · Cura verschliesst Öffnungen

Ich hab' das Ganze gerade mal in Blender probiert:

- original STL File importieren

- Modifier 'Solidify' darauf anwenden (hier gewünschte Wandstärke definieren)

Somit wird aus dem Vollkörper ein hohler Körper mit definierter Wandstärke.

Danach noch einen Zylinder vom Boden per Modifier 'Boolean' abziehen um somit das Loch rein zu modellieren.

Export als STL.

Das Ergebnis in Cura zeigt das gewünschte Loch.

Evtl. kann Blender hier mehr (oder arbeitet sauberer) als Sketchup.

 

Share this post


Link to post
Share on other sites
Posted · Cura verschliesst Öffnungen

Danke für eure Antworten und dem Tipp mit Blender. Leider sind Blender und ich nicht grad die besten Freunde ;-)

Aber für so´n Loch sollte es wohl reichen. Mal schauen..ansonsten nehme ich den DremeL, sollte für den Zweck reichen.

 

Share this post


Link to post
Share on other sites
Posted · Cura verschliesst Öffnungen

Hallo,

Meine Erfahrung dazu mit einem Rohr mit einseitigem Flansch:

Modell wurde in Trimble (Sketchup) erstellt

Ausdruck mit CURA und UMO+

Problem

Das Rohrende am Flansch wird verschlossen gedruckt, obwohl im STL - Modell offen dargestellt.

Sichtbar wird das in Cura wenn man die Schichten durchfährt

Abhilfe

Modell in Netfabb Basics laden und markieren

Unter Extras „New Analyses“ durchführen

In der Infospalte rechts werden „flipped Triangles“ angezeigt, werden auch im Modell mit anderen Farben angezeigt

Unter „Extras“ auf „Repair Part“ gehen, im Menü „Fix Flipped Triangles“ wählen und „Apply Repair“. Die Falschfarben verschwinden im Menü.

Unter „Part“ das Modell exportieren

Der Druck mit diesem Modell ist in Ordnung

Ursache: speziell bei Sketchup kann es sehr leicht passieren, dass die Oberfläche falsche Orientierung bekommt und man das nicht erkennt.

Share this post


Link to post
Share on other sites
Posted · Cura verschliesst Öffnungen

Hallo Zusammen

Ich vermute hier den Standard Fehler bei solchen Sachen. Du kannst nicht einfach ein Loch machen indem du ein Polygon löscht. Die wird Cura automatisch als Polygonfehler erkennen und verschliessen. Du musst das loch modellieren.

Polygone haben zwei Seiten eine innen und einen Aussenseite, dementsprechend ist auch dein Objekt aufgebaut. Wenn plötzlich ein Polygon mit der innen Seite nach aussen zeigt, ist das für Cura unverständlich und es probiert den schaden zu reparieren.

Grüsse

zpm3atlantis

Share this post


Link to post
Share on other sites
Posted · Cura verschliesst Öffnungen

Hallo,

ich habe da ein ähnliches Problem wenn ich einen Zylinder in Sketchup modelliere, nur das aber Cura den Zylinder oben nicht schliesst.

Auf dem Foto zu erkennen.

UGBAjZI.png

Der Zylinder ist nicht abgeschlossen. (Aussenwand zur Innenwand)

Wenn ich mir dies im Blender anschaue. Sieht dies gut aus.

7U9IfXC.png

Ich habe schon einige Zylinder in Sketchup modelliert, einige sind OK die anderen eben nicht. Ich modelliere sie immer gleich. Ich habe aber noch nicht herausgefunden warum es manchmal geht und manchmal nicht.

Share this post


Link to post
Share on other sites
Posted · Cura verschliesst Öffnungen

Hallo,

ich habe da ein ähnliches Problem wenn ich einen Zylinder in Sketchup modelliere, nur das aber Cura den Zylinder oben nicht schliesst.

 

Es kann an SektchUp liegen, das es defekte STL erzeugt. Der Wechsel auf ein anderes CAD wäre anzuraten. Ich verwende DesignSpark Mechanical. Das kostet nix und funktioniert ähnlich wie SketchUp, erzeugt aber vernünftige Dateien für Cura & Co.

Oder Du hast die falschen Einstellungen in Cura. Welche Version hast Du am laufen?

Die Wandstärke sollte immer ein vielfaches vom Düsendurchmesser sein, sonst kann es vorkommen das Cura das nicht richtig füllen kann.

Share this post


Link to post
Share on other sites
Posted (edited) · Cura verschliesst Öffnungen

Hallo,

ich benutze CURA 2.3.1. Die Wandstärke ist 1.05mm (standard). Ich werde mal das in DesignSpatk versuchen.

Leider gibt es DesignSpark Mechanical. nicht für Mac :O

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Cura verschliesst Öffnungen

und wie so kann nicht CURA ein Problem haben?

ich habe mir mein Modell in Blender nochmal angeschaut, und es scheint mir das die Polygone korrekt sind.

Q4Vx3JV.png

oder nicht?

In Cura aber so aussehen:

2ZsGpP9.png

Share this post


Link to post
Share on other sites
Posted · Cura verschliesst Öffnungen

und wie so kann nicht CURA ein Problem haben?

ich habe mir mein Modell in Blender nochmal angeschaut, und es scheint mir das die Polygone korrekt sind.

Q4Vx3JV.png

oder nicht?

In Cura aber so aussehen:

2ZsGpP9.png

 

Sicher kann auch Cura ein Problem verursachen.

Der Vergleich mit Blender und Cura kann aber nicht funktionieren. Blender ist ein 3D Programm, Cura zeigt die Daten aber als umgerechnetes Schichtmodell an. Was zeigt Dir Cura denn bei 100 InFill?

Share this post


Link to post
Share on other sites
Posted · Cura verschliesst Öffnungen

Hallo xperiment,

schau mal deine PN an, dort liegt ein Link für die STL-Datei mit Loch.

Grüsse aus Bayern

Harry

Share this post


Link to post
Share on other sites
Posted · Cura verschliesst Öffnungen

Was zeigt Dir Cura denn bei 100 InFill?

 

Das gleiche.

Ich habe jetzt meinem Kollegen den Auftrag gegeben das ganze in seinem Professional 3D Programm zu zeichnen. Das gleiche Programm benutzt er auch für Maschinen Teile zu zeichnen. Mal schauen wie diese dann in Cura aussehen.

Share this post


Link to post
Share on other sites
Posted (edited) · Cura verschliesst Öffnungen

Hallo Leute,

ich habe den Fehler mit der (Bohrung) rekonstruiert.

Objekt wurde mit Flächen erstellt und nicht als Körper.

Cura verabeitet das Objekt je nach Richtung ob liegend oder stehend ist.

Das gleiche Objekt wurde 3 mal geladen und nur die Lage verändert und das sieht so aus. Das erklärt warum die (Bohrung) verschwunden ist.

111.thumb.JPG.48f2678e6aeeb97eb2472ca764d12689.JPG

222.thumb.JPG.8f7fbfa91a4afb7c8089ee97f5524dd2.JPG

Bei Craft Ware sieht so aus.

333.thumb.JPG.a47834ed28196b8919b935e143b9f8ac.JPG

444.thumb.JPG.44b8334caa232b2466f5c26c5def89ae.JPG

Das Objekt kann durchaus in Ordnung sein, nur die Programme intepretieren sie unterschiedlich.

Und hier das Objekt.

https://drive.google.com/open?id=0B8SLtGEIZlAEcWw2NkREby01YUk

111.thumb.JPG.48f2678e6aeeb97eb2472ca764d12689.JPG

222.thumb.JPG.8f7fbfa91a4afb7c8089ee97f5524dd2.JPG

333.thumb.JPG.a47834ed28196b8919b935e143b9f8ac.JPG

444.thumb.JPG.44b8334caa232b2466f5c26c5def89ae.JPG

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Cura verschliesst Öffnungen

Bei den Beispiel von @Hallo sieht man das da was nicht stimmt, den die roten Flächen werden nur bei überhänge angezeigt und da ist es genau umgekehrt. Auch in der röntgen Ansicht sieht man ganz kleine rote Dreiecke die darauf hindeuten das die STL nicht ganz korrekt ist

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
        • Like
      • 96 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!