Jump to content

"Pause at Height" post-processing step is cooling down my extruder after resume


ckindall

Recommended Posts

Posted · "Pause at Height" post-processing step is cooling down my extruder after resume

Heya,

 

Not sure if this is the right place for this or not, but figured it'd be cool to get a little help if possible.

 

I've got the pause at height command set to a layer of my build using the M0 method, and all that's working fine and dandy. However, I noticed on resume of the pause that my hot end immediately cooled off and the print aborted.

 

Inspecting the gcode cura generated, I saw that instead of resuming the hot end temp after standby, it decides to drop it to zero.

 

;added code by post processing
;script: PauseAtHeight.py
;current layer: 12
M83 ; switch to relative E values for any needed retraction
G1 F300 Z4.640000000000001 ; move up a millimeter to get out of the way
G1 F9000 X190 Y190
G1 F300 Z15 ; too close to bed--move to at least 15mm
M104 S205 ; standby temperature
M0 ; Do the actual pause
M109 S0 ; resume temperature
G1 F300 Z3.64
G1 F9000 X117.463 Y113.386
G1 F300 Z3.64 ; move back down to resume height
G1 F1500 ; restore extrusion feedrate
M82 ; switch back to absolute E values
G92 E582.44268

 

Any idea why this is happening? I've sliced it a few times with a couple of different settings, but it doesn't really make a difference. As soon as I hit resume I have to be real quick about manually adjusting the temperature back.

  • Link to post
    Share on other sites

    Posted · "Pause at Height" post-processing step is cooling down my extruder after resume

    As a quick fix you can change that M109 line (after the M0) to M109 S205 or whatever your print temperature is.  

     

    In Cura, use the "File | Save Project" command and post the 3mf file here.  I use Pause at Height a lot and I've never seen that problem before.

  • Link to post
    Share on other sites

    Posted · "Pause at Height" post-processing step is cooling down my extruder after resume

    Yeah, it's simple enough to edit the gcode, but I'm curious why it would "resume" to 0 at all. Is my startup gcode not configured right? It's kind of a hobbled mess of copy paste stuff.

     

    I've attached the project file and the gcode sliced from this project, let me know what you think.

    CE3PRO_lizard_hole_tiny.3mf CE3PRO_lizard_hole_tiny.gcode

  • Link to post
    Share on other sites

    Posted · "Pause at Height" post-processing step is cooling down my extruder after resume

    Conflict between your two post-processors.

    Go into the post-processors you have active and move Pause At Height above Insert at Layer Change.  There is a conflict there and putting Pause at Height first resolves it.

     

    This looks like a bug to me.  The post-processors had some re-work done for the switch from 4.13 to 5.0 and maybe something got missed or was broken in the changeover.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 27 replies
    ×
    ×
    • Create New...