Jump to content
Ultimaker Community of 3D Printing Experts

SOLVED: Hotend & Bed Turn Off @ Start of Print


choder
 Share

Recommended Posts

Posted (edited) · SOLVED: Hotend & Bed Turn Off @ Start of Print

When slicing in Cura, and using the sliced file either on Octoprint or on the SD card directly in the printer, the hot end and bed turn off as soon as the print begins. 

The initial heat up process work perfect.  The bed heats, then the hot end heats.   I have been using simplify3d for years without issue and it still works.  I would really like to use Cura.

 

Machine: Flashforge creator pro

 

Cura sliced gcode file attached.

 

Startup printer gcode:

 

Here is the beginning of the gcode.

 

Any help would be appreciated.

 

;FLAVOR:Makerbot
;TIME:509
;MINX:-9.8
;MINY:-9.8
;MINZ:0.3
;MAXX:9.852
;MAXY:9.8
;MAXZ:19.9
;Generated with Cura_SteamEngine main
T1
M190 S60
M104 S210
M104 S210
M116
M82 ;absolute extrusion mode
; **** Replicator 1 dual start.gcode ****
M73 P0 ; enable build progress
G162 X Y F3000 ; home XY maximum
G161 Z F1200 ; home Z minimum
G92 Z-5 ; set Z to -5
G1 Z0 ; move Z to 0
G161 Z F100 ; home Z slowly
M132 X Y Z A B ; recall home offsets
M135 T1 ; load left extruder offsets
G1 X140 Y75 Z0.5 F800 ; move to wait position right hand side of the table
G130 X20 Y20 Z20 A20 B20 ; lower stepper Vrefs while heating
M126 S[fan_speed_pwm]
M140 S[bed0_temperature] T0
M134 T0 ; stabilize bed temperature
M104 S[extruder1_temperature] T1
M133 T1 ; stabilize left extruder temperature
G130 X127 Y127 Z40 A127 B127 ; default stepper Vrefs
G92 A0 B0 ; zero extruders
G1 Z0.4 ; position nozzle
M135 T1 ; left tool
G1 X135 Y75 Z0.2 F1200 ; move over bed
G1 X60 Y72 E20 F1200 ; purge nozzle
;G1 X50 Y72 Z0.2 F600 ; slow wipe
;G1 X50 Y72 Z0.5 F1200 ; lift
G92 A0 B0 ; zero extruders
M73 P1 ;@body (notify GPX body has started)
; **** end of start.gcode ****
M83 ;relative extrusion mode
G1 F1500 E-6.5
;LAYER_COUNT:50
;LAYER:0
M127 T0
;MESH:xyzCalibration_cube (1).stl
G0 F3600 X-9 Y-9 Z0.3
;TYPE:WALL-INNER
G1 F1500 E6.5
G1 F1800 X-9 Y9 E0.89802
G1 X9 Y9 E0.89802
G1 X9 Y-9 E0.89802
G1 X-9 Y-9 E0.89802
G0 F3600 X-9.4 Y-9.4
G1 F1800 X-9.4 Y9.4 E0.93794
G1 X9.4 Y9.4 E0.93794
G1 X9.4 Y-9.4 E0.93794
G1 X-9.4 Y-9.4 E0.93794
G0 F3600 X-9.8 Y-9.8
;TYPE:WALL-OUTER
G1 F1800 X-9.8 Y9.8 E0.97785
G1 X9.8 Y9.8 E0.97785
G1 X9.8 Y-9.8 E0.97785
G1 X-9.8 Y-9.8 E0.97785
G0 F3600 X-9.8 Y-9.6
G0 X-9.13 Y-9.13
G0 X-8.62 Y-8.62
;TYPE:SKIN
G1 F1800 X-8.62 Y8.62 E0.86011
G1 X8.62 Y8.62 E0.86011
G1 X8.62 Y-8.62 E0.86011

 

cube.gcode

Edited by choder
  • Link to post
    Share on other sites

    Posted (edited) · SOLVED: Hotend & Bed Turn Off @ Start of Print

    It looks like you copied that from SimpliFy3D.  Cura uses a different keywords and curly brackets.  When the gcode is created Cura understands the "M104 S" but doesn't understand the SimpliFy keywords in square brackets.  

     

     

    This line has to be hardcoded as Cura has no keyword in PWM.

    M126 S[fan_speed_pwm]

    You could change it to M126 S128 and your cooling fan would start at 50% speed.  An option would be to remove it and let Cura add the fan lines later.

     

    These two lines are wrong
    M140 S[bed0_temperature] T0

    M104 S[extruder1_temperature] T1

     

    Change them to:

    M140 S{material_bed_temperature_layer_0} T0

    M104 S{material_print_temperature_layer_0} T1

     

    That gcode looks to be for a single extruder print as T0 isn't called to heat up.  You might have to make further changes to insure that it's up to temperature for a print that uses it.  The Cura keywords are HERE.

    Edited by GregValiant
  • Link to post
    Share on other sites

    Posted · SOLVED: Hotend & Bed Turn Off @ Start of Print

    I have made the changes, but I am guessing it is something within the cura slicer settings not the start gcode. 

     

    Removed the fan set speed and changed the m140 and m104 commands.  

     

    it preheats normally.  Bed first then hotend.  But when the print starts, the bed, hotend and the filament extruder are all disabled.  It trys to print, but the fillimant will not extrude because the stepper is not turning and the bed and hotend just turn off.   The temps don't even show up in the monitor screen on the printer.  Once the print starts, the monitor temps just disapear on the screen.  ( I am assuming because it turns off).

     

    Thanks for the helpl

     

    Edited start gcode

    sliced cura attached.

     

    ; **** Replicator 1 dual start.gcode ****
    M73 P0 ; enable build progress
    G162 X Y F3000 ; home XY maximum
    G161 Z F1200 ; home Z minimum
    G92 Z-5 ; set Z to -5
    G1 Z0 ; move Z to 0
    G161 Z F100 ; home Z slowly
    M132 X Y Z A B ; recall home offsets
    M135 T1 ; load left extruder offsets
    G1 X140 Y75 Z0.5 F800 ; move to wait position right hand side of the table
    G130 X20 Y20 Z20 A20 B20 ; lower stepper Vrefs while heating
    M140 S{material_bed_temperature_layer_0} T0
    M134 T0 ; stabilize bed temperature
    M104 S{material_print_temperature_layer_0} T1
    M133 T1 ; stabilize left extruder temperature
    G130 X127 Y127 Z40 A127 B127 ; default stepper Vrefs
    G92 A0 B0 ; zero extruders
    G1 Z0.4 ; position nozzle
    M135 T1 ; left tool
    G1 X135 Y75 Z0.2 F1200 ; move over bed
    G1 X60 Y72 E20 F1200 ; purge nozzle
    ;G1 X50 Y72 Z0.2 F600 ; slow wipe
    ;G1 X50 Y72 Z0.5 F1200 ; lift
    G92 A0 B0 ; zero extruders
    M73 P1 ;@body (notify GPX body has started)
    ; **** end of start.gcode ****

     

    cube7.gcode

  • Link to post
    Share on other sites

    Posted (edited) · SOLVED: Hotend & Bed Turn Off @ Start of Print

    This is from the last gcode file you posted...

    ....
    M126 S[fan_speed_pwm]
    M140 S[bed0_temperature] T0

    .....
    M104 S[extruder1_temperature] T1

    .....

     

    There is a bug in the Machine Settings dialog.  After making changes to the StartUp Gcode you must click in the Ending Gcode box in order to save the settings.  Then you can close the dialog.

    No matter which you change (Start or End gcode) if you don't click on the other text box then the changes do not get saved when you close the dialog.  There is a bug report for this on GitHub.  This started in Cura 5.0 when the dialog boxes were changed from the Qt5 controls to Qt6 controls.

    So it appears that the StartUp gcode is the same as it was previously and Cura is not making the replacements from "Keywords" to "Settings Values".

    I think what is happening is that the printer is seeing a line like "M140 S[bed0_temperature] T0" which it can't understand and (in that case) is setting the bed to "0".  The same sort of thing is happening to the hot end temperature with that M104 line.

    You can check that by opening the gcode file and manually changing the lines to "M140 S60 T0" and "M104 S210 T1" and then try printing it again.  You can abort after it starts to print.

     

    Edited by GregValiant
  • Link to post
    Share on other sites

    Posted (edited) · SOLVED: Hotend & Bed Turn Off @ Start of Print
    2 hours ago, GregValiant said:

    There is a bug in the Machine Settings dialog.  After making changes to the StartUp Gcode you must click in the Ending Gcode box in order to save the settings.  Then you can close the dialog.

    No matter which you change (Start or End gcode) if you don't click on the other text box then the changes do not get saved when you close the dialog.  There is a bug report for this on GitHub.  This started in Cura 5.0 when the dialog boxes were changed from the Qt5 controls to Qt6 controls.

     

    That fixed it.  It now prints, but not very well.  The first layer is extremely under extruded but at about layer 23 in the attached gcode file the extruder just stops extruding. No filament gets extruded after line 23 (could be line22).  I don't know what to look for in the gcode where the extruder is told to stop.

     

    Edit, just tried printing again and the extruder just stopped at about layer 32 this time.  Nozzle is not plugged and its new.  Prints fine with simplyfy3d slicing right after. 

     

    Thanks.

    cube9.gcode

    Edited by choder
  • Link to post
    Share on other sites

    Posted · SOLVED: Hotend & Bed Turn Off @ Start of Print

    That gcode looks good.  After the print starts there is one hot end temperature M104 S210 line at line 348 in the gcode.  That may be a problem as it does not call out the Tool Number.

    If you haven't done so, go to the MarketPlace and load the "Printer Settings" plugin.  Then quit Cura and restart.

    Within "Printer Settings" is "Always Write Active Tool".  Enable that and try again.

     

    I've been assuming that you have two distinct extruders/hot ends and NOT a "multi-in-1 out" hot end.  If my assumption is wrong then there are a couple more settings for you to enable in Printer Settings.  "Extruders Share Heater" and "Extruders Share Nozzle" are for those "Multi-In - 1 Out" printers like the Geeetech M and T models.

     

  • Link to post
    Share on other sites

    Posted · SOLVED: Hotend & Bed Turn Off @ Start of Print

    No change.  When it starts to print line 23 it pauses very quickly, i can feel the print filament retract 1 or 2mm, and then it stops loading filament. 

     

    Yes I have two extruders, just like this.   Each one has a separate heating block and fan.  They are completely independent form each other besides being mounted on the same carriage. 

     

     

    Flashforge-Creator-Pro-Complete-Print-Head-Assembly-24316_1.jpg

  • Link to post
    Share on other sites

    Posted · SOLVED: Hotend & Bed Turn Off @ Start of Print

    Line 23 is part of your start gcode.  I didn't like it when I saw it but I figured hey, it worked with Simplify3d.

     

    It's "M140 S{material_bed_temperature_layer_0} T0"

    Delete the "T0".

    There is only one bed so there doesn't appear to be a need for T0 and it could be causing confusion in the printer/planner.

  • Link to post
    Share on other sites

    Posted · SOLVED: Hotend & Bed Turn Off @ Start of Print

    So I think I am close to figuring out what is happing.  Thanks for helping on this. 

     

    I did another small print.  At around Layer 35 or 36 the printer just stops extruding.  It started printing after a layer or so. See the attached picture of the print.  Along with the gcode file curascraper.gcode  

     

    I copied the below 6 lines from the terminal window of Octoprint when I noticed it stopped extruding.  I believe it was this underlined portion that caused this to happen.  

     

    Send: N19181 G1 X4.577 Y6.545 E0.05571*103

    Recv: ok

    Send: N19182 M105*36

    Recv: ok T:210 /212 B:60 /60 T0:50 /0 T1:210 /212 @:0 B@:0

    Send: N19183 G1 X4.851 Y7.373 E0.05802*103

    Recv: ok

     

    I looked at the Gcode from the attached curasraper.gcode and can't see anything around line 35 or 36 that cause this in the gcode, but it has to be there. 

     

    Here is my start gcode.  I don't think anything is wrong in here.

     

    ; **** Replicator 1 dual start.gcode ****
    M73 P0 ; enable build progress
    G162 X Y F3000 ; home XY maximum
    G161 Z F1200 ; home Z minimum
    G92 Z-5 ; set Z to -5
    G1 Z0 ; move Z to 0
    G161 Z F100 ; home Z slowly
    M132 X Y Z A B ; recall home offsets
    M135 T1 ; load left extruder offsets
    G1 X140 Y75 Z0.5 F800 ; move to wait position right hand side of the table
    G130 X20 Y20 Z20 A20 B20 ; lower stepper Vrefs while heating
    M140 S{material_bed_temperature_layer_0}
    M134 T0 ; stabilize bed temperature
    M104 S{material_print_temperature_layer_0} T1
    M133 T1 ; stabilize left extruder temperature
    G130 X127 Y127 Z40 A127 B127 ; default stepper Vrefs
    G92 A0 B0 ; zero extruders
    G1 Z0.4 ; position nozzle
    M135 T1 ; left tool
    G1 X135 Y75 Z0.2 F1200 ; move over bed
    G1 X60 Y72 E20 F1200 ; purge nozzle
    ;G1 X50 Y72 Z0.2 F600 ; slow wipe
    ;G1 X50 Y72 Z0.5 F1200 ; lift
    G92 A0 B0 ; zero extruders
    M73 P1 ;@body (notify GPX body has started)
    ; **** end of start.gcode ****

     

    Here is my end gcode. I think is fine.

     

    ; **** FlashForge Creator Pro PRINTER end.gcode ****
    M73 P100 ; end build progress
    G1 Z150 F1000 ; send Z axis to bottom of machine
    M140 S0 T0 ; cool down HBP
    M104 S0 T0 ; cool down right extruder
    M104 S0 T1 ; cool down left extruder
    M127 ; stop blower fan
    G162 X Y F3000 ; home XY maximum
    M18 ; disable stepper
    M70 P3 ; We <3 Making Things!
    M72 P1 ; play Ta-Da song
    ; **** end of end.gcode ****

     

    stops printing.JPG

    curascraper.gcode

  • Link to post
    Share on other sites

    Posted · SOLVED: Hotend & Bed Turn Off @ Start of Print

    Recv: ok T:210 /212 B:60 /60 T0:50 /0 T1:210 /212 @:0 B@:0

    That looks like the printer response to M105.  My guess is that Octoprint is sending "M105 T0 T1" and the "ok" part of the response indicates to Octoprint that the port is still open.

     

    I don't see anything in the gcode that could be causing the problem.  Usually when something like this happens there is an M104 or M109 (M133 for MakerBot) line that sets an extruder temperature to the Standby temperature which is too cool to print at.  That doesn't happen in your gcode.  The print starts with T1 and the only mention of T0 is to disable the fan at the start of Layer:0 and enable it at the start of Layer:1.  

     

    I save the ends of filament rolls for situations like this where something is occurring and I can't figure it out and it's driving me nuts.

    I changed my Home Offsets to make my Ender an Origin at Center printer and swapped out your starting gcode for mine.  The rest of this print is your gcode.  There were no extrusion stoppages but there was some funkiness on the backside.  I don't know what to make of that but the overhang was close to needing support.  After a couple of layers (which did extrude correctly) the print finished fine.

     

    The only thing I'm sure about here is:  If that is a window ice scraper then you have a really tiny car.

     

    DSCN2964.thumb.JPG.3263384acfd76d7c15f264d8e8271e27.JPG

     

     

     

     

  • Link to post
    Share on other sites

    Posted · SOLVED: Hotend & Bed Turn Off @ Start of Print

    Well I tried printing the x3g file created by cura direct on the my printer with the sdcard as my printer is a flashforge creator pro and runs on sailfish.  It natively prints x3g files from the sdcard.

     

    When it got the that line 39 or so, it paused very quickly but continued to print.   I reviewed the gcode file with octoprint and an online gcode view and you can see there are some weird dots, and this is where it pauses and stops extruding with octoprint.  It also pauses here with the x3g file from the sdcard.

     

    From my understanding the blue dot is the beginning of the printing sequence and the red is the end.   So there seems to be a start stop sequence in the middle at line 39 or so.

     

     I will have to trouble shoot this a bit more. 

     

    This is a scraper that takes a disposable blade to clean the glass on my aquarium.

    aquarium scrapper.JPG

    gcode2.JPG

    gcode.JPG

    back side.JPG

  • Link to post
    Share on other sites

    Posted · SOLVED: Hotend & Bed Turn Off @ Start of Print

    It looks like Layer 38 (Cura Preview) is the last full loop around the hole and Layer 39 is the first horseshoe shaped path.

    Could it just look like a hesitation there?  It's where the head has to stop and move back around to the other side of that opening that develops.

  • Link to post
    Share on other sites

    Posted · SOLVED: Hotend & Bed Turn Off @ Start of Print

    Thanks for you your help!

     

    So I figured it out!   The printer profile I was using had a 6mm retraction setting at 20mm / sec.  In simplify3d I use 2mm @ 42mm/sec.   This long slow retraction of 6mm was causing the problem.  Those blue and red dots from the previous posts are the retractions. 

     

    I was able to print with 2mm retractions at 42mm/sec, both the cube and scraper successfully without issue and the over hang printed fantastic with the scraper.  

     

    I know have a pretty decent profile for my flashforge creator pro.  Simplify3d was getting long in the tooth, especially with Cura and Prusaslicer adding a number of new features and plugins.   

     

     

     

     

    PXL_20220810_201632235_791x1050.jpg

    PXL_20220810_201419620_791x1050.jpg

    • Like 1
    Link to post
    Share on other sites

    Posted · SOLVED: Hotend & Bed Turn Off @ Start of Print

    I was going to ask you for a project file next.  That isn't to say I would have found that but from 2 to 6 is a jump.

     

    There was a poster here who was wondering why the prints were so slow.  After going back and forth with a couple of comments he produced a project file.  7mm retraction at 1mm/sec.  So his prints were spending 14 seconds on every retraction.  No wonder they were slow.

     

    Congrats on figuring out your problem.

    • Thanks 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 13 replies
    ×
    ×
    • Create New...