Jump to content

Wird auf ein mal nicht mehr gedruckt.


Stefan-B

Recommended Posts

Posted · Wird auf ein mal nicht mehr gedruckt.

Folgendes problem.

Von Cura  geslicte modelle lassen sich nicht mehr drucken. Die datei wird auf Speicherkarte geschrieben aber nicht mehr gedruckt auf zwei Druckern.

Habe drei Speicherkarten und das selbe problem. Aber die alte dateien auf den Speicherkarten lassen sich aber drucken.

Über USB Verbindung kan ich drucken.

Habe selbst andere (4.13.3/5.0/5.1) Versionen probiert,das problem bleibt. Die dateien auf den Speicherkarten sind am Drucker und PC sichtbar,ganz normal.

  • Link to post
    Share on other sites

    Posted · Wird auf ein mal nicht mehr gedruckt.

    Du könntest die Dateien vergleichen, also die ersten Zeilen ob es da Unterschiede gibt.

     

    Der richtige Drucker ist in Cura ausgewählt?

  • Link to post
    Share on other sites

    Posted · Wird auf ein mal nicht mehr gedruckt.

    Start Code

    M92 Z403.54
    G90 ; use absolute coordinates
    M140 S[first_layer_bed_temperature] ; set bed temp
    M190 S[first_layer_bed_temperature] ; wait for bed temp
    G28 ; home all without mesh bed level
    M420 S1
    M104 S[first_layer_temperature] ; set extruder temp
    G92 E0.0
    G1 Y-2.0 X150 F2400G1 Z3 F720
    M109 S[first_layer_temperature] ; wait for extruder temp
    G1 X150 F1000
    G1 Z0.2 F720
    G1 X80.0 E8.0 F900
    G1 X20.0 E10.0 F700
    G92 E0.0
    M221 S95 ; set flow

     

    Drucker ist richtig aus gewählt.

    Hab mal Prusa Slicer getestet, da druckter über Speicherkarte.

  • Link to post
    Share on other sites

    Posted · Wird auf ein mal nicht mehr gedruckt.

    Alles runter und wider drauf gemacht und das gleiche problem.

    Dan hab ich ein anders Model mit Cura ferig gemacht ohne was an Cura zu ferändern und das ging dan.

    Was ist da falsch ?

  • Link to post
    Share on other sites

    Posted (edited) · Wird auf ein mal nicht mehr gedruckt.

    PrusaSlicer uses different keywords and square brackets as replacements in the Start and End gcodes.  That is keeping your hot end and bed from heating.

    Here is the list of Cura Keywords.

    The ones you will want to change are:

    M104 S{material_print_temperature_layer_0}

    M109 S{material_print_temperature_layer_0}

    M140 S{material_bed_temperature_layer_0}

    M190 S{material_bed_temperature_layer_0}

    Note that they are in curly brackets.

    Edited by GregValiant
  • Link to post
    Share on other sites

    Posted · Wird auf ein mal nicht mehr gedruckt.

    Die datei macht probleme.

     

    Was ist damit?

    Ist mit Fusion360 erstellt

    Tüten Saug Adapter v11.3mf

  • Link to post
    Share on other sites

    Posted · Wird auf ein mal nicht mehr gedruckt.

    The models are fine with no errors.  I think the problem is in your StartUp Gcode.

    When Cura sees M104 S[first_layer_temperature] it doesn't know what to do with it because the words are in "Prusa" instead of "Cura" and Cura doesn't use square brackets.  That means neither the hot end nor bed temperatures get set and the printer won't print because there is a safety to keep it from cold extruding.

     

    With the model loaded in Cura and ready to slice use the "File | Save Project" command.  It will create a 3mf file with your printer and your settings as well as the model.  Post that new 3mf here.  Post one of your gcode files as well.  More information is a good thing.

     

    I can slice the models you posted and print them on my Ender but that doesn't help you.  I believe the problem is in your printer definition and/or startup gcode.

  • Link to post
    Share on other sites

    Posted · Wird auf ein mal nicht mehr gedruckt.

    Prusa war nur zum Testen da.

    Ich hatte am Curaproviel nicht geändert. Mit einer anderen 3mf datei ging es ja.

    EE_Tüten Saug Adapter v8.gcode

  • Link to post
    Share on other sites

    Posted · Wird auf ein mal nicht mehr gedruckt.

    Das gleiche Proviel nur andere 3mf und die will er Drucken.

    Verstehe ich nicht🤔

    EE_ER-20_Fan_Duct.gcode

  • Link to post
    Share on other sites

    Posted · Wird auf ein mal nicht mehr gedruckt.

     

     

    M140 S55        >
    M105               >
    M190 S55       >
    M104 S190     > Cura adds these lines because it does not understand [first_layer_bed_temperature] as it is a Prusa
    M105               > keyword and not a Cura keyword
    M109 S190     >

    ---------------

    M82 ;absolute extrusion mode
    M92 Z403.54
    G90 ; use absolute coordinates
    M140 S[first_layer_bed_temperature] ; set bed temp          >
    M190 S[first_layer_bed_temperature] ; wait for bed temp  >  In PrusaSlicer this line would say "M190 S155" but in Cura it passes through as "M190 S[first_layer_bed_temperature]" because it is not a Cura keyword.  When you print the file that's what the printer sees.  It then goes onto the Firmware how it reacts to that illegal line.  My older Marlin firmware would ignore it because it is an invalid command.  Your firmware might decide that "first_layer_print_temperature" is = zero and that will cause the printer to not extrude.

    There is also a typographical error in this line:

    G1 Y-2.0 X150 F2400G1 Z3 F720

    That should be two lines as:

    G1 Y-2.0 X150 F2400

    G1 Z3 F720

    So it looks like someone copied an pasted the Startup Gcode from PrusaSlicer to Cura.  That doesn't work well.

     

    Here is the "Duct" gcode back.  I made changes to the temperature lines and fixed the typo.  Try to print it.

     

     

    GV_ER-20_Fan_Duct.gcode

  • Link to post
    Share on other sites

    Posted · Wird auf ein mal nicht mehr gedruckt.

    Der Code hat nix mit Prusa zu tun. Ich Slice nur mit Cura. Prusa Slicer war nur zum Testen da ob es am PC oder Speicherkarte liegt.

    Drucker sind Eryone ER20.

  • Link to post
    Share on other sites

    Posted · Wird auf ein mal nicht mehr gedruckt.

    This is the StartUp Gcode for an Eryone ER20 from the Cura printer definition file:

    G21 ;Metric values

    G90 ;Absolute positioning

    M82 ;Set extruder to absolute mode

    M107 ;Start with the fan off

    G28 ;Homing the hotend

    G29 ;Auto bed leveling detecting

    G92 E0 ;Reset the extruded length

    G1 F200 E3 ;Extrude 3mm of filament

    G92 E0 ;Reset the extruded length again

    G1 Y-3 F1200 ;Move y axis to prime

    G1 X150 F6000 ;Move x axis to prime

    G1 Z0.2 F720 ;Move z axis to prime

    G1 X80.0 E8.0 F900 ;Prime line

    G1 X20.0 E10.0 F700 ;Prime line

    G92 E0 ;Reset the extruded length

    G5 ;Enable resume from power failure

    M117 Printing...

     

    This is your StartUp Gcode from the Duct file that also says ";Generated with Cura_SteamEngine main":

    M82 ;absolute extrusion mode
    G90 ; use absolute coordinates
    M140 S[first_layer_bed_temperature] ; set bed temp
    M190 S[first_layer_bed_temperature] ; wait for bed temp
    G28 ; home all without mesh bed level
    M420 S1
    M104 S[first_layer_temperature] ; set extruder temp
    G92 E0.0
    G1 Y-2.0 X150 F2400G1 Z3 F720
    M109 S[first_layer_temperature] ; wait for extruder temp
    G1 X150 F1000
    G1 Z0.2 F720
    G1 X80.0 E8.0 F900
    G1 X20.0 E10.0 F700
    G92 E0.0
    M221 S95 ; set flow

     

    What is happening is that you have a PrusaSlicer StartUp Gcode in your Cura installation.  I don't know how that happened but it won't work.  You need to make the changes I described earlier.

    On the Cura menu bar select "Settings / Printer / Manage Printers" and then "Machine Settings".  Look in the StartUp Gcode box.  You will see what I am talking about.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.8 beta released
        Another Cura release has arrived and in this 5.8 beta release, the focus is on improving Z seams, as well as completing support for the full Method series of printers by introducing a profile for the UltiMaker Method.
        • 1 reply
      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
        • 3 replies
    ×
    ×
    • Create New...