Jump to content
UltiMaker Community of 3D Printing Experts

Internal Geometry appearing on top and bottom layers


Taco_Bob
 Share

Recommended Posts

Posted · Internal Geometry appearing on top and bottom layers

Hello, I'm creating checker pieces with embedded magnets using the pause at height extension.  The internal cavity's geometry is affecting how the bottom layer and the first layer above the cavity is printed such that the layer above the cavity will print on nothing in the gap above the magnet.  See picts.  

 

Model x-ray:

x-ray.png.4888d727e871854af77e2c210f2ff122.png

 

Bottom Layer:

802121479_layer1.png.c2e97845ef8e3c015977f20412b2c9b1.png

 

Second layer:

2024666112_Layer2.png.2a80fcb6986babdc1ebdc871855f208c.png

 

First layer above cavity, might drop into it:

1370278520_disconnectedtop.png.29444954d6d86df09764ce6bf2695523.png

 

In Cura 4.2.1, I somehow changed settings so that this would not happen, but I can't find that setting. 

 

Same model, 1st layer above cavity in 4.2.1:

image.png.38a82cd7bd9d537ba25a197bf38aa82f.png

 

I'd just use 4.2.1 but the pause at height feature doesn't work for me, 5.1.0 is better.  I see that some of the settings in 5.1.0 are labeled differently.  

 

Does anyone know how to get the top/bottom layers to not be affected by internal geometry?  As is, the first layer above the cavity won't be connected to the cavity wall.

 

Thanks for any help!

Checker 25.obj

  • Link to post
    Share on other sites

    Posted · Internal Geometry appearing on top and bottom layers

    Hey @Taco_Bob,

     

    I recognize this issue. We have a known bug with Union Overlapping Volumes in Cura 5.0 and 5.1
    But if I try with Cura 4.13 I get this printjob without any changes:

    image.thumb.png.0adcfac8e9ab4b05da348ea26a8c4fd5.png

    Can you try Cura 4.13.1 for me? 
    You can get it here:
    https://github.com/Ultimaker/Cura/releases
     

  • Link to post
    Share on other sites

    Posted · Internal Geometry appearing on top and bottom layers

    In 4.X you might have to make sure that remove empty first layers is unchecked.  In 5.X they hid that setting so you are screwed.  I assume because the hollow for the magnet is too close to the bottom of the print.

  • Link to post
    Share on other sites

    Posted (edited) · Internal Geometry appearing on top and bottom layers

    Hello @Taco_Bob

    Try setting your "Top Surface Skin Layers" to 0 or 1.  (I'm using 5.2beta.)

    This is Top Surface Skin Layers at "2".

    image.thumb.png.90da20f14b6f5e14b38ab66492c375bd.png

     

    This is with it set to "1".

    image.thumb.png.132c112a2ace92c292f6c57c350185b9.png

     

     

    Edited by GregValiant
  • Link to post
    Share on other sites

    Posted · Internal Geometry appearing on top and bottom layers

    Thank you all.  Now I know what to call it thanks to MariMakes.  As it turns out, the version of Cura on my Raspberry pie has the pause at height features of 5.1 and doesn't have the union overlapping problem.  It's 4.(something) so that works, might be 4.13 actually.  It actually slices faster and better than the versions on my Win10 machine where I'm having these issues, go figure.  Its probably faster because Microsoft is so clodgey.

     

    Thanks!

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    ×
    ×
    • Create New...