Jump to content
UltiMaker Community of 3D Printing Experts

Cura on Arch Linux won't open my file explorer/web browser


yacinbm
 Share

Recommended Posts

Posted · Cura on Arch Linux won't open my file explorer/web browser

Hi!

 

I just recently installed the flatpack version of Cura on my Arch Linux PC and I'm having a pretty "game breaking" bug. After installing Cura, I tried to slice a sample 3D model, but whenever I click "Open File", nothing happens. I also tried signing into my Ultimaker Account, but when I click "Sign in", nothing happens either. My default file explorer is Dolphin and my default web browser is Chrome. That being said, when I drag/drop a file into Cura, it slices correctly, but once again, when I try to click "Save to Disk" nothing happens, and I cannot save the output GCode...

 

I also tried installing the non-flatpack version of Cura, but the same thing happened. I even tried re-installing my whole operating system, and still, nothing works. My other applications on my PC do not show this behaviour, which makes it even weirder.

 

If you have any suggestions, or need any additional details, please, let me know 🙂

Cheers!

  • Link to post
    Share on other sites

    Posted · Cura on Arch Linux won't open my file explorer/web browser

    Hey @yacinbm,

     

    Welcome to the Ultimake Community 🚀

    I recognize your issue 🤔


    We've had more linux users report issues with opening on our Cura github 
    https://github.com/Ultimaker/Cura/issues/12266

    I'm personally not a linux user so I don't know which of the comments in the thread are helpful. 
    Just know that we've added a ticket to the backlog with the intent to improve this. 

    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    ×
    ×
    • Create New...