Jump to content

Big Problem with Software Update

Go to solution Solved by AlexanderSamuel,

Recommended Posts

Posted (edited) · Big Problem with Software Update

Good evening everyone.


I recently aquired a used UM3.

When I connected it to my WiFi, is asked me if I wanted to upgrade firmware... I said YES without questioning the offer. Then the problems started:


- It downloaded an update and installed ist. When it went into the reboot, it never came past "Ultimaker" in the display. Jog-wheel didn't light up. Totally stuck. Repeated power cycles did not help.


- So, I opted for the Recovery process as described in the Ultimaker website. I downloaded recovery Image um-restore- and did as instructed. The install process does not start - green LED constant on, no yellow lights - only "Ultimaker" in the display, nothing else happens.


- I hunted the internet for older recovery images - found these: 

    - recovery- --- not working

    - UM3_recovery- --- not working


Finally found one image that did work:

   - UM3_recovery-

Install process runs fine - printer back up and running. However this firmware is really old and Cura doesn't recognize the printer on the network and it doesn't like the original Ultimaker filaments and the gcode processed via Cura will not run on the UM3.


I then tried updating via USB stick - as instructed on the UM website... for old firmware (4.3.3 and earlier)... selected 4.3.97 and the same thing happened: stuck on reboot!!


Can someone please point me in the correct direction?


Thanks a lot - kind regards,





Edited by AlexanderSamuel
  • Link to post
    Share on other sites

    Posted · Big Problem with Software Update

    Hi Alex,

    this sounds weird, but regarding to your description, you've done a lot of research and know what you're doing.

    When you write the recovery images are not working, I suppose download was ok, but they didn't recover your UM3?

    Do you know which firmware version your UM3 was before the "update"?

    Perhaps @gr5 or @CarloK have some solution for you.



    • Thanks 1
    Link to post
    Share on other sites

    Posted · Big Problem with Software Update

    Thanks a lot for your answer, Enigma_M4!


    I wanted to try a serial terminal session to the Olimex board, but realized that my 3.3Volt level shifting RS232/USB cable never came back home from a friend, who borrowed it ages ago! 😄


    I ordered a new one and hope that it will arrive end of next week. 

    Instructions on how to re-partition the internal storage seem to be promising. 

    I‘ll keep you updated. 



  • Link to post
    Share on other sites

    Posted · Big Problem with Software Update

    So the USB-Serial cable arrived today and has worked just fine...


    I logged the serial output when installing the 5.3 image from uSD-Card.

    The first error occurs, when it says:

    Unable to output image: '/umsplash_png.fb' to: '/dev/fb0'.
    Checking for updates ...
    Attempting to mount '/dev/mmcblk0p1'.
    [    5.070676] F2FS-fs (mmcblk0p1): Magic Mismatch, valid(0xf2f52010) - read(0x2000)
    [    5.078259] F2FS-fs (mmcblk0p1): Can't find valid F2FS filesystem in 1th superblock
    [    5.089403] F2FS-fs (mmcblk0p1): Magic Mismatch, valid(0xf2f52010) - read(0x2005)
    [    5.096948] F2FS-fs (mmcblk0p1): Can't find valid F2FS filesystem in 2th superblock
    [    5.104665] F2FS-fs (mmcblk0p1): Magic Mismatch, valid(0xf2f52010) - read(0x2000)
    [    5.112199] F2FS-fs (mmcblk0p1): Can't find valid F2FS filesystem in 1th superblock
    [    5.119873] F2FS-fs (mmcblk0p1): Magic Mismatch, valid(0xf2f52010) - read(0x2005)
    [    5.127372] F2FS-fs (mmcblk0p1): Can't find valid F2FS filesystem in 2th superblock
    [    5.143897] EXT4-fs (mmcblk0p1): mounted filesystem with ordered data mode. Opts: (null)
    No update image 'um-update.swu' found on '/dev/mmcblk0p1', tryin[    5.204089] F2FS-fs (mmcblk0p2): Magic Mismatch, valid(0xf2f52010) - read(0x5d60)
    g next.
    Attempting to mount '/dev/mmcblk0p2'.
    [    5.213846] F2FS-fs (mmcblk0p2): Can't find valid F2FS filesystem in 1th superblock


    If I read gr5s instructions correctly, that would indicate that something is wrong with my uSD card? (mmcblk0) and I should get another one?


    Can someone confirm this?


    Thanks a lot,



  • Link to post
    Share on other sites

    • Solution
    Posted · Big Problem with Software Update



    Hello everyone!


    I managed to get my printer up and running again! Here is what I did:


    Turns out that the error messages were misleading. No bad flash memory and no corrupted uSD!

    The actual install process went through without any problems! With the 4.3.3 recovery image and with the 5.3 recovery image.


    However: the problem here was that the installers always messed up the contents of the i2c Eeprom on the Olimex board.


    As described in @gr5s guide, I had to run the command (for my UM3)

    python3 /ulti_installer/configure_eeprom.py 9066

    and then reboot the printer.

    After that the operating system knows that is running on a Ultimaker 3 and everything is fine!


    As (and this is also described by gr5) the software versions 5.x don't have the python script included in the images anymore you have to extract this from a older version. I copied mine from the 4.3.3 installation via SCP. Note that you have to activate "Developer Mode" on the printer in order to do this!


    Interestingly, the Eeprom fix does not seem to be persistent with me: after installing 4.3.3 and running the python script the printer was ok. When updating to 4.3.97 it was broken again.. fixed it again and the upgraded to 5.3... broken again... and fixed it again. 


    Maybe the next update will break it again, so I will keep the serial cable in the Ultimaker draw, together with a USB stick containing the python script! 🐵


    By the way: @gr5 , the download for the script on your website does not work. Maybe you want to fix that?


    Many thanks - I learned a lot the last days.




    • Like 2
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 4 replies
    • Create New...