Jump to content
UltiMaker Community of 3D Printing Experts

Cura won't open on Macbook air

Recommended Posts

Posted · Cura won't open on Macbook air

I am unable to open Cura after downloading on a MacBook air with 12.6 monterey... I've tried re-installing/restarting numerous times. It downloads it but just won't open it. Any help is appreciated

  • Link to post
    Share on other sites

    • 4 weeks later...
    Posted · Cura won't open on Macbook air

    Hey @dah8829,


    Welcome to the Ultimaker Community 🎉

    Sorry, it took us a while to get back to you 😞 

    Are you still stuck?
    This version of MacOS should be supported so I would love to have someone from the Cura team take a look. 

    Was it working before or has this version of Cura not worked on your device yet?
    Can you share your Cura version and perhaps a little more about your set-up? 
    Do you for example have multiple monitors attached? 

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Our picks

      • New here? Get ahead with a free onboarding course
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    • Create New...