Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
brictone

Marlin Layer Shifting with latest version

Recommended Posts

I have been experimenting using the Marlin firmware and for the most part it works. I used the second version available in the repg firmware update, that says layer shifting fixed. The problem with that one is it seemed to make the printer vibrate quite a bit on the perimeter of objects. So I went to github and downloaded and compiled what I thought was the latest and most stable version. The date on it was Nov 3rd I believe.

I just relaunched the same gcode with that new firmware and it must have shifted on both the X and Y axis about 15 times throughout. I tried turning up the voltage from the board so now it's just over half way and I'm still getting shifting.

Is there a better recommended version available that I should be using? github is crazy confusing to me. Should I be using version 3 in the repg firmware update? I tried putting that firmware on last night and got an error when clicking upload and that was as far as I have gotten.

Update:

I initially was printing at 100mm/sec and since I've tried 75mm/sec with the same results.

.1mm layer height

Share this post


Link to post
Share on other sites

Hi

Maybe check all your settings by typing M501 into your RepG and pressing 'Build'

Then check against your settings here http://wiki.ultimaker.com/Marlin_firmware_for_the_Ultimaker

Also check your belts, and X & Y Motor Mounting. I found mine to be loose and jumping the first time I sped up printing.

I find Github a bit confusing too.

I got my last version from Nov. 3 and I have had 1 unexpected slip on the Y.

Hope this helps. Sorry for any obvious stuff you already know.

Owen

Share this post


Link to post
Share on other sites
Well I ran M501 and compared them to the site and I get to this point on the wiki and it says...

 

Below is a matrix of values for various configurations:

[To be done]

nothing... So what are these values supposed to be mine are all default and I'm using sf40+

This is what I've been looking for myself lately. You made me find it. Thanks.

https://groups.google.com/d/msg/ultimaker/jzFDsHy0XVc/MzVXUxBNlcwJ

This is fairly relevant, maybe write down what your current settings are before trying any changes.

Owen

Share this post


Link to post
Share on other sites

Yeah I spent all day trying to get this firmware to work reliably and it's not doing it for me. I brought the printer inside so it's warm, greased it up, made sure it's still lined up, tuned the pots. I couldn't get a perfect non shift. I ended up reducing the voltage closer to default.

I noticed in the controls it doesn't matter how fast you set anything it just goes at what seems like max speed. I slowed down the speed in my print, and it just made weird speedups during infill area. I don't know enough about this firmware stuff to know what was happening. I finally found a version on github from oct 18th and put that on my ultimaker so we'll see how that goes.

It doesn't seem to be making the crazy vibrations it was before. So that's good. we'll see if it shifts...

Edit:

yup still shifting. I don't know... maybe I'll just go back to the good ol' fashioned default firmware

Share this post


Link to post
Share on other sites

Yes the versions of marlin in the repG firmware area are very old and still have skewing issues.

Git isn't so difficult for those not interested in setting up git on their system. Just download the arduino IDE then go to the marlin git page and click "downloads", the select the "download as zip". Extract that somewhere and sartup the Arduino IDE. Load the Marlin.PDE file. Under tools->board pick arduino mega 2560. Click the play button to compile it then click upload (second button from the right)

It may need you to specifiy a serial port. Then it will tell you if the upload was successful.

Hope that helps.

Also you probably (if you haven't already) may need to upgrade the motors to the larger nema 17 ones.

-b

Share this post


Link to post
Share on other sites

Does the machine make a "grinding" noise when operating?

Mine couldn't handle the speed and was jumping the belt on the Y axis... the belts were pretty tight too. The newer machines have a torque-y motor. I ended up taking the machine apart and polishing the brash bushings inside with 320 grit wrapped around a dowel. It should slide effortlessly . I also removed the "sticky" lube (which will get WAY worse in cold weather) and used a sewing machine oil.

I am still trying to find the sweet spot with Marlin...

Good luck!.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

[[Template core/front/global/_customFooter does not exist. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!