Jump to content

Temperature setting goes to 240"C on start of printing


spucky

Recommended Posts

Posted · Temperature setting goes to 240"C on start of printing

Hello,

 

i am using the new Creality K1 MAX printer.

So far everything works. I have created different profiles for the filament i am using.

 

The slicing works, but once i start the print, the printer seem to ignore the temp settings. 

Independent from what i  have set in Cura, the printer heats the hotend up to 240°C but the bed down to 50°C 

 

I can adjust ist on start of the print, but i would expect that Cura is setting the temperature in GCODE properly 

 

This is the start of the GCODE, as shown the print temperatures are in:

 

;FLAVOR:Marlin
;TIME:1666
;Filament used: 3.74721m
;Layer height: 0.2
;MINX:113.118
;MINY:130.906
;MINZ:0.24
;MAXX:179.801
;MAXY:169.105
;MAXZ:48.04
;Generated with Cura_SteamEngine 5.4.0
M140 S60
M105
M190 S60
M104 S195
M105
M109 S195
M82 ;absolute extrusion mode
M140 S0
M104 S0
START_PRINT EXTRUDER_TEMP=[material_print_temperature_layer_0] BED_TEMP=[material_bed_temperature_layer_0]
G92 E0
G92 E0
G1 F3000 E-0.6
;LAYER_COUNT:240
;LAYER:0
M107
M204 S6000
G0 F9000 X117.199 Y135.737 Z0.24
M204 S2000
;TYPE:SKIRT
G1 F3000 E0

Would be great if somebody knows a solution for it.

Other slicers like Prusa or the Creality own application ( a fork of an earlier Cura version) work fine.

  • Link to post
    Share on other sites

    Posted · Temperature setting goes to 240"C on start of printing

    Just looking at the Hot End lines you have:

    M104 S195
    M109 S195

    M104 S0

    These next lines are for some other intermediate gizmo.  It's possible that these aren't reacting properly since these are the lines that are actually supposed to set the temperature.

    START_PRINT EXTRUDER_TEMP=[material_print_temperature_layer_0] BED_TEMP=[material_bed_temperature_layer_0]

    If those were M104 or M140 then Cura would replace the variable names with the temperature values.

    It's also possible that the single line should be two lines like;

    START_PRINT EXTRUDER_TEMP=[material_print_temperature_layer_0]

    BED_TEMP=[material_bed_temperature_layer_0]

     

    Anyway, I think that's where you need to look but do a search through the gcode file for M104 and M109 and see if there are any that set the hot end to 240°.

  • Link to post
    Share on other sites

    Posted (edited) · Temperature setting goes to 240"C on start of printing

    Thanks for your reply.

    I've checked the whole GCODE file.

    M104 and M140 are only used one more time at the end to set the temperature to 0 after the print is finished. No other occurance somewhere else.

    M109 is only given on the part of the code shown above.

     

    This custom GCode is in the printer settings, not at the extruder.

    Should I put it there?

    Edited by spucky
  • Link to post
    Share on other sites

    Posted · Temperature setting goes to 240"C on start of printing

    Quick update

    Tried it putting the commands in one line each, didn't work

     

    The printer started again with 240 °C until i set it down to the 210 as defined in the profile.

  • Link to post
    Share on other sites

    Posted · Temperature setting goes to 240"C on start of printing

    I'm thinking it could be a problem with the printer's profile in Cura generating incorrect gcode. Just looked and Cura 5.4.0 doesn't seem to include a profile for it. Can you upload/post/link to the profile you're using?

  • Link to post
    Share on other sites

    Posted · Temperature setting goes to 240"C on start of printing
    3 hours ago, Slashee_the_Cow said:

    Can you upload/post/link to the profile you're using?

    Correct, the printer isn't yet included in the Cura settings.

    This is the profile i am using:

    https://forum.drucktipps3d.de/forum/thread/27510-creality-k1-profile-für-cura-prusa/#post312788

  • Link to post
    Share on other sites

    Posted · Temperature setting goes to 240"C on start of printing

    When you get old you miss tricks...

    In these two lines change the square brackets [PrusaSlicer] to curly brackets {Cura}.

    START_PRINT EXTRUDER_TEMP=[material_print_temperature_layer_0]

    BED_TEMP=[material_bed_temperature_layer_0]

     

    to

    START_PRINT EXTRUDER_TEMP={material_print_temperature_layer_0}

    BED_TEMP={material_bed_temperature_layer_0}

     

    That startup is redundant though.  There is no reason to heat the machine up and then turn it off just so you can heat it up again.

    Experiment (2) would be to comment these lines out by placing a semi-colon in front of them.

    ;M140 S0

    ;M104 S0

    ;START_PRINT EXTRUDER_TEMP=[material_print_temperature_layer_0]

    ;BED_TEMP=[material_bed_temperature_layer_0]

     

    That allows the initial M104 and M109 to do their thing and the printer should understand that.

     

  • Link to post
    Share on other sites

    Posted · Temperature setting goes to 240"C on start of printing

    Damnit @GregValiant you beat me to it. That custom start gcode is WACK.

    Here's one generated from your profile:

    M140 S0 ; Set target temperature of bed to 0 degrees
    M104 S0 ; Set target temperature of extruder to 0 degrees
    START_PRINT BED_TEMP=60 EXTRUDER_TEMP=200 ; I'm not great at Marlin but I'm guessing these set variables, not sure if it works with two on one line though and they're never referenced again
    G92 E0 ; Specify that the current extruder position is 0 (which it probably is already)
    G92 E0 ; Why do this twice?
    G1 F3000 E-0.6 ; Set the extruder to -0.6 (is it trying to be a vacuum?)

     

    Compare to the default profile for an Ender-3 S1 (I messed up my profile for the regular Ender-3 when I tried to customise it for my v2 Neo so this should be close enough). Admittedly I have no idea what the difference between that and the K1 is. Anyway:

     

    ; Ender 3 S1 Start G-code
    ; M413 S0 ; Disable power loss recovery
    G92 E0 ; Reset Extruder
    
    ; Prep surfaces before auto home for better accuracy
    M140 S60 ; Start heating bed - n.b. for this print I did set the bed to 60 and extruder to 200
    M104 S200 ; Start heating extruder
    
    G28 O ; Home all untrusted axes
    G1 Z10.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed < It's about to move and we don't want it to scrape the bed
    G1 X0 Y0 ; Move to the front-left corner of the plate
    
    M190 S60 ; Wait for bed to finish heating to 60
    M109 S200 ; Wait for extruder to finish heating to 200
    
    ; This code is when it wipes its nose along one side of the bed so hopefully anything caught on the hotend comes off and just gets it flowing
    G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position
    G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
    G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
    G1 X0.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line
    
    G92 E0 ; Reset Extruder
    
    G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
    G1 X5 Y20 Z0.3 F5000.0 ; Move over to prevent blob squish

     

    IMHO You're probably better off just using a Creality profile that comes with Cura for the printer most similar to yours. Or at the very least just customise the profile for the K1 and replace its start code with one from another Creality printer, the default profiles are all found at C:\Program Files\UltiMaker Cura 5.4.0\share\cura\resources\definitions

  • Link to post
    Share on other sites

    Posted · Temperature setting goes to 240"C on start of printing

    Ya gotta get up pretty early in the morning to beat me.

    (Some folks have to stay up all night!)

     

    Those two lines are not Marlin commands.  The printer might understand them...PrusaSlicer might understand them...Octoprint, or the "Creatlity interface" thingy might understand them, but the "Replacement Pattern" variable name  must get replaced.  It won't get replaced as written because Cura doesn't acknowledge the square brackets.

  • Link to post
    Share on other sites

    Posted (edited) · Temperature setting goes to 240"C on start of printing

    Thanks for your great suggestions.

     

    The K1 is indeed different to an Ender 3

    I had an Ender 3 S1 before and selected that printer and modified it. That ended up in a mess.

     

    The lines in the K1 start configuration are used also in Creality Print, the forked Cura 4.whatever version made by creality. They have K1 profiles in there. 

     

    The GCODE flavor set there is "NebulaPad" (whatever that is)

    image.thumb.png.cfef8fca6e7bf37abccdfdca1ab3f4b5.png

     

    And this is the part where the GCODE is documented:

    image.thumb.png.a081e9e0f37757036c84debc99888418.png

     

    I would really appreciate getting the things working on my Linux machine. Even if Crealty has a version which can be launched on Linux, the slice process quitted the whole application with a memory access fault. So it simply can't be used. 

     

    And running a virtual machine with Windows just for that is like killing flies with a flame thrower.

    I will try commenting out the start code and see what happens to the printer then. But i think i need to keep the "START PRINT" command. From what i understand is that the reference line (on the very left of the printer) is made here, before it starts with the print itself.

     

    But it still doesn't answer the question why 240°C is selected and not any other value. This is far away from the extruder capabilities (300°C)

    Edited by spucky
  • Link to post
    Share on other sites

    Posted · Temperature setting goes to 240"C on start of printing

    Quick Update after more testing.

     

    neither changing to {} brackets nor commenting out solves the problem.

    The print starts with 240°C and only gets down by manually changing it.

     

    Next attempt will be exchanging the variables with fixed values. Seem to be that Cura is getting an override by the printer which isn't covered by the material setting.

     

    But even 210 would be better than the given 240 which makes at least skirt and first layer too high until it cools down to the correct temperature

     

    But more tomorrow. Now it's already late 🙂

  • Link to post
    Share on other sites

    Posted · Temperature setting goes to 240"C on start of printing

    Another try.  (I hope we're getting closer.)

    This should be 3 lines (with curly brackets):

     

    M140 S0

    M104 S0

    START_PRINT

    EXTRUDER_TEMP={material_print_temperature_layer_0}

    BED_TEMP={material_bed_temperature_layer_0}

     

    A test results in:

     

    ; Ender 3 Custom Start G-code
    ;
    START_PRINT
    EXTRUDER_TEMP=235
    BED_TEMP=83
    M104 S235
    M140 S83
    M109 S235
    M190 S83
    G92 E0 ; Reset E

  • Link to post
    Share on other sites

    Posted · Temperature setting goes to 240"C on start of printing

    Hi everyone! Just stumbled upon this topic. I have been experiencing the same issue with my K1 Max and Cura. I used this guide to set up the printer: https://sainsmart.s3.us-east-1.amazonaws.com/Creality K1/Cura/Creality_3D_K1_docking_cura_slice_software_operation_manual.pdf but it didn't help with the temperature so I just deleted everything in the Start G-code section and it works. I hope it helps:) My settings are attached in an image below, and some sample g-code here:

    ;FLAVOR:Marlin
    ;TIME:20205
    ;Filament used: 72.8304m
    ;Layer height: 0.52
    ;MINX:80.74
    ;MINY:80.743
    ;MINZ:0.25
    ;MAXX:219.257
    ;MAXY:219.258
    ;MAXZ:225.18
    ;ARCWELDERPROCESSED
    ; Postprocessed by [ArcWelder](https://github.com/FormerLurker/ArcWelderLib)
    ; Copyright(C) 2021 - Brad Hochgesang
    ; Version: 1.2.0, Branch: master, BuildDate: 2021-11-22T09:56:32Z
    ; resolution=0.05mm
    ; path_tolerance=5.0%
    ; max_radius=9999.00mm
    ; allow_dynamic_precision=True
    ; default_xyz_precision=3
    ; default_e_precision=5
    ; extrusion_rate_variance_percent=5.0%
    ;Generated with Cura_SteamEngine 5.4.0
    M140 S60
    M105
    M190 S60
    M104 S220
    M105
    M109 S220
    M82 ;absolute extrusion mode
    G92 E0
    G92 E0
    G1 F2400 E-0.5
    ;LAYER_COUNT:433

     

    Знімок екрана 2023-10-06 о 14.11.25.png

  • Link to post
    Share on other sites

    Posted · Temperature setting goes to 240"C on start of printing

    If this is what it takes to get Creality printers to work, I might start to regret buying an Ender-3 v2 Neo.

  • Link to post
    Share on other sites

    Posted · Temperature setting goes to 240"C on start of printing

    It doesn't have to be completely empty.  So long as the temperature(s) aren't mentioned Cura will add the temps to the "prepend" section before the startup.  You could still have purge lines if you wanted.

    Printers with auto-leveling systems usually fair better if they aren't drooling during the auto-level routine.  Limiting the temperature while leveling and then moving up to printing temperature is the tricky part.

     

  • Link to post
    Share on other sites

    Posted · Temperature setting goes to 240"C on start of printing
    31 minutes ago, GregValiant said:

    Printers with auto-leveling systems usually fair better if they aren't drooling during the auto-level routine.  Limiting the temperature while leveling and then moving up to printing temperature is the tricky part.

    Tricky or slow, pick one. I just set mine to get the bed to printing temperature, auto level, then start heating up the nozzle. Only added about 7 minutes to the startup sequence compared to the default.

  • Link to post
    Share on other sites

    Posted · Temperature setting goes to 240"C on start of printing

    Hi, I had the same issue with my new K1 and you helped me a lot! 

     

    Curly brackets solved the issue for me, the variables are now getting exchanged correctly. Removing everything from the start g-code caused my printer to heat up and then stop the print, removing just the EXTRUDER_TEMP and BED_TEMP lines made the printer heat up, calibrate and then stop the print.

     

    My settings: 

    Bild_2023-10-13_230945740.png

  • Link to post
    Share on other sites

    Posted · Temperature setting goes to 240"C on start of printing

    Is there a way to make these changes automatic in Cura?

    Running a K1C

  • Link to post
    Share on other sites

    Posted (edited) · Temperature setting goes to 240"C on start of printing

    You will have to figure out what the firmware wants to see and how it will interpret it.  There is a support group for the K1 over on Reddit.  That might be your best bet.  I hate to guess - and I'd be guessing.

     

    "START_PRINT EXTRUDER_TEMP" is not a gcode command but rather something (the name of a macro???) that Creality might have put into their firmware (Klipper might want to see the same sort of thing).  

    Edited by GregValiant
  • Link to post
    Share on other sites

    Posted · Temperature setting goes to 240"C on start of printing
    4 hours ago, GregValiant said:

    "START_PRINT EXTRUDER_TEMP" is not a gcode command but rather something (the name of a macro???) that Creality might have put into their firmware (Klipper might want to see the same sort of thing).  

    Newer Creality printers like the K1C and E3V3 run "Creality OS" which is built on top of Klipper.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.8 beta released
        Another Cura release has arrived and in this 5.8 beta release, the focus is on improving Z seams, as well as completing support for the full Method series of printers by introducing a profile for the UltiMaker Method.
          • Like
        • 1 reply
      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
    ×
    ×
    • Create New...