Jump to content

Issues during the installation of Cura from the source code


Recommended Posts

Posted · Issues during the installation of Cura from the source code

Hi all,


I am trying to follow the procedure posted in https://github.com/Ultimaker/Cura/wiki/Running-Cura-from-Source to install  Cura in my windows 10 machine. However, I got some problems. This is what I have when I run step3 of the procedure.


in my PowerShell, after typing in 

conan install . --build=missing --update -o cura:devtools=True -g VirtualPythonEnv

, it installed several packages but eventually stopped here in showing the issue:

FileExistsError: [WinError 183] Cannot create a file when that file already exists: 'C:\\.conan\\a0bdb4\\1\\build\\Release'
ERROR: pyarcus/5.2.2: Error in generate() method, line 94
while calling 'build', line 33
        self._conanfile.run(cmd, cwd = self._conanfile.source_folder)
        ConanException: Error 1 while executing "sip-build"

I tried to by pass it via the following two steps:

  1. I went to in the venv folder (\my_cura_venv\Lib\site-packages\sipbuild and opened project.py
  2. in line 604, change os.mkdir(self.build_dir) toos.makedirs(self.build_dir, exist_ok=True)


By doing this, the error will not show up. However, after bypassing the error above, when I ran the command in step3, I encountered another issue:


> "sip-build"
These bindings will be built: pyArcus.
Generating the pyArcus bindings...
Generating the pyArcus .pyi file...
The project has been built.
pyarcus/5.2.2: Aggregating env generators
pyarcus/5.2.2: Calling build()
pyarcus/5.2.2: ERROR: Package '46f4cc8d5d301cf7f04473c21ba4cacf2020349f' build failed
pyarcus/5.2.2: WARN: Build folder C:\.conan\a0bdb4e\1\build\Release
ERROR: pyarcus/5.2.2: Error in build() method, line 103
        cmake = CMake(self)
        ConanException: CMakePresets.json was not found in C:\.conan\a0bdb4e\1\build\Release\generators folder. Check that you are using CMakeToolchain as generator to ensure its correct initialization.


The issue is fundamentally related to the missing file "CMakePresets.json", I tried to create one and placed in the generator folder, but when I ran the command in step3 again, I can identify that the file is firstly deleted then the same error (this file is not found) showed up again. I tried different methods but still got the problem. 


Can anyone help me on this? Thank you so much!









  • Link to post
    Share on other sites

    Posted · Issues during the installation of Cura from the source code

    There are several helpful people who have built Cura.  I guess I'd direct message nallath.  He can be extremely helpful at times.


    Or you can try posting in github issues.  That's more meant for bugs but this is sort of a cura issue.  Or you might be able to direct message people on github.  I'm not sure how to tell the developers from the other people - I guess by if they have contributed code.


    Nallath I'm sure is very busy and doesn't see every message directed his way but a direct message through this forum might work.




    There are people triaging these that may hide your issue, or may send it to someone helpful.



    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.4 stable released
        The full stable release of UltiMaker Cura 5.4 is here and it makes it easier than ever to remove brims and supports from your finished prints. UltiMaker S series users can also look forward to print profiles for our newest UltiMaker PET CF composite material!
          • Like
        • 58 replies
    • Create New...